Log in to reply
 

Most mods don't work


  • Banned

    I have the latest scripthook, community .net scripthook, so before you tell me to check those let me explain a few mods that work:

    • any trainers (eg Jedijosh's)
    • Openinteriors

    But tons of script mods don't work. I can reload them with Insert but nothing changes.

    Things like "one man army" for example, the key bound in the .ini does absolutely nothing.

    Help?? :)


  • Banned

    This post is deleted!

  • MODERATOR

    @BikerJohnny Out of curiosity, do you use vehicle mods?



  • @BikerJohnny FIrst question... have you tried changing the key bound in the One Man Army ini file to something else? I say that just to identify if it's a specific key that is not triggering, or the mod in general.

    My next suggestion would be to get one of the mods that doesn't work, like One Man Army and use just that mod. The first thing that springs to mind, is one of the mods might be disabling the controls all the time, which might be preventing another mod from using certain other controls.

    There's a function called DisableAllControls(), which basically blocks everything, one of the mods might be doing that and causing the problem. If you remove everything apart from One Man Army, that might get things on the right track. That's based on my limited knowledge of what that function does mind you. Scripthook might still expose those controls to other mods under its control, so that's just a speculative guess.


  • MODERATOR

    @LeeC2202 In my experience, scripts are still able to use controls that are disabled (Game.IsControlPressed). But if a script is trying to use Game.SetControlNormal or SetControlValue to simulate an input but the control is disabled, it won't work. Sorry for going off topic OP.



  • @stillhere Ah, good to know, thanks.


  • Banned

    Thanks for the replies.

    • No I don't use vehicle mods - I mainly use .asi mods that affect the game world, stuff like Disarm, sometimes gang warfare stuff etc.

    • I've tried to narrow it down but it's not simply one mod. It appears to be tons of scripts. I change the bindings in the .ini files but nothing triggers. so I don't think it's a key binding issue.

    • but what's weird is I've tried two trainers - the basic one you get with scripthhook and Jedijosh's, both work flawlessly

    • Anything requiring OpenIV works

    It's strange as this is a new problem. I've had scripts just stop working, and I have everything required installed.

    I ran Rageplugin.exe and it says "these files are blocked by windows" - I've disabled my antivirus. What exactly is being blocked and how? Where can I check this? As that's the only lead I have.

    Thank you for the responses guys. I love my mods but they haven't always been broken.


  • Banned

    My INIs are all blank! WTF?

    I've checked to see if the DLLs are blocked by windows but they're not. I'm going to re-download and re-install everything bar GTA itself.



  • @BikerJohnny Please provide a screenshot of your root GTA V folder


  • Banned

    Fixed it

    When installing a .dll or .ini based mod you need to right click for properties and click Unblock

    Windows 10 seems to be blocking DLL files

    alt text


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.