Log in to reply
 

Problem with tunings...



  • I have something around 120 add-on cars in my game I think,just know I have a lot ok kkkkkkk. They all have working tunigns,lights,bla bla bla,whatever. The thing is,even they all have working tunings and none of them have conflicting ids.still the newer GTA V cars lose tuning if my add-ons are enable (Sultan RS,good part of the low riders,Elegy Custom,etc...). Why that happens? Is there a way to make them all work together? Because Im sure none of my add-ons have conflicting IDs,I already investigated that



  • As many of us have discussed in other threads about modkit IDs, there are some things you need to be aware of.

    ModKit IDs are only 8-bit numbers, that means that any number over 255 is meaningless, as it will only use the lower 8-bits anyway.

    As an example, your ID of 984 isn't really 984, it's 216.

    This is 984 as binary - 11 1101 1000

    Only the numbers in bold are used as those are the lower 8 bits. 1101 1000 in decimal is 216 and that's what your ModKitID translates to. So all those numbers like 766666666 and 911111111 actually end up as 170 and 199.

    Then there is the fact that the ID your car is given in the game, is usually different to the ID you set in the documents. As another example, I have a car with an ID of 254, yet if I spawn that car in the game, it actually has an ID of 235.

    And then there is the load order of the addon pack to consider, which also changes whether an ID works or not. If you look in setup2.xml, you will see a line like this:

    <order value="25" />

    The game addon packs have load orders that run up to 25. If you set your load order on your addon to a number earlier than that, you might cause some IDs to stop working and others to start working. If you set the order later than 25, again, you may change which IDs work and don't work.

    ModKit IDs are complex, unreliable and inconsistent from one person to the next. What works for you, might not work for someone else. And just when you think you have it all worked out, you will discover that everything you thought you knew, is possibly not what the game is doing at all.
    (something i saw and helped me with this problem,i also had it with the youga classic yesterday but i fixed it)


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.