Log in to reply

Scripthook stops game from working

  • Hey guys,

    I have the problem that ScriptHookV stops GTA from working. Everytime I am in the loading screen (with all the pictures and music and stuff) I get the following error:

    Error. Please reboot and restart the game.

    When I delete all the scripts form the scripts folder it works perfectly fine. Here is what I tried.

    • Installed the latest scripthook and scripthook.net
    • Tried different scripts to verify, that it's not an error caused by a certain script
    • Reinstalled the openiv asi loader
    • Googled like 10 hours to find a solution

    The Scripthook log file always looks similar to this:
    [20:30:16] [DEBUG] Instantiating script 'SinglePlayerApartment.Brain' in script domain 'ScriptDomain_5890E0AB' ...
    [20:30:16] [DEBUG] Started script 'SinglePlayerApartment.Brain'.
    [20:30:16] [DEBUG] Instantiating script 'SinglePlayerApartment.EclipseTower' in script domain 'ScriptDomain_5890E0AB' ...
    [20:30:16] [ERROR] Failed to instantiate script 'SinglePlayerApartment.EclipseTower' because constructor threw an exception:
    System.IO.FileNotFoundException: Die Datei oder Assembly "INMNativeUI, Version=, Culture=neutral, PublicKeyToken=null" oder eine Abhängigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.
    Dateiname: "INMNativeUI, Version=, Culture=neutral, PublicKeyToken=null"
    bei SinglePlayerApartment.EclipseTower..ctor()

    If anybody knows what to do I would really appreciate your help.

    (Sorry for all the German sentences I hope you understand it anyway) :)

  • The log gives you the answer. You forgot to install IMNativeUI.dll which comes along with the SPA mod.

  • @Cyron43 Well I have it installed. It comes with the mod. So it can't be that. :/

  • @TheViper1198 The log clearly says that IMNativeui.dll could not be found. Have you placed it into the scripts folder? Also make sure the version matches. V1.6.1.0 is expected.

  • i'm getting the same problem but my game will actually load and i can play for like 2-3mins but it crashes after that.

    exact same scripthook log on mine too :( and I made 100% sure that the INMNativeUI was in the scripts folder

  • @lemonbrahz Yeah that really sucks. :/

  • @TheViper1198 I've just reinstalled and slowly adding my most used mods haha

  • @TheViper1198 @lemonbrahz singleplayerapartment will most likely need to be updated for 1103. Alot of people have problems with that mod not to mention you will lose 20-25fps just with that mod installed.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.