Log in to reply
 

What's special about this in-game Location ?



  • Hi,

    I have a little (or big?) problem and I'm not sure how to exactly write this Question..
    But, what is special about this in-game location? Game Files, Events, Spawn or whatever ...
    alt text
    It seems that my game crashes 90% of the time when I drive in that direction entering "Del Perro" ...
    Sometimes it happens a few feet earlier and sometimes a little past this highway sign...

    At first I thought it was my add on cars, but since the crash only seems to appear here I'm starting to doubt that...
    I can literally trigger the "The Game has stopped working" Error by driving that part of the road into the City...
    And if the Game does not crash the first time, I just turn around and drive there again and it crashes on "second try"

    I do have a few mods and add-on cars, but none of them seem logical to me that they cause this..

    In the past I did have random crashed at various locations that indeed where related to a typo in my carvariations file But II triple checked every single add-on car one by one.. None of them causes any crashes when I use my test-popcycle (that spawns only one car for testing issues)

    As said: This crash happens at this specific location in this direction when I just drive around (no mission etc.)


  • MODERATOR

    @Sabrina2001 do you have any map mods installed or any script mods that affect the Del Perro area?



  • @nathanjamesddg151

    No, absolutely no Map Mods or Map Edits.

    Script Mods I have installed are:
    Speedometer and Location Info (seen in the corner of the screenshot)
    Longer Days (In-Game Time Script)
    Indicator / Turn Signal Mod
    GPS Speech Mod
    ScriptHook (most recent update)
    Open Interiors

    Other Mods:
    Make Visuals Great Again (but I modified some settings in visualsettings and timecycle myself)
    1 DLC with addon Cars
    Modified gameconfig for supporting addon cars and slightly more overall traffic (i copied values from files available here)
    modified popcycle and popgroups to spawn add-on cars in traffic
    Add-On Plates
    Modified most of my Radio Stations

    This should be a full list of installed and running mods.
    I also checked this error again and again I played without crashed since posting this, but as soon as I drove this stretch of the road "GTA 5 has encountered an error" Sadly launcher log is no help on this either...

    The Game is installed on a WD Blue SSD.


  • MODERATOR

    @Sabrina2001 I think the issue has to do with an improperly edited popcycle or popgroups file. I can't remember which, but one of those (or both) have the game split up into regions, so to speak, which allow the game to spawn traffic and whatnot. It is hard to explain, but try and replace those with the default GTA ones and see if your game crashes. If that does fix it, you need to look into those data files in the Del Perro section and see what was improperly edited.



  • @nathanjamesddg151
    It's the Popcycle.dat file that splits into the regions
    In fact Popcycle has three sections for "Del Perro" called "Del Perro" / "Del Perro Beach" / "Del Perro Prom"

    I did however check that file multiple times for errors (restored default values and started from scratch 2 times) ..
    I don't believe the Error is still there..

    Using the default file(s) would maybe temporarily work, but then my addon cars would no longer spawn ...
    But I seriously consider your option if I don't find the cause of the error and start from scratch once again...
    Funny thing is, that if I enter del perro from any other road (or drive within del perro) I don't get any errors... Even when I advance time with the Native Trainer (and therefore cycling thru the popcycle timespans ..)


  • MODERATOR

    @Sabrina2001 maybe it's one of the scripts, either it's been corrupted with a new update, or it's interfering with one of the data files. My guess would be the GPS Speech or the Location and Speedometer mod.



  • @Sabrina2001 My suggestion is, if using a default file will not make the game crash, then use a default file and use another mod like the Addon Vehicle Spawner In Traffic or Lively World's traffic injector feature to spawn those vehicles in traffic.


  • Banned

    @Sabrina2001 It could be this -

    Do you have any replacement vehicles? I have a lot, and used to get crashes. What it could be, is that you have say a replacement vehicle that did NOT come with tuning parts, and an entry in popgroups that spawns the vehicle in this area. If it spawns said replacement in this area with vanilla tuning parts, your game crashes. What I did to eliminate any possibility of this ever happening (and it doesn't), is I edited "modkits" in vehiclemodelsets.meta to a value of -1. Never had a crash again.



  • @eshenk
    Thanks for that tip.
    All Vehicles I have added are added as "Add-On", so I didn't replace any of the original vehicles.
    Most of these come with the "0_default_modkit" but a few also have their own modkits..
    And actually this is what I kinda believe too, that there is 1 vehicle with error, that the game tries to spawn in "Del Perro" ....
    I just hope I find it...

    @nathanjamesddg151
    I check on updates for these..
    Thanks for letting me know that these scripts may also be the cause of error.. Since they run constantly I never assumed the error to be there... And the GPS Speech thing was rather glitchy anyways (saying things like leave freeway in Vinewood Hills) so I guess I'm gonna kick that one out for good now :D

    Another thing I considered:
    Does anyone know what exactly "Fragment Store" does?
    Somewhere in the depths of the many GTA forums I found someones suggestion to lower that value if random crashes occur. I did that (I have it increased over the vanilla values because of addon cars)
    When I lowered this value it seems the crash moved from Del Perro to Burton :p
    So I may also consider to get back to the Gameconfig stock value (or download a completed one from here and just redo my Population increase)

    I feel like a complete Idiot with this -.-
    I did just a few things at the same time and now I don't know where the error is..

    But I safely assume the "popcycle" and "popgroups" files are ok. I admit they are highly customized, but they don't affect the "Del Perro" Error...
    That one started a little before I made any changes to popcycle for Del Perro

    MANY THANKS again for your suggestions!!
    What I try to do next is :
    revert the Gameconfig (or use a ready one from here) and see what happens..
    I check (and remove) any scripts, especially those mentioned above..
    And I recheck my addon cars.. Good thing is, that not all my cars are set to spawn in "Del Perro" so I can narrow it down a little ...

    If I get any closer or get more infos I can provide, then I'll post them later



  • Update:
    I can rule out Gameconfig! I tried various files (a few downloaded from here)
    I can rule out popgroups.dat and popcycle.dat (also tried edit, mostly vanilla and started from scratch etc)
    I can rule out Location Script and Speedometer Script. I completely removed the GPS Speech.

    But Special Thanks to @eshenk ! While your tip didn't fix the issue, it removed tuner parts in traffic. Something I wanted to do a long time ago, so at least got something out of my error :D



  • Good News:
    I'm 99% sure I found and fixed the error(s).
    I'm not sure if all the steps counted towards this, but in any case (and if anybody reads this in a few weeks/months)

    1. I have removed one Add-On Bus. With Popgroups/Popcycle I had set it to spawn as part of the "Del_Perro_Prom" Region
      It seems that I triggered the spawn always around this highway sign, which in turn crashed the Game..
    2. I increased the Fragment Store Value in "gameconfig" again.
    3. For the removed Bus I now added two more Cars (One R* Vanilla Car and One Add-On Car) to my popgroups to be spawned around Del Perro

    Before that I also did what @eshenk suggested about the tuner parts.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.