Log in to reply
 

Hi, I can't get any scripts running, help please : (



  • Ok, so I am having trouble getting scripts to run.

    I have installed Scripthook V with the native trainer and ScripthookDotNet.
    Scripthook V and the native trainer it comes with seem to work fine. I have windows 10 and the correct version of visual c++ thanks to the post by someone with a similar issue (HueyPilot0014 ) the post with the most replies I believe...

    I'm running the latest GTA V (version 1.0.1103.2 on Steam) and I updated OpenIV, ScriptHookV, ScriptHookVDotNet. Here are the logs:
    asiloader log >>> https://pastebin.com/arViBp1v
    ScriptHookV log >>> https://pastebin.com/runKysw5
    ScriptHookVDotNet2 log >>> https://pastebin.com/S2kqWVCZ

    I have tried these 3 different scripts to no avail

    I have put Don't_Writhe.dll in my main directory folder
    I have put BulletCam.dll in my main directory folder
    & I have put CPR.dll in my main directory folder

    I am sure I am missing something simple...
    Is the scripts folder neccessary or is it just for tidiness or something openiv related?

    I apologize if the formatting is bad, this is my first post. I have trying to solve this on my own the past few days. And I mean most of my day was spent trying to figure this out. And if I don't figure this out soon, I am going to lose my mind and gtav irl. LOL jk, but seriously. This is really a pain in the ass.

    Alright, I'm going to bed. Thanks, and for the life of me lets figure this out, pleassssssse.



  • @tobcvb

    .NET scripts go into the scripts folder. These are the mods that rely on ScriptHookVDotNet. Scripts ending with a .asi extension go into the main folder.



  • Could you please explain why I have to make a separate scripts folder and put things in that folder? Do my log files look OK? I tried to make my post informative like you asked so I can get this solved. Thank you very much, anyhow. You seem to be doing a lot for these forums.
    Anyway, I have already tried throwing them in the scripts folder, and I spelled it out exactly like 'scripts'.



  • @tobcvb said in Hi, I can't get any scripts running, help please : (:

    Could you please explain why I have to make a separate scripts folder and put things in that folder?

    ScriptHookVDotNet simply works like that. Here: It's just hard-coded to look in the scripts folder.

    In that folder, it looks for files with the .cs, .vb and .dll extensions.

    Do my log files look OK?

    Yes, everything looks fine. Since you don't have anything in the scripts folder, ScriptHookVDotNet indeed doesn't load much. Simply moving your .dll script mods to /scripts should do the trick.

    I tried to make my post informative like you asked so I can get this solved.

    Thank you for that, it makes helping a lot easier :P



  • OK, gonna give it a shot again. BRB. You're the bomb, btw.



  • OK, it works!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    I don't know what is different but it works now. Could of sworn I tried it last night. I think it is because as I mentioned above I had only recently gotten the the right visual c++ (as I wrongly thought having the most up to date visual c++ was enough). And also the scripts folder thing. No one really said that it was necessary or why, so that was confusing. And trust me it isn't just me, I'd be willing to help make a list of the problems I ran into on my way to this point to help other people, because I think a lot of people had similar issues to what I have or thought what I was thinking. Again, thank you so much. You are a saint.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.