Log in to reply
 

Script hook v and script hook dot net



  • I cant seem to get this to work. I have stuff correctly installed like i installed the scripthook and the script hook dot net files in the right folders and the framework i updated too even tho i didnt have to since i have win 10 and also installed the redistributed 2013 64bit all correctly. The game doesnt crash or anything like that but i cant get any trainers to work. So maybe its the gta 5 version?

    Currently my launcher states my version as 1.0.231.0 | 1.0.1103.2 | 1.2.1.9 | 1.0.1103.2 | FFP
    Is that the correct version for the latest script hook v?



  • also the community dot net download page it said i could change the reload script button from insert to soemthing else in the ini file but where would the ini file be located? it doesnt seem to have a ini file with the dot net files



  • Please follow the format laid out in here.

    Is an asiloader.log generated?
    Is a ScriptHookV.log generated?
    Is a ScriptHookVDotNet2.log generated?
    Which scripts are you trying to get to work?



  • @ikt no logs are generated. like my game runs fine with those files installed and put in the main directory, but stuff like my trainer doesnt work. Ive tried so many things to fix i dont know what to fix is my version i listed up there the correct version?



  • Yeah, 1103.2 is the latest.

    Are you very sure the following files are there?

    • dinput8.dll - asi loader, generates asiloader.log
    • ScriptHookV.dll - script hook, generates ScriptHookV.log
    • ScriptHookVDotNet.asi - ScriptHookVDotNet loader
    • ScriptHookVDotNet2.dll - .NET runtime, generates ScriptHookVDotNet2.log

    Also check if your AV isn't blocking things.



  • @ikt i dont think its my antivirus disabled it all together and still nothing. This is what im getting. Im running the digitally downloaded version from the social club. could that be the reason? i mean i have other scripts in scripts folder but i dont think its loading it? Also i dont know how i got this log file i cant seem to get it again or replace the one i have. This is apparently from last night around midnight. also is there a hook v dot net ini file cause the latest one doesnt come with ini

    // GTA V SCRIPT HOOK (build Jun 22 2017, v1.0.1103.2)
    // (C) Alexander Blade 2015-2017
    [00:24:33] INIT: Started
    [00:24:33] INIT: Success, game version is VER_1_0_1103_2_NOSTEAM
    [00:24:37] INIT: Registering script 'Menyoo.asi' (0x00007FFCFD6F8DC0)
    [00:24:37] INIT: Registering additional script thread 'Menyoo.asi' (0x00007FFCFD6F7A40)
    [00:24:38] INIT: Registering script 'ScriptHookVDotNet.asi' (0x00007FFD29711380)



  • You only need whatever is in the latest archives.

    So the script hook does load? Seems like it's only part of the file, since I expect to see stuff like this next:

    [15:43:17] INIT: Pool 1 extended
    [15:43:17] INIT: Pool 2 extended
    [15:43:17] INIT: Pool 3 extended
    [15:43:17] INIT: Pool 4 extended
    [15:43:23] INIT: GtaThread collection size 188
    [15:43:23] INIT: wnd proc 0x00000000FFFF274B
    [15:43:23] INIT: IDXGISwapChain 0x00000001800CFFD8 (0x000000018001AEB0)
    [15:43:23] INIT: IDXGISwapChain set
    [15:43:23] INIT: DX init started
    [15:43:23] INIT: DX feature level B000
    [15:43:23] INIT: DX init succeeded
    [15:43:51] CORE: Requesting thread creation
    [15:43:51] CORE: Creating threads
    [15:43:52] CORE: Started control thread, id 33 active 1
    [15:43:52] CORE: Started thread 'ScriptHookVDotNet.asi' (0x00007FF8CD061380), id 41 active 1
    [15:43:53] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FF8CD061380), id 41
    


  • for some reason i cant get it to make a log file i dont know how i did it the first time lol


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.