Log in to reply

Script Hook update

  • @vendetta1969 intresting. So how come on the install page of the newest Scripthook V page it says You must delete previous asi loader version (dsound.dll) if you have one installed.??

  • @Biggdogg said in Script Hook update:

    I figured it was the gameconfig that's what I recommended earlier https://www.gta5-mods.com/misc/gameconfig-for-1-0944#description_tab

    the gameconfig file doesn't work for add on vehicles, it will crash your game as soon as you start story mode loading.

  • @Daznick said in Script Hook update:

    @vendetta1969 intresting. So how come on the install page of the newest Scripthook V page it says You must delete previous asi loader version (dsound.dll) if you have one installed.??

    it may have been an old version of scripthookv and ab hasnt updated the description which seems to be the case.

  • Everyone please back up all add on files then delete from your directory. update your dlclist.xml and meta files as well delete all add ons. If you have replaced cars with mods you will be able to use them or wait until the next gameconfig update which should happen soon I'm assuming, If you do this you can play with mods if you have replaced them with gta v normal vehicles.


  • okay I can confirm that the misunderstanding between files is In newest version of ScripthookV they are using dinput8.dll instead of dsound.dll, so, if you have a dsound.dll from older ScripthookV, you need to remove it

  • Yeah I clicked auto repair in Menyoo and was able to take off. I also have both of my car add ons working too which I thought was strange since i thought we needed an updated gameconfig file?

  • This post is deleted!

  • I was going to reply with a picture of my Lambo and BMW but I can't send a screenshot :angry:

  • My game works fine with the new scripthook, even menyoo and most of my scripts, but when i replaced dlclist with my new one ( with add ons) and the gameconfig i was using my game doesnt crash but it keeps in infinite loading, when i remove dlclist and gameconfig replacing with original ones the game works fine. Is this because gameconfig???

  • ok I got my game working by deleting everything in the mods folder. all the trainers are working. Now I will reinstall my mods one by one to see if it crash the game. Will post my results in a little while.

  • yes it works now , no crashing.

  • The new scripthook seems to not be working with GTAVlauncherbypass. My version does not have steam

    Please help!

  • Hi all,

    I've just installed the latest version of ScriptHook V, version 1.0.1180.2 and I get roughly the same problem on Windows 10 64-bit. As the loading screen before my previously saved game loads, I get the error message "A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available'. The game loads and runs fine without 'ScriptHookV.dll' and 'dinput8.dll' installed. The previous version of ScriptHookV worked fine, so is the problem to do with the new version of scripthookV?


  • Hello again, all.

    Just a quick update. I've narrowed the loading problem down to the file 'dinput8.dll'. If I install 'ScriptHookV.dll' without 'dinput8.dll' installed, the game loads and runs fine, except my mods don't work. Therefore, I wonder if 'ScripthookV.dll' has been updated, but not 'dinput8.dll'.


  • @Daznick Ok, I got it working.

    I wiped the entire game folder & re-downloaded the game entirely. I then ran the game, saved it and then exited.

    I then installed Menyoo, Alex's Script Hook, NativeUI, OpenIV and mpsmuggler.asi. I didn't install ANYTHING besides the files.

    I was able to start the game w/out it crashing & using Menyoo spawn the new planes & cars without it crashing or disappearing... I then saved the game again and exited.

    I'm going to start re-installing mods, but slowly and on a case-by-case basis, as I make sure they're either compatible with it or have been rewritten to work with the new DLC.


  • @Daznick

    It's working.
    The only problem now - can't spawn add on vehicles, waiting someone to update compatible gameconfig file. For now, If you want to play the game without crashing, clear your add on stuffs in dlclist, it's work fine.
    If still not working, I think is related to some other thing. Perhaps you can to re-install whole game and update it again.

  • Because the moderator closed down a thread I opened trying to get mine working, when already getting zero response on here, I'll post here again.

    I have everything updated and see the mods loading into the directory on load up but no mods work at all. That's not all my controller doesn't work on my modded load up. Vanilla works fine though. Maybe the new ScriptHookV is faulty?

  • There is NOTHING wrong with scripthookv - countless many use it every day. What I feel like I am seeing through all of these comments, is that too many forget that when GATV updates, it renders their modded update folder useless, because that is one of the rpfs that are modified with each and every R* update. This also is the reason why I stopped allowing updates back since version 1.944.1, because with the amount of modifications I have, it would be an all day event to get everything back in order again.

  • @eshenk PRF's I understand but I'm referring to Script Mods. Updates come and go all the time without any being effected.

  • @DeadSonRIsingxD I have NEVER seen an updated scripthookv NOT work period. The issues these users face are clearly on their end. They need to ensure that scripthookv is actually loading their scripts - this can be verified by checking their scripthookv log in their root directory.

  • @vendetta1969 A word of caution as you proceed with further modifications: when doing vehicle replacements, take note whether said replacement has it's own tuning parts, if not, make sure to edit modlits=1 to modkits=0 for said model in vehiclemodelsets.meta in your update/update.rpf/common/data/ai directory. This will prevent the replacement from spawning with vanilla modkits which can at a minimum cause strange-looking bugs or even crash your game outright.

  • Hello again, all.

    Those experiencing a problem getting GTAV to load and run without an error on Windows-based PCs with the latest version of ScriptHookV installed, I've solved the problem. In the main game directory is a folder called mods and within it is a file called update.rpf and this file seems to be the culprit. As soon as I either removed the mods directory in the main game directory, or just deleted the update.rpf file within it, the game loads and runs fine with all my mods. Please try it yourself, to see if it solves the problem. It worked for me.


  • @eshenk wb mate :) That's sound advice there about changing modkit values - altho I used this https://www.gta5-mods.com/misc/unmodifiedimicated-traffic#comments_tab to make things easier lol.

  • @krissboo Whatever you do, do NOT uptick my comment - I could get banned again, LOL.

  • @eshenk Yeah I'm being extra careful with my upvotes lol. You get a virtual one from me today ;)

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.