Log in to reply
 

Random crash in game few seconds/SHV Critical Error/Stopped Working. Help!



  • Need to know what cause is it that my game random crash in game just in few sec or minutes randomly. I use scripts, asi, add-on, graphic replace and etc as usual. I have latest scripthook and all scripts mod that latest update available. Im try troubleshooting self but still doesnt work. :(
    Updated problem: Read comments below



  • It's probably the etc. Those are killing



  • @ReNNie What type of mod do u think that might cause it?



  • @ReNNie That's a good one. xD

    @Nafizz96 How about you tell us what mods you have installed specifically before asking us which one could be the culprit? You guys never cease to amaze me. Do you think we have a crystal ball? Please read this: https://forums.gta5-mods.com/topic/13256/how-to-ask-for-help-and-support/6



  • @ReNNie @Cyron43
    Hahaha, that was funny but im serious. My language not very well bro, sorry :angry:

    Updated problem: Now got popup Scripthook critical said FATAL ERROR: Can't find native 0x80E4A6EDDB0BE8D9

    Here my scripts and asi mod list i used:
    https://drive.google.com/file/d/0B3NeyRfQ1QX7WVB0NGtqazJGUnc/view?usp=sharing

    https://drive.google.com/file/d/0B3NeyRfQ1QX7dmNaV0xka0FVb3M/view?usp=sharing



  • @Nafizz96 said in Random crash in game few seconds. Help!:

    Can't find native 0x80E4A6EDDB0BE8D9

    Have you updated Scripthook to the lastest version?



  • @Nafizz96 @ReNNie This native function is LOAD_ALL_PATH_NODES and was removed by Rockstar. All script mods which call this function need to be updated. I know this because I had the same issue with my VAutodrive mod, which I fixed right away. I see VAutodrive in your mods list. So head right over and get the update. :slight_smile:



  • @Cyron43 said in Random crash in game few seconds. Help!:

    @Nafizz96 @ReNNie This native function is LOAD_ALL_PATH_NODES and was removed by Rockstar. All script mods which call this function need to be updated. I know this because I had the same issue with my VAutodrive mod, which I fixed right away. I see VAutodrive in your mods list. So head right over and get the update. :slight_smile:

    I have updated latest scripthook and Vautodrive but still same Fatal Error popup. I try remove Vautodrive and still happen. Idk what should i try remove my mods installed now. Any help :/



  • @Nafizz96 It must be some other mod which calls this function. LOAD_ALL_PATH_NODES was always used for waypoint routing. Which other mods could that possibly be in your list? Try to find out and remove them. BTW you can safely put VAutodrive back in (don't forget VCommonFunctions). My mod works, I guarantee. :slight_smile:



  • If I'm not mistaken, ScriptHookV.log should also mention which asi called the non-existing native.



  • @ikt said in Random crash in game few seconds. Help!:

    If I'm not mistaken, ScriptHookV.log should also mention which asi called the non-existing native.

    This written scripthookV log at the end:
    [02:19:01] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FFCFF431380), id 41
    [02:19:01] CORE: Launching main() for 'Skin Control.asi' (0x00007FFCF7AC3600), id 42
    [02:19:01] CORE: Launching main() for 'TrainerV.asi' (0x00007FFCDE103530), id 43
    [02:20:05] FATAL: Can't find native 0x80E4A6EDDB0BE8D9
    [02:20:13] UNINIT: Unregistering script 'TrainerV.asi'
    [02:20:13] UNINIT: Unregistering script 'Skin Control.asi'

    And here from ScripthookVdotnet log find the different written than others:
    [02:19:14] [DEBUG] Instantiating script 'FightClubV.Menus.Shop' in script domain 'ScriptDomain_6A9D73DD' ...
    [02:19:14] [DEBUG] Started script 'FightClubV.Menus.Shop'.
    [02:19:14] [DEBUG] Instantiating script 'FightClubV.Scripts.Entrance' in script domain 'ScriptDomain_6A9D73DD' ...
    [02:19:15] [ERROR] Failed to instantiate script 'FightClubV.Scripts.Entrance' because constructor threw an exception:
    System.InvalidOperationException: Illegal call to 'Script.Wait()' outside main loop!
    at GTA.Script.Wait(Int32 ms)
    at GTA.Model.Request(Int32 timeout)
    at GTA.World.CreatePed(Model model, Vector3 position, Single heading)
    at FightClubV.Scripts.Entrance.Init()
    at FightClubV.Scripts.Entrance..ctor()
    [02:19:15] [DEBUG] Instantiating script 'Gym.Gym' in script domain 'ScriptDomain_6A9D73DD' ...
    [02:19:15] [DEBUG] Started script 'Gym.Gym'.
    [02:19:15] [DEBUG] Instantiating script 'HelicopterEffects.cHelicopterEffects' in script domain 'ScriptDomain_6A9D73DD' ...
    [02:19:16] [DEBUG] Started script 'HelicopterEffects.cHelicopterEffects'.



  • @Nafizz96 that clearly shows the problem is fight club



  • @baneofpoo2 said in Random crash in game few seconds. Help!:

    @Nafizz96 that clearly shows the problem is fight club

    Still happen... :(



  • @Cyron43 said in Random crash in game few seconds. Help!:

    @Nafizz96 It must be some other mod which calls this function. LOAD_ALL_PATH_NODES was always used for waypoint routing. Which other mods could that possibly be in your list? Try to find out and remove them. BTW you can safely put VAutodrive back in (don't forget VCommonFunctions). My mod works, I guarantee. :slight_smile:

    Ok, thanks for tips. I put yr Vautodrive back and find out comflict other mods that problem it. I will tell in this post if my game work or still not. :)



  • @Nafizz96 It's trainerv. You can see that scripthookV unregisters it because of that invalid call. Have you installed the latest version 6.0? It works fine in my game.
    Fight club is also bugged but because of a different reason. Remove it because it doesn't work anyway.
    I wonder why SkinControl also gets unregistered. Idk know this mod. From the looks of the log it seems to be dependent on trainerv in any way. Is it? Anyway, this one doesn't work either. Quite frankly there's a lot of crap mods on the internet.
    EDITED because I failed to see the second part is from ScripthookVdotnet log at first. Thanks @ikt for telling.



  • @Cyron43
    When SHV closes, it unregisters mods ;)



  • @ikt Oops sorry, somehow I missed the second part is from ScripthookVdotnet log.



  • @ikt @Cyron43
    Ok, thanks guys. I will try it later in my game



  • @ikt @Cyron43
    I follow yr helps but still have randomly crash in my game. I have redownload latest trainerv and remove fightclub mod but still doesnt work pop shv critical fatal error. Then i try remove trainerv, another problem is got crash stopped working popup after loading then in few seconds. Then I try open game again, another way crash stopped working in loading screen also, both nothing to said error in shv n shvdotnet log. Then after that i try open game again for 3 times now without troubleshooting mods, got popup again shv critical fatal error native. I go see the shv log and found the error said like this, should i try to remove shvdotnet but it doenst work scripts mod without it. Im so confuced, never happen to me this problem before :/ :(

    [19:11:30] CORE: Launching main() for 'Menyoo.asi' (0x00007FFCDA92C850), id 35
    [19:11:30] CORE: Launching main() for 'mpsmuggler.asi' (0x00007FFCFC051040), id 36
    [19:11:30] CORE: Launching main() for 'NativeTrainer.asi' (0x00007FFCF99BA3C0), id 37
    [19:11:30] CORE: Launching main() for 'NorthYankton.asi' (0x00007FFCFAAA3850), id 38
    [19:11:30] CORE: Launching main() for 'OpenInteriors.asi' (0x00007FFCEC1AB950), id 39
    [19:11:30] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FFCFC331380), id 40
    [19:12:37] FATAL: Can't find native 0x80E4A6EDDB0BE8D9



  • @Nafizz96 What does NorthYankton.asi do? Is it the one which spawns NPC traffic there? Try without it.
    Your ctd while loading the game w/o error message could be due to an outdated gameconfig.xml



  • @Cyron43 said in Random crash in game few seconds. Help!:

    @Nafizz96 What does NorthYankton.asi do? Is it the one which spawns NPC traffic there? Try without it.
    Your ctd while loading the game w/o error message could be due to an outdated gameconfig.xml

    Still same. But I found problem i think is Vanillaworks extended mod that make custom cars into traffic spawn. I read on https://www.gta5-mods.com/vehicles/vanillaworks-extended-pack-add-on-oiv-tuning-liveries-vanillaworks-and-other-modders still have happen with shv error and outdated for support smuggler run update. They will update 1.3 soon but for now i try to remove it. :thinking:



  • @Nafizz96 said in Random crash in game few seconds. Help!:

    @Cyron43 said in Random crash in game few seconds. Help!:

    @Nafizz96 What does NorthYankton.asi do? Is it the one which spawns NPC traffic there? Try without it.
    Your ctd while loading the game w/o error message could be due to an outdated gameconfig.xml

    Still same. But I found problem i think is Vanillaworks extended mod that make custom cars into traffic spawn. I read on https://www.gta5-mods.com/vehicles/vanillaworks-extended-pack-add-on-oiv-tuning-liveries-vanillaworks-and-other-modders still have happen with shv error and outdated for support smuggler run update. They will update 1.3 soon but for now i try to remove it. :thinking:

    Still no luck remove them. On SHV log still said with trainerv problem but already update. What kind of comflict mod done in my game until make unplayable :dizzy_face: :tired_face:

    [23:08:52] CORE: Launching main() for 'OpenInteriors.asi' (0x00007FFCE300B950), id 43
    [23:08:52] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FFCFC351380), id 44
    [23:08:52] CORE: Launching main() for 'Skin Control.asi' (0x00007FFCDDCA3600), id 45
    [23:08:52] CORE: Launching main() for 'TrainerV.asi' (0x00007FFCD1943570), id 46
    [23:10:21] FATAL: Can't find native 0x80E4A6EDDB0BE8D9
    [23:10:38] UNINIT: Unregistering script 'TrainerV.asi'
    [23:10:38] UNINIT: Unregistering script 'Skin Control.asi'





  • @Nafizz96 Does this only happen when you try to use the autopilot function of Simple Trainer?



  • @Cyron43 said in Random crash in game few seconds/SHV Critical Error/Stopped Working. Help!:

    @Nafizz96 Does this only happen when you try to use the autopilot function of Simple Trainer?

    No, im never use autopilot with simple trainer. I use yr mod easily


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.