Log in to reply
 

Random game crashes after ~30min. [SOLVED]



  • I hope you guys can help me out as I can't locate the problem.
    My GTA V crashes totally random after 30 - 60 minutes ingame.
    By now Im pretty sure it's not related to a specific mod.
    It happens while driving, using a mod menu, standing still, exiting a car (no noticeable pattern).

    Im playing on Windows 10 in 4k with settings maxed out at 60FPS.
    My hardware:

    • 1080TI 11GB
    • i7 - 4790 @ 3.6 GHz
    • 16GB RAM
    • SSD

    Im using VSync (fastest) trough NVIDIA's control panel in order to remove the tearing.

    The following Mods are installed:

    • VisualV
    • NaturalVision (ENB + ReShade)
    • L.A. Vegetation
    • L.A. Roads (Add-On)
    • LA Billboards + Real LA MegaPack (Add-On)
    • 10 Add-On vehicles

    All I have is the launcher.log below:

    [2017-11-06 03:23:07.401] [ ERROR ] HRESULT failed when doing m_device->Present(NULL, NULL, NULL, NULL) : 88760868
    [2017-11-06 03:23:07.401] [WARNING] Device lost.
    [2017-11-06 03:23:07.401] [WARNING] Resetting device...
    [2017-11-06 03:23:07.402] [WARNING] Reset failed with D3DERR_DEVICELOST.
    [2017-11-06 03:23:11.561] [DISPLAY] Reset succeeded.
    [2017-11-06 03:23:11.570] [ ERROR ] GameComm: ReadFile failed.
    [2017-11-06 03:23:12.018] [DISPLAY] Game exited with code 0xc0000005
    [2017-11-06 03:23:12.018] [ ERROR ] Unable to stat out-file!
    [2017-11-06 03:23:12.020] [ ERROR ] ************************************************************************
    [2017-11-06 03:23:12.020] [ ERROR ] * Setting error condition
    [2017-11-06 03:23:12.020] [ ERROR ] * Category: 1 (ERROR_CATEGORY_LAUNCHER)
    [2017-11-06 03:23:12.021] [ ERROR ] * Code: 107 (LAUNCHER_ERR_GAME_CRASHED)
    [2017-11-06 03:23:12.021] [ ERROR ] * Extra:
    [2017-11-06 03:23:12.021] [ ERROR ] * Localised: Fehler beim Starten. Code: 107
    [2017-11-06 03:23:12.021] [ ERROR ] ************************************************************************
    [2017-11-06 03:23:12.023] [ ERROR ] Unable to read out-file!
    [2017-11-06 03:23:12.024] [ ERROR ] ************************************************************************
    [2017-11-06 03:23:12.024] [ ERROR ] * Setting error condition
    [2017-11-06 03:23:12.025] [ ERROR ] * Category: 5 (ERROR_CATEGORY_EXIT_CODE)
    [2017-11-06 03:23:12.025] [ ERROR ] * Code: -1073741819 (c0000005)
    [2017-11-06 03:23:12.025] [ ERROR ] * Extra:
    [2017-11-06 03:23:12.025] [ ERROR ] * Localised: Grand Theft Auto V wurde unerwartet beendet.

    [2017-11-06 03:23:12.028] [ ERROR ] Exit code 0xc0000005 indicates a game crash (STATUS_ACCESS_VIOLATION)
    [2017-11-06 03:23:12.040] [ ERROR ] Unable to clear in-file and out-file!
    [2017-11-06 03:23:20.222] [DISPLAY] Uninitializing.

    I already used DDU to uninstall my graphics driver and did a clean reinstall, I also removed NVIDIA Experience.
    I did a clean install of Windows 10.
    I tried Rockstar and Steam Version of the game (both original).
    I googled the sh*t out of the internet but Im still not able to fix this.

    I hope someone here can - thank's in advance!



  • @P1P3L1N3 This is what happens when doing a lot of modding. Overtime, we often overwrite a file which had parameters that depended on info from another file, that is not present within said file that was overwritten. Here is an example of what I mean -

    I had a popcycle.dat that was trying to spawn a vehicle class that was not established in my popgroups. It happened because I had reinstalled the game and was using the vanilla popgroups with a popcycle I had made edits to from RDE 3.1.1 In RDE popgroups there are several new vehicle classes established, so when my popcycle attempted to spawn some of these, I would crash with a status access violation.

    This was an example, but hopefully to get you thinking towards where you might have a conflict somewhere. There are several files that cross-reference other files for information in order to work. If any file/mod was overwritten that depended on info from another file, you will get crashes that happen regardless of what you do, and sometimes will take several minutes to occur.

    Same with replacing vehicles. Did the replacement come with tuning parts? If not, the game might try to spawn replacement with vanilla tuning parts, and yes, down goes the game, LOL.



  • @eshenk
    I have a strict installation plan for the mods I'm using, I'm pretty sure there's no conflicting mod installed (popcycle / popgroups are still vanilla).
    Could be some scripts that are conflicting but I already tried it without them and it still crashes.

    I'm at the point where I think it's maybe some hardware or software issue - someone wrote that it could be an outdated audio driver but mine is up to date.



  • @P1P3L1N3 Right-click your speaker icon at the bottom right of your desktop and go to playback devices, disable all showing except the one in use. Also go to recording devices and disable it if not using. Restart and try again. Also, make sure you are NOT telling the in-game settings to do the same thing you have turned on in nVidia control panel, i.e., vSynch or say anisotropic filtering.



  • @eshenk
    Yes that's what I'm trying - I also unplugged every unused USB device.
    So far so good - last to session were exited via menu and not via crash :D

    But I'm not sure if it's fixed yet, sometimes I could play for over 1 hour before it crashed.
    I will run some hardcore session and we will see if it's stable now.



  • A modded V that is stable is like a civil servant equipped with ambition. Pure Utopia.



  • @ReNNie
    Atleast it's a goal I can always work on :)



  • @P1P3L1N3 Game crashes that occur after X minutes of playing are usually indicative of a mistuned gameconfig. Try this one: Gameconfig.xml 2.0 Very stable one, for me.



  • Looks like I'm not the only one having this issue too haha. My game crashes every time I use a modded vehicle going at high speeds. I even tried to using a few configs to get it to work but no luck :\



  • No @Modojo you guys aren't not alone ...

    eg
    My V can run on VAutoDrive in Cinematic Mode driving a vanilla car for more than an hour
    Yet when I get in a big gunfight the game crashes after a couple of minutes of mayhem
    Most likely because I'm using a custom policefleet with IRL cars not supporting LODS ;)
    Either that, or the fact that I've increased gameconfig values like the TxdStore and others to facilitate 1500+ added cars, 300 added peds etc
    Also the 30+ scripts I have in, some added maps, various retexturing, added trees... all that stuff puts a strain on the engine



  • @ReNNie
    That's exactly my problem and it's really sad there is no actual fix for this. Sometimes I drive around for almost 1 hour - after I shoot 10 second -> crash.

    I tried everything I could imagine of, several gameconfigs, no scripts, only visual overhauls and add-on cars but it still crashes.
    I will pay the man who finds a fix for this (not kidding) :D



  • @P1P3L1N3 There may be a way for us to help each other out since we are all in this mess together. The issue is, is that among us, our situations may be very different. I don't do add-on peds or vehicles.

    My specs

    i-7 4790k proc
    16 Gb DDR3 vengeance memory
    EVGA 850 W PSU
    nVidia 1070 FE

    I use GTA Realism 0.9, with zipporaid's violence overhaul, rage euphoria, insane-overpowered-weapons, and bullethit FX. I use all of @mati36 mods, realistic top speed and damages, and then the rest are texture packs for various billboard mods, LA roads, CA architecture, and then about 15 scripts. I also modified my gameconfig and settings.xml to push traffic and ped densities to resemble real-life.

    I have had stable games in the past, but I have been struggling lately to find out what is causing my random crashes. At first I thought the script screaming injured peds was conflicting with some of zipporaid's files from his violence overhaul mod. I removed it because I noticed that as soon as I started shooting peds the game would crash, while shooting vehicles had no effect. It solved the issue, but I still am getting crashes triggered by I don't know what now. I have only four replacements for vehicles, so I know it isn't because they are spawning with vanilla tuning parts because these particular vehicles either had their own tuning parts, or I commented them out in vehiclemodelsets.

    Either I have a conflicting mod file somewhere, my ped and traffic densities are just too much, or I just need to make my gameconfig stronger in the right places. I may need to go to a vanilla update state, while keeping my gameconfig and settings.xml file the same, just to see if the increase in traffic densities is the problem or not. If I can drive around for over an hour without issue, then I will know there is a conflicting file somewhere.

    Also an FYI -

    Event viewer logs will usually show the culprit as either gtav.exe OR clr.dll

    scripthookvdotnet will CATCH unhandled exceptions preventing it from being seen by windows itself - see below for example -

    [08:16:18] [ERROR] Caught fatal unhandled exception:
    System.NullReferenceException: Object reference not set to an instance of an object.
    at The_Heavy_Service_Mod.The_otherstuff.The_otherstuff_Tick(Object sender, EventArgs e)
    at GTA.Script.raise_Tick(Object value0, EventArgs value1)
    at GTA.Script.MainLoop()

    It caught the unhandled exception so no crash from windows - BTW this mod works without issue. So a script should very rarely be the source for a crash unless there is another similar script that does the same thing. If it is a clr.dll error in event viewer the likelihood is that we have two different files telling the game to do the same thing or each one telling it to do something different in a given scenario. Scripthookvdotnet cannot see modified .meta, .xmls for example, so if there is a conflict there, windows will see that, and crash. An error from gtav.exe usually means we are asking too much of the game engine, i.e., too many add-on, replacements, too much traffic etc - maybe means a stronger gameconfig is needed in the right parameters.

    I just wish they had a "Gameconfig For Dummies" book, explaining in detail what each parameter is responsible for, and which one's we want to increase for desired results.



  • @eshenk
    If you want we can try to figure it out.
    I mean I can still play the game for solid 60 minutes but it makes me sad knowing it could crash anytime - I assume you know what I mean.

    We could try adjusting the gameconfig or testing mod by mod. You can add me on Steam: P1P3L1N3 (or try saw395)



  • @eshenk said in Random game crashes after ~30min.:

    scripthookvdotnet will CATCH unhandled exceptions preventing it from being seen by windows itself - see below for example -
    [08:16:18] [ERROR] Caught fatal unhandled exception:
    System.NullReferenceException: Object reference not set to an instance of an object.
    at The_Heavy_Service_Mod.The_otherstuff.The_otherstuff_Tick(Object sender, EventArgs e)
    at GTA.Script.raise_Tick(Object value0, EventArgs value1)
    at GTA.Script.MainLoop()
    It caught the unhandled exception so no crash from windows - BTW this mod works without issue. So a script should very rarely be the source for a crash unless there is another similar script that does the same thing. If it is a clr.dll error in event viewer the likelihood is that we have two different files telling the game to do the same thing or each one telling it to do something different in a given scenario.

    Not always, sadly. Yesterday I suddenly had 4 freezes, while in Spooner Mode, but nothing to confirm that being the cause in the SHVDN log (or any of the other game logs). In Event Viewer, it will show you something like:

    Application: GTA5.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: exception code c0000005, exception address 00007FF7283EE546

    With the only true exception being that the unhandled exception wasn't caught by the game.

    Errors like these are very annoying. At first I thought maybe my video card (GTX 980) was giving out, as GTA V puts quite a bit of stress on it. So, in that sense, I was 'happy' to see it was just an unhandled exception. Still, this game has got to be the most user-unfriendly when it comes to error logs. No different for the gameconfig file: it often feels like Rock* is doing everything in their power to frustrate modding as hard as they can.



  • @P1P3L1N3 Oh TRUST me pal, I know EXACTLY what you mean, LOL. Every inch I drive my vehicle, I brace myself for that oh so familiar windows alert that your game crashed! Yesterday, I got rid of zipporaids shit-head peds mod, because I felt that it was conflicting with something within the GTA Realism mod. I played for about 45 minutes, and then saved my progress, and exited the game. Does that mean I found the culprit? Maybe, maybe if I had just played one more minute I would have CTD, LOL. I will say that I have traffic pushed through the roof, and I have it working the way I never could get it before, where for some reason I would have insane traffic on the highways and countryside, but could never get city traffic up. I have solved that issue, and so far so good. Now I am going to slowly start replacing vehicles, but will only choose vehicles that don't require edits to handling, vehicles, carcols, carvariations etc to keep things simple.



  • @meimeiriver Well let's also be fair here. We ARE modding the f*ck out of our games, so it's not like there is a useful way of saying "Oh, that was your blah-blah mod spazzing out", LOL...



  • @eshenk said in Random game crashes after ~30min.:

    @meimeiriver Well let's also be fair here. We ARE modding the f*ck out of our games, so it's not like there is a useful way of saying "Oh, that was your blah-blah mod spazzing out", LOL...

    True that. But this is also the first game I've encountered that has its default gameconfig tuned so ridiculously minimally. We pretty much all have 64-bit machines now, and I have 32G memory installed. The game should just have grabbed everything it can, and we'd have never ever crashed because, OMG, we installed 1 addon car too many!



  • @meimeiriver BUT....for the sake of sales, they have to ensure they maximize their audience by accounting for those who have systems far less capable. You might recall Skyrim - same troubles we had then, until Boris came out with his ENBoost, which allowed us to access memory beyond 4Gb - it was a real game-changer if you remember. Just recently we got the heap-adjuster which is akin to the ENBoost for Skyrim - 150 Mb is HUGE - it allows for insane figures to be added to gameconfig, that could not have been done before without running into game memory errors.



  • @eshenk said in Random game crashes after ~30min.:

    E mo

    Now I have only VisualV + NaturalVision + ScriptHook + .NET and guess what - crashing like it's hot.
    I'm pretty sure it has something to do with VSync - trying some different settings now.

    I will not give up until it runs 24/7 without crashing.



  • @eshenk said in Random game crashes after ~30min.:

    @meimeiriver Well let's also be fair here. We ARE modding the f*ck out of our games, so it's not like there is a useful way of saying "Oh, that was your blah-blah mod spazzing out", LOL...

    Also, maybe it can't identify our mod (fair enough), but would it really kill them to log something like 'VehicleMemoryMultiplier exceeded' Or, 'Out of ped memory'. The game itself does nothing more than log 'GameComm: ReadFile failed.' Riiight.



  • @P1P3L1N3 You will get this nailed down, and it will be a rewarding experience once you have that stable game you always had dreamt of LOL.



  • @meimeiriver BTW, mod author of heap-adjuster hard-coded the hook address, "that will not end well", LOL...



  • @eshenk said in Random game crashes after ~30min.:

    @meimeiriver BTW, mod author of heap-adjuster hard-coded the hook address, "that will not end well", LOL...

    That's what I said on his mod page, right? Upon closer examination, looks more like he's searching for a pattern, with several wildcards in it.



  • @P1P3L1N3 Dude I feel you too man. Right when I installed my basic mods (weapon replacements and scripts) I get to the point where my game crashes when trying to edit a video within the Rockstar editor..

    All of my mods were working fine before the smuggling run update and now Im just struggling to find a ****ing solution to get my game running without crashing.



  • @Modojo

    R* Editor crashes are most likely related to gameconfig values

    from Willief23 & MAESTRE's Gameconfig »

    Also if your RockStar Editor crashes go to line 382 and lower the value to 300.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.