Log in to reply
 

Empty insurgents with modified dispatch.meta



  • I ve been using this dispatch.meta for a lot of time before I reinstalled GTA V with all updates, at 5 stars I got military troops on me, but insurgents are spawning empty. Its very annoying. Everything else is working more-less normally. Anyone has any experience with this?



  • I'm having a similar problem with my modded 'dispatch.meta' (based off of DoV: https://www.gta5-mods.com/misc/dispatch-of-variety). In my case it's APC's & Rhino's that sometimes turn up without a driver (makes them very easy to steal, not ideal when you want a challenge :/) so I'd be very intersted in a solution to this as well.
    I haven't had a chance to try anything out yet but ideas I thought of where either increasing the possible ped models:

    Example:

    					<Vehicle>rhino</Vehicle>
    				</VehicleModels>
    				<PedModels>
    					<Ped>S_M_Y_Marine_03</Ped>
    					<Ped>S_M_Y_Marine_02</Ped>
    					<Ped>S_M_M_Marine_01</Ped>
    				</PedModels>
    

    or more likely to work, increasing the 'NumPedsToSpawn' in the dispatch type:

    Example:

    			<Item>
    				<DispatchType>DT_PoliceRoadBlock</DispatchType>
    				<NumPedsToSpawn value="8"/> 
    				<DispatchVehicleSets>
    					<Dispatch>DOV_RB_POLICE</Dispatch>
    					<Dispatch>DOV_RB_SAHPDICK</Dispatch>
    				</DispatchVehicleSets>
    			</Item>
    

    I will be watching this thread & will post if I find anything out (when I get a chance).



  • @JonaQ thanks for willingness, I did try these things a long time ago, but I dont remember it had any influence. I might give it a try again



  • It's a hard one for me to test as it only happens some of the time for me. More often when there are 2 of the vehicles together at a roadblock.
    I did notice that the vehicles seem to spawn with the peds outside & then the peds try to jump into the vehicles sometimes (other times I run them over :/).
    I'm in the process of making sure the drivers in vehicles.meta:

    		<drivers>
    			<Item>
    				<driverName>S_M_M_Marine_01</driverName>
    				<npcName />
    			</Item>
    			<Item>
    				<driverName>S_M_Y_Marine_02</driverName>
    				<npcName />
    			</Item>
    		</drivers>
    

    match up to at least one of the ped models in dispatch.meta:

    				<PedModels>
    					<Ped>S_M_Y_Marine_03</Ped>
    					<Ped>S_M_Y_Marine_02</Ped>
    					<Ped>S_M_M_Marine_01</Ped>
    				</PedModels>
    

    Total long shot I know. I'm just shooting in the dark here. Hope somebody comes along that knows something.



  • @JonaQ well I managed at least make barracks at 5 stars spawn with soldiers. It didnt work with riot and insurgent though... never mind im gonna keep it like this.



  • @libertz

    Just dropping this here in case you are still suffering from empty vehicles.

    Spot of luck (perhaps). I haven't tried it out on my game yet but it sounds promising:

    https://www.gta5-mods.com/scripts/dispatch-ghost-fix

    In the thread there is info about authors putting '--' (& possibly other invalid characters) in .xml files. This can cause problems (it was causing one ped in my dispatch.meta to have trouble spawning). If you have any comments in your dispatch.meta, try removing them :thumbsup:

    EDIT: I noticed your comment in the link above saying it didn't work for you but given the info above might be worth trying it out again. The mod has a 'DispatchGhostFix.log' that is produced in the main GTA V folder that may give you useful info also.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.