Log in to reply

Choppers/Motorcycle Discussion and Troubleshooting

  • I'm working on an add on package for vanilla edited motorcycles but I'm having an issue with the linkage on the bikes that have springer front ends. For some reason (even on ones that I don't touch the fork) the linkage piece between the front and rear legs becomes detached. So for example even if I don't modify anything in z3d just importing and exporting seems to cause this problem. Has anyone else experienced this? I'm running out of ideas and have spent several days trying to figure out what the problem is. I have several bikes that are finished and ready to upload but I don't want to upload them until I have this issue resolved.

  • @riotvision just import the bikes with slice to parts option unchecked and it will import into zmodeler 3 without being sliced off.

    but you can't edit much that way . just try and import without this option ticked.

    and if u want to edit bikes in a more detailed way u will have to get it into zmodeler 3 sliced and then attach vertices manually later bu using weld vertices option. i hope it helps you get out of confusion.

    also don't use cracked zmodeler 3 for bike conversions as cracked versions had limitations when it came to bikes and bicycles export.

    happy mod creation :slight_smile:

  • @FoxtrotDelta Thanks for the help and quick reply! I pay for z3d so it shouldn't be an issue. I definetely need to import with it sliced to make the edits that I want to do. So is there a way to see exactly which vertices are welded originally? I'm not sure how I would weld it and still have the linkage hinge the way it is supposed to in order for the suspension to work correctly.

  • http://www.mediafire.com/file/gub05q7skb66qkr/zombiekiller.z3d


    In game you can see the fork linkage by the wheel seperates. The suspension works properly but it's causing some major visual cringe for me even though you have to look for it to even notice it lol.

    And I tried welding vertices, it ended up making it rigid, not allowing for the linkage to hinge... idk

  • @riotvision you have to weld them one by one not multiple vertices at the same time.

    Thats why tanks and bikes take long time.

    Dont worry at first i couldnt make sense of,it too. The vertices you are trying to weld should be in linear same plane so that they dont become cone like or stretched when welded. You need to view tutorial forum topics and videos on how to weld properly it even bugs the hell out of me.

    In open iv just uncheck the bike forks or suspension springs, the ones which are weled wont disappear but will be stretched towards the chassis dummy node towards the mid of the bike. Like stretched ropes . you will see. And u dont have to weld exactly those vertices which were welded originally. U just need a clean weld so that u cant see dislinkage or empty space between parts when the bike turns or jumps.

    When u weld them they would stick together.

    @SkylineGTRFreak is the one who taught me this, we were working on tanks back then.

    You have the knowledge and ur confusion or uncertainity should have gone now.

    Now its upto you what you do with the knowledge. ;) Good Luck

  • Basically do Everything you want and when you're finished, export your file normally and refer to this Video starting at 3:10:

  • @SkylineGTRFreak awesome Video . you should make more when u have time. ! you do it more efficiently and quicker than i do. lol i'll do it this way from now on. Thanks.

  • @FoxtrotDelta unfortunately I haven't got time for that in the foreseeable Future, but I'd Really like to.
    Something like a Tutorial for planes or so would probably be very appreciated. Hm, we'll see.

  • My Weld doesn't have the option for Multiple Targets like yours shows in the video. Your Weld icon has a check box it looks like? None of my icons have that. With it sliced I can pinpoint the pairs of vertex that need to be welded I just don't know how to actually weld the vertex between two seperate objects (the front and rear fork leg). I can get both vertex selected but how do I actually tell it to weld the two together? I'm missing something idk. When I import it not sliced as you are doing in the video I can't pinpoint only the pairs of vertex that need to be welded because I can't look at the front and rear fork leg objects separately, but I can manage to get the selection isolated to only the groups of polygons that I need to be connected between the two. At that point it looks like all I need to do is select Weld/Multiple Targets, and that is where I'm stuck because as I said I don't have the Multiple Targets option.

  • @riotvision did you click on that small arrow or whatever it is in the top corner of the weld symbol?

  • @SkylineGTRFreak That's what I was saying, I don't have that on any of the tool symbols, I see it on yours. Not sure why, I have the latest version of z3d, I just paid for three months the other day.

  • @riotvision

    if you don't have this. remove your zmodeler 3 and re-install it.

  • @FoxtrotDelta @SkylineGTRFreak Thanks fellas, I figured it out. For some reason the icons don't have options buttons on them in the drop down menu, you have to have them visible in the toolbar like I see both of you have. I really appreciate the help, I was cruising along pretty good until I hit this obstacle.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.