Log in to reply

Cant Launch GTA V without RSSC pushing an Update, Update creates new folder in program files named, 'Grand Theft Auto V - Mods' and downloads here.

  • Hoping that some one could help me out, new to this forum so please forgive me if I miss something.

    Anyway, I picked up a disc copy of GTA V a few days ago, played around a bit on SP/MP but quickly realized this isnt why I wanted the game. I bought the game for a third time(1st on 360, 2nd on Xbone) because I wanted to experience modded GTA V(as well as high refresh rate 1440p GTA V). So I began the process of getting it ready for mods. I made a copy of the game so Id have the original so I can still play online. I downloaded OpenIV, installed both ASI files, got the mods folder in the non-online copy, as well as the update folder(with update rpf) with x64 contents inside. Basically I tried my hardest to follow the tutorial thats commonly linked to here, step by step until i got to the point where you run the game with the car mod installed.

    Heres where the problems begin. When I launch, it only lets me launch via the "play gtav.exe" which takes me through RSSC and forces me to update after giving it admin rights. If I launch from "gtav.exe" it says I cant do that and makes me launch with RSSC. Now, when I try to launch and RSSC starts updating(downloading the whole game), it creates a new folder in Program Files titled, "Grand Theft Auto V -Mods", this is where its downloading this 'update'. Why its doing this, is beyond me. I have a feeling that this is whats causing my issue though.

    Heres what else I did in the process of trying to get this work.

    • Installed 'Modded GTA V Launcher' from user: BroXe (no difference)
    • Installed the RagePluginHook, put it in the modded directory, everything works but it cant launch the game either.
    • Copied x64a through x64w .RPF into mods folder(dont know why I thought that would work)
    • Tried launching vanilla GTA V, but was still pushing for full redownload(I think is because when I first started I accidentally installed ASI files to vanilla, Deleted them but im thinking I missed one)
    • Spent all morning searching forums trying to find a solution.

    I think I touched on everything, if theres any more info you need to help me out please let me know Ill provide whatever I can.

    UPDATE: So after many hours and many forum posts searched, I finally found the solution. Remember early in my post I said RSSC kept trying to download the entire game again, but would download to a directory that it creates called 'Grand Theft Auto V - Mods'? Well this was in fact the issue, but I solved it when I blocked the update in Action Center, and RSSC told me the GTAV.exe couldnt be found. Strange, because I was launching from where it was located. Well, my solution was to rename my modded GTAV directory to 'Grand Theft Auto V - Mods', and RSSC pushed an update of about 750mb, I let it update as I figured it would remove all the modded files and let me start fresh. Wrong. It updated and all the files were still there, I launched and it loaded SP and what do you know, Native Trainer was present in the game! Now my problem is that NT uses a numpad to navigate and ive got a TKL Logitech Pro... Should be a fairly easy fix though!

  • @brando_1771 Sounds like your 2 copies are conflicting. I would rename the folders to 'GTA V clean' and 'GTA V modded', then just rename whatever one you want to play. EG rename 'GTA V Clean' to GTA V if you want to play online, and vice versa if you want to play with the mods.
    then rename the folders when you finished playing - PITA but only way I know how to run 2 copies.

  • @krissboo okay so I just tried that, I renamed them 'clean', and 'modded' respectively, then renamed the 'modded' one back to original name. Tried launching again via the PlayGTAV.exe and the same thing still happens. It created the 'Grand Theft Auto V - Mods' folder again, and in it was only the GTAVLauncher.exe(it didnt download anything though because it didnt have admin rights so idk where this came from).

  • @brando_1771
    Any chance you can get me a pic of your GTA install folder?

  • @krissboo
    note that the 'Grand Theft Auto V - Mods' folder is the one created by the launcher, and the unlabeled one is the one with the mod folder inside it


Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.