Log in to reply
 

GTA V wont Launch ERR_GFX_D3D_SWAPCHAIN_ALLOC_2



  • hi, could do with some help as struggling to get anywhere with googling the problem, similar to describe in this post below...

    https://forums.gta5-mods.com/topic/4070/solved-err_gfx_d3d_swapchain_alloc_2

    I recently got rid of the previous version of Windows off my laptop to save space, not sure if this has done something to computer but it doesn't want to play.

    I get the error code after social club has gone and its about to go into the black screen for loading and said ERR_GFX_D3D_SWAPCHAIN_ALLOC_2, and also something regarding it not finding Direct X 10 or 11 please use a suitable graphics card. But i checked and my Nvidia GT525M is running Direct X 12.

    I have copied a clean version of the game just to try and get it going so it has no modifications at the moment (i have also tried it with and without the launcherbypass).

    If i try to launch from GTAV.exe i get the message as in this picture....
    alt text

    And now when i try to launch from PlayGTAV or GTAVLauncher the social club does nothing. it did go away and come up with the Direct X problem message but now does nothing.

    Oh its also a disc version of the game not a download or steam
    Any help is very much appreciated.
    Thanks
    Christian



  • also forgot to mention i have uninstalled and reinstalled the drivers for nvidia



  • Done some more testing this morning...

    Tried to launch in Safe Mode with Nvidia Graphics Card Disabled - it works

    Regular Mode and Nvidia graphics card - Stops working and has to close (around point where you get all the flashing sirens on start up) No Direct X 10 or 11 Graphics card detected message please use suitable graphics card .

    Regular Mode + Nvidia Disabled - Stops working after the sirens but before the legal message

    Safe Mode and Nvidia Enabled - get the direct X 10 or 11 message again... like this one....

    alt text

    Seems it doesnt like something to do with the Nvidia Graphics Card. But im not sure what.



  • @Christian6984
    I would start by deleting your 'settings.xml' file & then loading the game.

    'C:\Users\USERNAME\Documents\Rockstar Games\GTA V\settings.xml'

    At the bottom of the 'settings.xml' file it will show you what GPU it is trying to use to load the game.

    Example:

    </video>
    <VideoCardDescription>NVIDIA GeForce GTX 1080</VideoCardDescription>
    </Settings>

    Make sure it matches the card you have installed & are trying to use.

    If that doesn't work try removing your Nvidia driver with Display Driver Uninstaller & then redownloading & reinstalling the driver.

    Other things:

    Does your monitor have a USB3.0 display adapter? If so disable it (just the USB device, not your Monitor) in Device Manager. Reinstall Nvidia drivers after.

    If your Laptop has Integrated Graphics disable it also in Device Manager & then reinstall Nvidia drivers.

    Also, check if you have a 'commandline.txt' in your main GTA folder & that there are no gpu related settings in there that might be messing things up.



  • @JonaQ many thanks for the reply, i have tried the suggestions i can.

    I have no Settings.xml file in the GTA V folder?
    I disabled the usb3.0 which also stops my controller working as use an old PS3 one but still game wouldnt run even after a reinstall of graphics.

    I also have no commandline.txt in the GTA V Folder?

    One thing i did try was disabling the intel graphics card and running the game to force it to run on the Nvidia but the lag was terrible, it ran better on the intel one, not as good as when it was working with all the mods in it but it ran. I think i also ran it in compatibility mode to make it think it was on Windows 8. Could this deleting of the old windows affected previous versions as laptop was originally Windows 7 but GTA was only purchased after upgrading to windows 10.



  • @Christian6984

    Right, I'll start by saying, try one thing at a time, don't be trying 5 fixes at the same time. Change something, test load game, put settings back to how they were, try something else...

    Try downloading this settings.xml & putting it in:

    /Documents/Rockstar Games/GTA V/

    The tricky part might be telling whether the game is actually using that settings.xml file. You may have to change a few of the settings in the settings file while reloading the game to check & see if you can see a difference.

    <GrassQuality value="0" /> 
    

    (0= off completely, 1 or 2 = On (2= Higher density))

    <Reflection_MipBlur value="true" /> 
    

    (if set to 'false' car windows will look matt with no reflections)

    <DoF value="true" /> 
    

    (false = off)

    Note: You NEED a settings.xml to have any chance of running the game smoothly & also I said USB 3.0 Display Adapter. Not USB 3.0. :thumbsup:

    So the game now loads with Integrated Graphics disabled but your Integrated Graphics are better than a GT525M?! (that doesn't make much sense. I have a GT525M in my Laptop & I've never heard of Integrated Graphics getting anywhere near it on gaming performance!). How sure are you that the game wasn't using the GT525M before?
    I would try the settings.xml above while leaving the Integrated Graphics disabled & just using your GT525M. I'm pretty sure you are getting the ERR_GFX_D3D_SWAPCHAIN_ALLOC_2 error as the game is trying to use your Integrated Graphics which do NOT have DX10-11 capabability. The reason the game may have been laggy on the GT525M might be the fact the settings.xml is missing & is not optimised (Grass may be on etc). Try using the one above or similar here> https://www.gta5-mods.com/search/settings.xml/latest)

    I doubt the old Win 7 install (was it in a Windows OLD folder?) has anything to do with it. It's more likely the game just doesn't run as well on Win10. Win 7 is a good OS, It's the last good OS. Everything since is a bit :thumbsdown:



  • @JonaQ

    I've added the settings.xml file and i got it to open with these settings (although at the bottom says AMD something but mine is Nvidia?) does this need changing....

    <?xml version="1.0" encoding="UTF-8"?>

    <Settings>
    <version value="27" />
    <configSource>SMC_AUTO</configSource>
    <graphics>
    <Tessellation value="0" />
    <LodScale value="0.000000" />
    <PedLodBias value="-0.500000" />
    <VehicleLodBias value="-0.500000" />
    <ShadowQuality value="0" />
    <ReflectionQuality value="0" />
    <ReflectionMSAA value="0" />
    <SSAO value="0" />
    <AnisotropicFiltering value="0" />
    <MSAA value="0" />
    <MSAAFragments value="0" />
    <MSAAQuality value="0" />
    <TextureQuality value="0" />
    <ParticleQuality value="0" />
    <WaterQuality value="0" />
    <GrassQuality value="0" />
    <ShaderQuality value="0" />
    <Shadow_SoftShadows value="0" />
    <UltraShadows_Enabled value="false" />
    <Shadow_ParticleShadows value="false" />
    <Shadow_Distance value="1.000000" />
    <Shadow_LongShadows value="false" />
    <Shadow_SplitZStart value="0.930000" />
    <Shadow_SplitZEnd value="0.890000" />
    <Shadow_aircraftExpWeight value="0.990000" />
    <Shadow_DisableScreenSizeCheck value="false" />
    <Reflection_MipBlur value="true" />
    <FXAA_Enabled value="false" />
    <TXAA_Enabled value="false" />
    <Lighting_FogVolumes value="false" />
    <Shader_SSA value="false" />
    <DX_Version value="0" />
    <CityDensity value="0.000000" />
    <PedVarietyMultiplier value="0.000000" />
    <VehicleVarietyMultiplier value="0.000000" />
    <PostFX value="0" />
    <DoF value="true" />
    <HdStreamingInFlight value="false" />
    <MaxLodScale value="-0.00000" />
    <MotionBlurStrength value="0.000000" />
    </graphics>
    <system>
    <numBytesPerReplayBlock value="9000000" />
    <numReplayBlocks value="36" />
    <maxSizeOfStreamingReplay value="512" />
    <maxFileStoreSize value="65536" />
    </system>
    <audio>
    <Audio3d value="false" />
    </audio>
    <video>
    <AdapterIndex value="0" />
    <OutputIndex value="0" />
    <ScreenWidth value="800" />
    <ScreenHeight value="600" />
    <RefreshRate value="75" />
    <Windowed value="0" />
    <VSync value="0" />
    <Stereo value="0" />
    <Convergence value="0.100000" />
    <Separation value="0.000000" />
    <PauseOnFocusLoss value="0" />
    <AspectRatio value="0" />
    </video>
    <VideoCardDescription>AMD Radeon HD 7560D (AMD Radeon HD 7560D || ATI FirePro A300 Series(FireGL V) Graphics Adapter)</VideoCardDescription>
    </Settings>

    This opens the game but only if i stop the Intel Graphics card. Other wise i get the Direct X 10/11 problem. Its still laggy as hell though to the point its more unless unplayable anyway. GEforce Experience opens but only if i run it as the Integrated Graphics card can i see the game.

    I have no USB 3.0 Display Adapter that i can see in the Device Manager?

    Thanks for your help so far, you are being a massive help



  • Settings.xml
    What should happen is that when you load up the game & then go into the graphics menu & change something the game should save the new config to the settings.xml.
    This will update it to the correct nvidia card <VideoCardDescription> name. You can then open settings.xml again & manually set the parameters to what you have above. Save it & then mark it as Read Only to try & stop the game changing it back. In my experience however the game does change it even if it is marked 'Read Only' when you go into the games graphics options so make a copy of the correct settings.xml & make sure the game is using that when you start it.

    I'm guessing it should say:

    <VideoCardDescription>NVIDIA GeForce GT525M</VideoCardDescription>

    You can also try adding these settings to the file:

    <textureplaceholder3 value="1.000000"/>
    <particleplaceholder1 value="1"/>
    <particleplaceholder2 value="true"/>
    <particleplaceholder3 value="1.000000"/>
    <waterplaceholder1 value="1"/>
    <waterplaceholder2 value="true"/>
    <waterplaceholder3 value="1.000000"/>
    <lightingplaceholder2 value="true"/>
    <lightingplaceholder3 value="1.000000"/>
    <shaderplaceholder1 value="1"/>
    <shaderplaceholder3 value="1.000000"/>
    

    to perhaps help with lag. Put them somewhere in the middle. It doesn't matter where.

    Cleaning old possibly corrupt driver components:
    Use Driver Display Uninstaller to uninstall your drivers. Using this gave me ~+15 frames running at 4K DSR so it may help you with lag. Perhaps also uninstall Geforce Experience & make sure to reset ALL driver & Geforce Experience settings to default when reinstalling.

    Geforce Experience is something I NEVER install. It is useless at optimising games. You are much better doing it manually (ingame or using Nividia Control Panel or Nvidia Profile Inspector & testing framerates yourself. Every machine is individual. There is no cure all :thumbsup:

    Clean registry between installs using CCleaner & be sure to restart your computer when prompted. No shortcuts

    I would reinstall DirectX if you have not done so already.

    Compatibility Mode: I would probably leave this out of the equation at the moment. You can experiment with it if you like but remember to set it back to normal after so as not to introduce new variables. Messing with that setting has caused my game to crash on startup before.

    Windows 10 Optimisation
    I would have a look at

    or this also & search Google for Win 10 Optimisation Guides too. I am convinced the lag you are experiencing is Win 10 or driver related & nothing to do with using a different graphics card. What Integrated Graphics chipset does your laptop have anyway? To me it makes no sense that it would be better than a dedicated card. Why would a company go to the extra expense/increased heat/less battery life of installing a GT525M on a laptop when the onboard GPU is better anyway?! Seems pointless. More likely to be an old corrupt nvidia driver part left from before messing up your GT525M or Windows 10 (& it's bloatware) using WAY more CPU than Win 7 in the background when you are trying to run the game. GTA V is VERY CPU intensive. Ah, that reminds me.

    Setting GTAV.exe to 'High' CPU Priority:
    Note: Prio Instructions (below) are for Win 7 but should be similar for Win 10.
    Download & install Prio & then when you are running the game Alt+Tab out of the game, press Ctrl+Shift+Esc to open Task Manager, on the 'Processes' tab, find & right-click GTAV.exe>'Set CPU Priority'>'High' (don't use 'Realtime', 'High' is the highest setting you should use). You can also do the same to set other processes to 'Low' so that they stay out of GTA V's way when you are playing the game.
    Once you have set the CPU priority for a given process the process will ALWAYS lauch with that priority. So you only need to do this once for each process :thumbsup:



  • @JonaQ

    I have update the <VideoCardDescription> and added the suggested lines into setting.xml

    I used DDU to uninstall the Nvidia drivers and then used ccleaner followed by a restart. Then i reinstalled the Nvidia Drivers but it still wants to only play from PlayGTAV and using the Intel HD Graphics 3000, if i use Nvidia GT525M it comes up with the Directx 10/11 problem. It will launch under Nvidia if i disable the intel one but when you go to graphics settings in game there is less with the Nvidia one (Nvidia 979mb to Intels 1632mb)

    I have optimised the computer as per video and got rid of GE Force Experience. I have also set the priority to high, i needed to do this in one instance to get the infinate loading story mode screen to go away and get me in game.

    One thing i dont know how to do is reinstall Direct X as when i got to links it tells me that windows update automatically downloads the updates.

    I am well and truly stumped as to what the problem is

    Many Thanks
    Christian



  • @Christian6984
    I'm beginning to think your laptop is running some sort of hybrid setup. Using the HD Graphics 3000 as default & then using the GT525M when graphics load is high. That's what should happen anyway.

    I had a look at HD Graphics 3000 drivers:

    https://downloadcenter.intel.com/product/81500/Intel-HD-Graphics-3000

    & I noticed they don't seem to have one that officially supports Windows 10.

    Info here: https://www.drivereasy.com/knowledge/how-to-solve-intel-graphics-3000-driver-issue-in-windows-10/ from 9 months ago also states that "Intel Graphics 3000 is not supported in Windows 10". No support confirmed again here: https://communities.intel.com/thread/112238

    I did however find this: https://downloadcenter.intel.com/download/25176/Intel-HD-Graphics-Production-Driver-for-Windows-10-64-bit-N-Series- which maybe might work, maybe. Create a restore point before trying anything.

    I suggest you explore the angle of making sure you have a Windows 10 supported driver for your HD Graphics 3000.
    Note: This link https://www.techspot.com/downloads/drivers/essentials/intel-hd-graphics-windows-10/ (& the previous one) were found quickly. It will be your responsibility to make sure that the drivers are compatible with your exact hardware setup. Watching a few youtube vids first is probably a good idea. :thumbsup: https://www.youtube.com/results?search_query=How+To+Install+Intel+HD+3000+Graphics+Driver+Windows+10+



  • I have had the same problem after update to windows 10, 1709 with a notebook with Intel HD3000 and NVIDIA GT540M.
    To resolve, install the latest nvidia driver (clean install). There is no need to update the HD3000 driver who comes with windows 10.
    After this configure the game in Nvidia controlpanel to run with the Nvidia graphics processor.

    Download and install older directx versions(dx9, dx10, dx11)

    Next step: (the most important) goto the GTA5 installation folder, right click on the GTA5.EXE, Properties -> Compatibility -> Mark the checkboxes "Disable Fullscreen optimizations" and "Run as Administrator".

    After this the game run in Directx11 @GT540M in Windows 10.

    DXDIAG doesnt show the NVIDIA graphics processor!

    I hope this helps



  • @ABE01 Nice one, cheers. Here's hoping it fixes the issue for Christian6984 :thumbsup:

    @Christian6984 See post above by ABE01. Hope it works :thumbsup: Let us know



  • i have prepared a folder on my google drive with all necessary files to run gta5 on windows 10.

    https://drive.google.com/drive/folders/15pxsKBRROTaEjNG2-5qnMDr8AOpAGqER?usp=sharing

    here again the necessary steps to run GTA5 or other DX9-11 games on windows 10 properly:

    1. the 96MB .zip file contains all necessary dx9-dx11 setup files. unzip and execute dxsetup.exe.
    1. (the most important) goto the GTA5 installation folder, right click on the GTA5.EXE, Properties -> Compatibility -> Mark the checkboxes "Disable Fullscreen optimizations" and "Run as Administrator".

    2. Configure the game in Nvidia controlpanel to run with the Nvidia graphics processor.

    3. optional
      after the update of windows10 from windows7 geforce experience doesnt run properly too. only a black window witout content.
      there are 2 folders, system32 and syswow64. copy this folders to your windows directory. this folders contain dxcpl.exe in 32bit and 64bit from win7, a tool to configure DX10,11 on windows 10. this files are necessary to run geforce experience properly, maybe gta5 too (GTA5 runs on my old notebook GT540M and HD3000 without this modification)
      enter in the searchbar from win10 dxcpl and execute the file as administrator.
      in the tab "scope" click on "edit list.."
      click on the 3 points, search for the .exe files (geforce experience and/or GTA5.exe and/or any other game executable). then ok and then mark "force warp" and press apply or OK.

    4. if this not helps, move the 2 files d3dcompiler_46.dll and d3dcsx_46.dll from the gta5 folder to another location.

    5. if this not helps, try to run GTA5 in a borderless window with the same size of your screen.



  • @ABE01 @JonaQ

    Thank you so much for your help. I’ve got the game working. I tried to optimise windows as in the video above and for some strange reason upon next restart onwards it became really slow and when you right clicked anything on desktop or browser it would come up with the outline and the part where the options were became see through and took ages to load if at all. So I had created a system restore point and went backward. Installed latest nvidia drivers. And the. Took ABE01’s advice above and it works. Game is running frame rate back to normal.

    So from there I added scripthook v and re ran game. All seemed fine and it loaded. So added enhanced native trainer. It worked still. Added one of my cars and it worked. So thought I’ll try adding my dlc car packs (I mostly have them in brands so I’m not overrun with them and I reached the limit for individual cars) . I had saved all of these to a folder else where on computer while I started modifying the game back to how it was. I added Alfa Romeo and it has two cars. Both worked fine. Aston Martin has one car in it and both work fine. Got to Audi and it’s crashing the game. Is there any reason why it would do this, it was working before and I have added each car individually and they all work but as the car pack they don’t. Does something change when the game updates like to do with the cars they are based upon seems weird they all work but one Audi S1 doesn’t work and they were all saved to ENhanced native trainer and this S1 came up a different colour than I saved it. All the other cars came up as I left them (so if I saved for example the Q7 in blue it spawned as a blue car)

    Many thanks. I’m glad it’s working but confused why the car pack doesn’t seem to want to play.

    Thanks
    Christian



  • @ABE01 @JonaQ

    Seems it was the gameconfig file not allowing numerous cars. So got them back in but have a weird problem with some of the cars tail lights, they don't seem to look red on some models or they are dim red on some. ill try and find and example of it with some pictures.



  • @Christian6984
    Barring some other glitch I've never heard of, modded cars have different brightnesses of lights. They are not all the same. If they worked before & now are broken then that's something else & I have no idea what. Before & after pics would illustrate this very well. Here is some info anyway on lights that may help you out in finding a possible workaround:

    Tail light brightness (& other car lights) can be edited in 'visualsettings.dat' using settings under the heading 'emissive bits':

    emissive bits
    car.headlight.day.emissive.on 10.00
    car.headlight.night.emissive.on 10.00
    car.headlight.day.emissive.off 0.05
    car.headlight.night.emissive.off 0.001
    car.taillight.day.emissive.on 44.0
    car.taillight.night.emissive.on 3.0
    car.taillight.day.emissive.off 25.0
    car.taillight.night.emissive.off 3.0
    car.indicator.day.emissive.on 10.00
    car.indicator.night.emissive.on 10.00
    car.indicator.day.emissive.off 0.30
    car.indicator.night.emissive.off 0.003
    car.reversinglight.day.emissive.on 20.00
    car.reversinglight.night.emissive.on 3.00
    car.reversinglight.day.emissive.off 0.10
    car.reversinglight.night.emissive.off 0.003
    car.defaultlight.day.emissive.on 50.50
    car.defaultlight.night.emissive.on 10.50
    car.defaultlight.day.emissive.off 0.003
    car.defaultlight.night.emissive.off 0.003
    car.brakelight.day.emissive.on 56.00
    car.brakelight.night.emissive.on 30.00
    car.brakelight.day.emissive.off 25.0
    car.brakelight.night.emissive.off 3.0
    car.middlebrakelight.day.emissive.on 56.00
    car.middlebrakelight.night.emissive.on 30.00
    car.middlebrakelight.day.emissive.off 25.0
    car.middlebrakelight.night.emissive.off 3.00
    car.extralight.day.emissive.on 9.00
    car.extralight.night.emissive.on 9.00
    car.extralight.day.emissive.off 0.005
    car.extralight.night.emissive.off 0.005
    car.emissiveMultiplier 2.00

    These settings apply globally (ie to all vehicles) & be aware that 'car.defaultlight' affects Police siren lights & dashboard lights brightness. Afaik they can't be easily edited independently of one another. If I want truly bright emissive police lights I have to edit the dashboard textures of certain cars independently (where possible) to make them dimmer to compensate.
    Also, those are just my preference settings with tail lights always on in the day as well as at night & brighter brake lights so they stand out (just prefer that look). It's combined with a modded ENB which can also control emissive brightness of car lights globally. If you go this route you'll have to experiment with the settings & find what works for you. It will be about finding the right balance for you. ENB settings are a nice easy place to start with instant visual feedback (can't remember exact setting but it's under the vehicle settings & should be easy to find :thumbsup: )

    Other solutions I've found (where possible, not always) is editing the texture for the tail lights independently in each cars .ytd (changing the colour or transparency to make the lights appear brighter/more red etc).



  • @JonaQ Could just be me being paranoid after not being able to play the game for a while due to the problems i struggled to overcome and re-putting all the mods back in place. If it starts to bother me i will get some photos, i cant get the before's but can always see it if differs to the photos on the vehicles write up.

    thanks for the advice on the manual adjustment of lights i guess that would be an option if needs be. The Peugeot 207 GT for example seemed to have kind of see through lights other day yet next day they seemed more red? some of the Lamborghini have very faint brake lights out in the daylight. They could have always been like this and maybe i never noticed, unsure at present but will look into it. Once again Thank You :)


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.