Log in to reply

Do old add-on cars not work? (.GXT2 crash?)

  • So for the past few days I've been installing the newest add-on cars to this site, and they seem to work.

    I tried some from early 2017 and summer 2017, but they always seem to crash my game after selecting "single player" when loading the game.

    Obviously, taking the car out of the game fixes the issue, and the game doesn't crash. Is this some sort of compatibility issue? Open IV was installed correctly, and the car was as well. The only thing I did to all the cars (including the 2017 ones) was edit the .gxt2 files so they would have proper names in-game. For example, there was a vehicles.meta file but no lang folder, so I created one in x64 -> data -> lang -> americandlc.rpf -> global.gxt2. That is where the lang folder and gxt2 file goes every time, if the developer chooses to have different languages.

    How could adding a .gxt2 file crash the game entirely? And how do car mods work without one, maybe it's some sort of directory error (where the game can't allocate the names / files)?

    I also tried installing the gameconfig.xml file that was updated 3 days ago, but the car still crashes the game.


    Removing the car from the x64 -> dlcpacks folder seems to fix the issue. Not sure why car mods crash the game, when I install them correctly. Are they outdated in respect to the GTA5 version?

    I'm pretty sure it's not the .gxt2 file either, so it has to be the actual car mod or .rpf

    Here is the launcher log, by the way (sorry about emojis, due to site formatting):

    [2018-04-03 15:51:37.377] [DISPLAY] Using DPI 96
    [2018-04-03 15:51:37.433] [DISPLAY] File version 10000:5550001 (for D:\Games\steamapps\common\Grand Theft Auto V\GTA5.exe)
    [2018-04-03 15:51:37.489] [DISPLAY] File version 10002:30008 (for C:\Program Files\Rockstar Games\Social Club\socialclub.dll)
    [2018-04-03 15:51:37.533] [DISPLAY] File version 10000:5550001 (for D:\Games\steamapps\common\Grand Theft Auto V\GTAVLauncher.exe)
    [2018-04-03 15:51:37.549] [DISPLAY] Version: |1.0.1365.1||1.0.1365.1|FSP
    [2018-04-03 15:51:38.014] [DISPLAY] OS version: Major: 6, Minor: 2, Build: 9200, Platform: 2
    [2018-04-03 15:51:38.172] [DISPLAY] Steam initialized successfully
    [2018-04-03 15:51:38.176] [DISPLAY] Steam id: 76561198120457766
    [2018-04-03 15:51:38.181] [DISPLAY] Steam offline: FALSE
    [2018-04-03 15:51:38.185] [DISPLAY] Steam persona: LazerGreen
    [2018-04-03 15:51:38.205] [DISPLAY] Social Club initializing...
    [2018-04-03 15:51:38.732] [DISPLAY] Attempting to create device...
    [2018-04-03 15:51:38.737] [DISPLAY] Attempting to initialise DX9 COM object...
    [2018-04-03 15:51:38.755] [DISPLAY] Window size: 690 x 496
    [2018-04-03 15:51:38.827] [DISPLAY] Successfully created DX Device!
    [2018-04-03 15:51:39.330] [DISPLAY] Geo: US
    [2018-04-03 15:52:10.996] [DISPLAY] Privilege 7 - True - permanent.
    [2018-04-03 15:52:11.596] [DISPLAY] Launching game...
    [2018-04-03 15:52:11.600] [DISPLAY] (path: D:\Games\steamapps\common\Grand Theft Auto V\GTA5.exe cmdline: "D:\Games\steamapps\common\Grand Theft Auto V\GTA5.exe")
    [2018-04-03 15:55:16.785] [ ERROR ] GameComm: ReadFile failed.
    [2018-04-03 15:55:19.453] [DISPLAY] Game exited with code 0x0
    [2018-04-03 15:55:21.058] [DISPLAY] Uninitializing.


    @BinaryGreen how many have you added? have you downloaded a game config?

  • Seems that I sort of fixed the issue.

    It ended up being the gameconfig, even though I already installed the one by YCA, that didn't work. I installed F7YO's and now the car mod works.

    I have 4 car mods as well.

    The only thing that bugs me is being unable to change the car name using a gxt2 file, hm.

    I'm wondering how to change a vehicle's in-game name (add-on car), it doesn't work for some reason.

    Like I said before, I added a data folder in the dlc.rpf's x64 folder, then made a lang folder, then made an americandlc.rpf folder, and put the new gxt2 file (that corresponds with the gamename and makename hashes)
    in there. To no avail, in the addon car spawner, it still shows up as "V242", not what I wanted, "Volvo 242 Turbo".

    I'm wondering if this has to do with the developer, maybe I should add all of the languagedlc.rpf files in the lang folder, so it covers every language? I wonder if your language settings in GTA5 matter when it comes to which language rpf is used.


    @BinaryGreen it may be to do with content.xml, it may need to be put in there

  • I think you might be right. I looked at all the other car mods, and the Volvo car file does NOT have a dlctext file.

    If it DOES have a globaltext file, it will say "true" in dlctext.

  • @Reacon I wish I could +1 you 1000 times. Here's how I fixed the naming issue:

    1. All the other cars had a dlc.text file, which indicates that there is an alternate name for that car, not what the developer put in vehicles.meta

    2. Every car has a content.xml file, which points to the .META files (like vehicles.meta and dlctext.meta) inside the data folder, to tell the game to load those files.

    3. Also, if the developer is making the mod for multiple languages, they may include a data folder within the x64 folder of the dlc.rpf, then a lang folder with the 12 available languages (only matters for your selected language in GTA5 settings), each language .rpf has a .gxt2 file that points directly to the vehicles.meta names under makeName and gameName. It may also have the names of car mods, such as spoilers, bumpers, etc.

    1. The problem was, my car mod didn't have a dlctext.meta or a lang folder, as the developer just wanted to stick to the names in vehicles.meta (which makes the car names confusing).

    2. So I added a dlctext.meta file (which is the same for all car mods, you need to make sure that "hasGlobalTextFile" is set to TRUE.

    3. Then, you need to add two things in content.xml, so content.xml knows which files need to be loaded in-game.

    Under dataFiles:

    <overlay value="false" />
    <disabled value="true" />
    <persistent value="false" />

    Under filesToEnable:


    Replace NAME with the dlc name (usually folder name holding dlc.rpf, or the name in dlclist, or the other names in content.xml)

    So yeah, I thank you for helping me solve this issue that stumped me a few years back. Also helped me realize that there isn't that much code between two files, helped me simplify the concept.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.