Log in to reply

Realism Dispatch Enhanced 3.1.1 Memory Error crash.


    So, I decided to install Realism Dispatch Enhanced and my games just crashed at loading
    I fixed crashing but NOW while loading my game is showing an error: ERR_MEM_MULTIALLOC_FREE then it crashes.
    I tried to use many game configs I used config create for RDE, I tried many other configs. Nothing worked.
    Please help. I have script hook DOT net script hook and other stuff like that.
    I use script mods but before I installed RDE it didn't crash.
    Does anybody have a fix?

  • @Mrug
    Have you tried this gameconfig?

    Try this mod also. It can fix some 'ERR_MEM_MULTIALLOC_FREE' errors. Probably a good mod to have installed anyway, so if you want you can leave it activated (even if it doesn't fix your problem). I have it installed & it has never given me any trouble.

    Did you install RDE to a clean mods folder?
    "IT IS HIGHLY RECOMMENDED TO USE A CLEAN MODS FOLDER WHEN UPDATING TO 3.1.1! Smuggler's Run DLC update (v1180) required!"
    Maybe move you RDE mods folder somewhere & try a fresh mods folder & RDE install, see if you get the same problem or not.

  • I removed all mods and installed in the clean mods folder. Didn't work.
    I tried this config. Didn't work.

  • @Mrug
    Did you try the Heap Limit Adjuster as well?
    I see in the RDE comments that a lot of people are having various crashes. I myself opted to uninstall RDE due to various crashes & general instability as well. I've since build my own dispatch etc from scratch. My game is now 100% stable, it never crashes, not ever!
    So it is possible :thumbsup:
    I would either learn to make your own dispatch (it's pretty easy) or if you must have RDE then it will be a case of testing (ie remove/replace/replace with vanilla etc) individual files/scripts etc to see if you can identify what is causing the crash. Start by replacing all the RDE 'vehicles.meta' back to vanilla & then maybe try 'handling.meta'/'dispatch.meta' etc until you find something that stops the game crashing then inspect that/those files for problems. Keep backups along the way.
    Have you tried a fresh RDE install with minimum add-on options selected in the installer? Try & keep RDE as close to vanilla as possible.
    After that you are looking at replacing ped/vehicle models back to vanilla ones as crashes may reside there. Start with the most un-vanilla of vehicles/peds & then work through each one by one.
    Note You can stop police vehicles & peds from spawning by removing their entries from 'dispatch.meta' which will make this process a lot quicker than manually removing vehicle files etc

    You could also give Dispatch of Variety [Addon][.OIV] 4.0.0 a try.

  • Oh man. RDE Looked so good, and I can't use it.
    Damn it.
    But anyway, thanks for your help and engagement.
    Really appreciate your help.

  • To be fair RDE has not been updated since September 24th, 2017 and is only compatible with GTAV up to and including compatibility with Smuggler's Run DLC update (v1180). Game versions newer than this are not supported and therefore may or may not work. If it works, great, if not then you're SOL until the mod team behind it can patch it. Keep in mind that they are unpaid volunteers doing this in their free time and real-life responsibilities come first always. Ergo you'll have to either live with the issues until patched or uninstall it for now.
    They have a discord channel where you can keep apprised of updates too.

  • @a63nt-5m1th Even better. Dispatch of variety crashes too.

  • @Mrug

    Unlucky :/ Another 'ERR_MEM_MULTIALLOC_FREE' error or a new one?

    Just as a test try taking your original/vanilla gameconfig.xml from:

    \Grand Theft Auto V\update\update.rpf\common\data\gameconfig.xml

    Install it to your mods folder:

    \Grand Theft Auto V\mods\update\update.rpf\common\data\gameconfig.xml

    & see if you still get crashes?

    Also, what version of the game are you running? (1.0.1365.1? etc).

  • @Mrug Hey man I've experienced this too, Someone posted a fix for this but after an hour of gameplay their game will just crash? If you want to check it out here "https://www.gta5-mods.com/misc/realism-dispatch-enhanced#comments_tab" or if you want just check out the comment section of the "RDE 3.1.1" look for the name "hoseclamp" he posted an answer about the crashing he got it to work, So about the gameconfigs most of them won't work you can download F7YO's gameconfigs and see if it works (The only gameconfig that worked for me) here's a link - https://www.gta5-mods.com/misc/gta-5-gameconfig-300-cars just check it out if it works for you, (Please reply to me if I have violated a guideline about linking mods thank you) and btw I never tried it but I hope it does for you I'm still downloading the file.

  • https://it.gta5-mods.com/misc/hazard-gameconfig-1-0-1493-0 Try this gameconfig, this gameconfig delete all add-on limits. For me it's work.

  • But......this CAN be updated by any person who wants it bad enough. It's not just the gameconfig that needs attention, but there are likely other files in there that also needs updating. It's just a matter of comparing files with the latest files per DLC, and merge any changes that have been added since this was released. I don't use it myself, but I could look at this, and make compatible with After Hours DLC. Without the Mod author's permission, all I could do is merge any changes, and then provide a link to it here.

  • I had the same problem...with RDE & Vanilla Extended.I had all of them installed including dispatch works and a really lot more and suddenly started to had those memory error like after 15-30 mins of gameplay. So I removed all the mods and tried one by one and found that its only 2 mods that created the memory error for me and that were RDE & Vanilla extended.

    I know I had a good gameconfig because I had like 120+ addon vehicle 3 maps addon dlc and la billboards & road , ymap and so much.Unfortunately no solution was there that I could find so just uninstalled both and moved on.:dragon_face:

    Maybe it's due to rockstar games updates but maybe it's due to that those mods have been finalized and not updated any more.I don't know much about them as never played them completely.:confused:

    Good luck:boxing_glove: :dragon_face:

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.