Log in to reply
 

Crashes when using mods; "Out of game memory". Help?



  • Hi,

    Whenever I play with mods, I get this error: "ERR_MEM_EMBEDDEDALLOC_ALLOC" and then "Out of game memory. Please reboot and restart the game."
    I have tried to change the page file size and a few other things but they don't help.
    It only occurs after playing with mods for a good half hour. Then it crashes when I press escape to go to the map.

    Any thoughts?



  • @Josh1dfs
    Legit version of gta?
    All mods updated?

    NaturalVision Photorealistic Can crash when using a mod menu like menyoo,Simpletrainer or something else
    Remove all mods and instal just a few to see what cause the crash
    Just put the mods folde ron desktop and make a new one so you got the old one as backup for all mods.



  • @yeahhmonkey Yeah, it's the retail version, using social club.

    I'm only using openiv and ENT, I don't think that's the issue.



  • @Josh1dfs Are you using car/Motor mods?
    A gameconfig mod could help you in this case.

    or A time a go motor mods can cause crashes we don't really know why but the old mods do this memory thing.
    disable openiv.asi to and play a bit. so we could test if it's a car/motor problem please.

    I'm 80% sure this has to be the issue.



  • @yeahhmonkey

    Yeah, playing without any mods seems to work just fine.
    I have an edited gameconfig file, although I'm not really sure if it does the job just fine.
    I don't think I have any motor mods installed. Plenty of car mods though, I'm guessing probably close to 40.

    Any suggestion for another gameconfig file?



  • @Josh1dfs https://www.gta5-mods.com/misc/gta-5-gameconfig-300-cars

    It's pretty much the goto config... lots of variations on traffic density and good stability.



  • @Josh1dfs Yes just what LeeC2202 says
    I'm using the same normal traffic of https://www.gta5-mods.com/misc/gta-5-gameconfig-300-cars

    I think you got yourself some work todo.

    When this gameconfig is not helping you i would start a new mods folder and instal some cars then play a bit. then instal some more and re do the steps to see if this works for you.
    because now you don't know what mod is causing the crashes.



  • @yeahhmonkey @LeeC2202
    Okay so I just installed that gameconfig and uninstalled quite a few cars.
    There was an improvement, as in, it crashed after like 1,5 hours of playing.
    It still crashed however. Do you think the issue lies within a specific car?
    I'll uninstall some more cars.

    Thanks for the help.



  • @Josh1dfs You should rebuild all your .rpf, it can help a lot. I also had some crash, at randomly place, and time played. This solved every issues



  • I'm lost, how do you rebuild the rpf? I don't see that option anywhere. It IS in OpenIV right?



  • @GetTheClicker File > Rebuild



  • I'll have to wait... I am in the middle of the defrag option. When you rebuild the rpf does it replace or change any modded car?

    I do not see that option.... create or open archive, read only mode, reopen, defrag, archive properties... are my only options



  • @GetTheClicker I've just noticed, it's in v2.6 which I use in my Windows 7 install but not there in v2.8 which i use in Windows 10. Maybe it isn't used anymore... sorry for the confusion, I use different versions of different software in different installs to give myself a variety of scenarios for my mod testing.



  • Yeah, I too have windows 10 and version 2.8. I'm fine in free mode but as soon as I start with the missions I crash even if there isn't a modded car in sight. The most recent error is out of memory and all my replaced/added cars are stable in free mode but I crash while in a mission.



  • @GetTheClicker That's actually very odd. Mine would just crash randomly. In fact, when I press escape, it crashes, yet only after a bit more than an hour. I'm still not sure what actually causes the crashes. I've uninstalled most of the cars now, but will continue to do so until I find the culprit. Thanks for the replies.



  • I never ever rebuild. No crash at all. No lag. Nothing!
    Yeah maybe it's a car/motor like i said. Make a new mods folder and start installing mods for the beginning lool



  • @GetTheClicker It's defrag



  • @yeahhmonkey I've uninstalled most if not all. Seems to be good for now.
    Thanks to all of you for the help. ( @GetTheClicker @LeeC2202 @yeahhmonkey @baba0rum )




Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.