Log in to reply
 

Loading saved games from within GTA V crash



  • Hi,

    I recently resolved an issue with GTA V crashing when loading a new game from within GTA V by deleting the profile folder in the save game location in the rockstar games folder. Loading an existing save is the only way to start a new game from the in game menu unless you delete the files I did. This initially fixed that issue where a new game would not start.

    I can load a story mode game from the main menu and it will load the latest save I have so that's fine. Within GTA V, however, loading a save game causes the game to crash.

    I have looked into scripthook logs and they look good.

    / GTA V SCRIPT HOOK (build Mar 28 2018, v1.0.1365.1)
    // (C) Alexander Blade 2015-2018
    [22:23:16] INIT: Started
    [22:23:16] INIT: Success, game version is VER_1_0_1365_1_STEAM
    [22:23:16] INIT: Registering script 'NativeTrainer.asi' (0x00007FFEFAA6A3C0)
    [22:23:16] INIT: Registering script 'ScriptHookVDotNet.asi' (0x00007FFF05891380)
    [22:23:16] INIT: Registering script 'timecyclemods.asi' (0x00007FFEFB212480)
    [22:23:34] INIT: Pool 1 extended
    [22:23:34] INIT: Pool 2 extended
    [22:23:34] INIT: Pool 3 extended
    [22:23:34] INIT: Pool 4 extended
    [22:23:39] INIT: GtaThread collection size 189
    [22:23:39] INIT: wnd proc 0x00000000FFFF0AAD
    [22:23:39] INIT: IDXGISwapChain 0x00000001800CFFD8 (0x000000018001AEB0)
    [22:23:39] INIT: IDXGISwapChain set
    [22:23:39] INIT: DX init started
    [22:23:39] INIT: DX feature level B000
    [22:23:39] INIT: DX init succeeded
    [22:24:42] CORE: Requesting thread creation
    [22:24:42] CORE: Creating threads
    [22:24:43] CORE: Started control thread, id 42 active 1
    [22:24:43] CORE: Started thread 'NativeTrainer.asi' (0x00007FFEFAA6A3C0), id 43 active 1
    [22:24:43] CORE: Started thread 'ScriptHookVDotNet.asi' (0x00007FFF05891380), id 44 active 1
    [22:24:43] CORE: Started thread 'timecyclemods.asi' (0x00007FFEFB212480), id 45 active 1
    [22:24:43] CORE: Launching main() for 'NativeTrainer.asi' (0x00007FFEFAA6A3C0), id 43
    [22:24:43] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FFF05891380), id 44
    [22:24:43] CORE: Launching main() for 'timecyclemods.asi' (0x00007FFEFB212480), id 45

    Looking at scripthookVDotNet2 logs shows this. I don't have a script directory in my main folder

    [22:24:43] [DEBUG] Created script domain 'ScriptDomain_6F8D2AF2' with v2.10.6.
    [22:24:43] [DEBUG] Loading scripts from 'C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\scripts' into script domain 'ScriptDomain_6F8D2AF2' ...
    [22:24:43] [ERROR] Failed to reload scripts because the directory is missing.

    However, the crash did not happen at 22:24:43, it would have happened about 22:28 so I don't think DotNet is causing this. (It would crash before installing Dot net) I have no trainers installed. Also scripthookdotnet says to you the insert key (I assume in game) to load scripts. I tried, nothing happen, still no script directory in main game folder.

    Are there any other logs I can access that I may have missed? Anyone suggest anything for me?

    I have mods like this to name a few:

    NVR with ENB files
    Water 1.7
    LA Billboards
    Project reload texture patch
    Real California Architecture
    LA ROADS
    LA Vegetation
    VisualV
    Using OpenIV 3.0

    No trainers like Menyoo Release yet.

    Cheers

    EDIT: I manually added the script folder in the main folder and it may have fixed that issues. No more errors but there is nothing in that folder anyway /shrug

    [22:53:30] [DEBUG] Created script domain 'ScriptDomain_F56DA482' with v2.10.6.
    [22:53:30] [DEBUG] Loading scripts from 'C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\scripts' into script domain 'ScriptDomain_F56DA482' ...



  • Love? :(



  • OK so after suspecting the issue may be caused by Natural Vision Remastered I read up on the notes there and found the author updated his mod 3 days after releasing a new version. One of the fixes was to stop crashes with Rockstar editing and loading save games.

    Long story short, I'm very confidant that I downloaded on my PC the original updated version released on March 20th on about the same date in preparation for modding GTA V which I have now done almost a month later. On the 23rd March a new update was released but placed under the same update that was released on the 20th... and then again on the 24th which I think is a big mistake on the mod authors part for not releasing a new version.

    I'll will confirm which version I have later tonight and if the times stamps on that are 20th march it may very well be the cause of this issue.

    I will report back later so that future users can use this as a base.



  • OK I confirmed the files were dated 20th March. The new set I downloaded are dated 24th as explained above. The save games load fine and new games can be created without a crash.

    Thanks guys for all your input and help... :bleh:


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.