Log in to reply
 

ScriptHookDotNet not working



  • Hey, I've attempted to try and fix script hook dot net but it seems to not load, I have other script mods such as custom peds open interiors which I'm pretty sure dont need .NET I'm pretty sure it's not a conflict of mods just the fact that script hook .net isnt loading as ive read before one way to see if it hasnt loaded in is to check for a log file which I dont seem to have only ScriptHookV log file.. Been trying to fix it for awhile; Ive tried re installing script hook v and .NET but just doesnt seem to work.. Any suggestions?



  • @ItsInk dot net's log is called ScriptHookVDotNet2 look for that in the directory



  • Not there bud, I only see ScriptHookVDotNet2 and ScriptHookVDotNet2.dll and the one which isn't a dll is a XML which pretty sure is the actual mod/script itself

    xx



  • @ItsInk okay. What game version are you running? Tried reinstalling?

    EDIT: just realised you said you had tried reinstalling



  • Latest version of steam version.
    Re-installed and re-installed both script hook and script hook.net
    still same issue. I know what the issue is it's that scripthook.net isnt running I may have installed wrong or I am missing things for it to work.

    Just to clarify it should be installed in the root of GTA V which I have done so.

    (C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V)



  • @ItsInk yeah that’s where it goes, try making sure you 100% have the most recent version as well

    Also: when you reply, can you tag me in it so I can see when you reply



  • @ItsInk If there is no ScriptHookVDotNet2.log in the root installation folder it means scripthookV didn't load shvdn for an unknown reason. Please show us the ScriptHookV.log and the asiloader.log.



  • @Reacon everything is 100% up to date as far as I know.
    @Cyron43 and yes, what I thought scripthookdotnet wasn't loading
    http://prntscr.com/jdqhi8

    photo contains both of the logs plus with my root of gta



  • @ItsInk EnhancedMeleeeCombat seems to be a .net mod and hence belongs in the scripts folder but it's somewhat hard to tell because known file extensions are suppressed. You don't need ScriptHookVDotNet2.xml. That's for developers only. Which shvdn version is installed? Get rid of LUA. That thing is outdated.



  • @Cyron43 yeah I know it is a .net mod I just moved it in there to see if that would help and haven't been able to move it back as well no matter where it was didnt help :|
    and I have the latest version of shvdn which is 2.10.6
    and from what I am aware of this is the right one (https://www.gta5-mods.com/tools/scripthookv-net) as thats the one I have download. I believe I may not have everything installed for shvdn to actually run. Not talking like all the visual basic stuff all of that is up to date more of I think I may be missing a file inside gta, but I don't know.





  • @Cyron43 yep installed latest one.



  • @ItsInk Well have you deleted ScriptHookVDotNet2.xml and the LUA crap (LUA fails anyway)?

    @ItsInk said in ScriptHookDotNet not working:

    may be missing a file inside gta, but I don't know

    Run an integrity check. Here is how -> https://support.rockstargames.com/hc/en-us/articles/205778987-GTAV-PC-General-Troubleshooting-Installation-Issues-Crashes-Freezes-Poor-Performance

    If that doesn't help either I can't see the reason why shvdn fails to load. Maybe report your problem on the shvdn issue tracker at https://github.com/crosire/scripthookvdotnet/issues



  • @Cyron43 Ah, I was talking about missing a file for shvdn. Or something is messing with it like a mod doesn't like it.
    I'll try taking out most of my mods and see if it wants to work then.



  • @Cyron43 after taking out a few mods and playing around still doesn't seem to work.. Though did figure out I get more fps with out cortex running so thats something aha


  • Banned

    @ItsInk Then you are doing something wrong. Your asi loader log should show scripthookv being loaded. It will look like this -

    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FFD0F970000
    API: "DirectInput8Create" => 00007FFD0F979C70
    API: "DllCanUnloadNow" => 00007FFD0F989C20
    API: "DllGetClassObject" => 00007FFD0F989CF0
    API: "DllRegisterServer" => 00007FFD0F9939C0
    API: "DllUnregisterServer" => 00007FFD0F993C30
    LOADER: Loading *.asi plugins
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\DismembermentASI.asi"
    "DismembermentASI.asi" => 00007FFD13380000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\GTAV.HeapAdjuster.asi"
    "GTAV.HeapAdjuster.asi" => 00007FFD0FB60000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\GTAV_LoadingFix.asi"
    "GTAV_LoadingFix.asi" => 00007FFD10AD0000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\InputSimulator.asi"
    "InputSimulator.asi" => 00007FFD07450000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\MeleeRiot.asi"
    "MeleeRiot.asi" => 00007FFD092B0000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\NoBoundaryLimits.asi"
    "NoBoundaryLimits.asi" => 00007FFD0F950000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FFD0EE20000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\PLD.asi"
    "PLD.asi" => 00007FFD070F0000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" => 00007FFD0F940000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\SimpleFootControls.asi"
    "SimpleFootControls.asi" => 00007FFD09400000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\StrappedLamar.asi"
    "StrappedLamar.asi" => 00007FFD070C0000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\timecyclemods.asi"
    "timecyclemods.asi" => 00007FFD07050000
    LOADER: Finished loading *.asi plugins



  • So ive been following all the conversations and I cant figure out why it's not working I updated everything and game still crashes on me. Please help.



  • So I figured it out! It was the menyoo mod I removed it from my gta v main directory.



  • @nebur78045 said in ScriptHookDotNet not working:

    So I figured it out! It was the menyoo mod I removed it from my gta v main directory.

    why post on here? Not being rude pretty sure I made this post for a scripthook error. If you had an issue make a post about it..

    @eshenk yep I am aware I probably have done something wrong.
    Im planning to just uninstall everything and re install it all again.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.