Log in to reply
 

Added car and Aircraft mods not appearing



  • @Turrel81
    Post a screenshot of your 'dlclist.xml' :thumbsup:

    Perhaps try re-installing OpenIV's 'ASI loader' & 'OpenIV.asi'

    OpenIV > Tools > ASI Manager > [Uninstall] > [Install]

    Also various logs (ScriptHookV.log/OpenIV.log etc) may be of use.

    Tip: You can delete the log files from the main GTAV folder & then load the game to get clean ones focused on just that load if you like (less data to look through/easier to post/upload if your log files are bloated).





  • @Turrel81

    Can you confirm your 'dlclist.xml' has

    "<?xml version="1.0" encoding="UTF-8"?>"

    at the top of it?

    Example:

    <?xml version="1.0" encoding="UTF-8"?>
    <SMandatoryPacksData>
    	<Paths>
    		<Item>platform:\dlcPacks\mpBeach\</Item>
    		<Item>platform:\dlcPacks\mpBusiness\</Item>
    		<Item>platform:\dlcPacks\mpChristmas\</Item>
    		<Item>platform:\dlcPacks\mpValentines\</Item>
    		<Item>platform:\dlcPacks\mpBusiness2\</Item>
    		<Item>platform:\dlcPacks\mpHipster\</Item>
    		<Item>platform:\dlcPacks\mpIn...
    

    I don't think it makes much difference whether it has that line but just want to confirm the top of your dlclist is good as your pic starts on line 3.

    Other than that I'm a bit stumped :/

    Post you log files here (you can use pastebin if it makes things easier)


  • MODERATOR

    @a63nt-5m1th positive it is required



  • @Reacon
    That's what I would have thought too but I tested missing out the
    '<?xml version="1.0" encoding="UTF-8"?>'
    line & having 2 blank lines at the top & my dlc addons still work/spawn/no crashes etc.

    Like this:

    --------------------------------------------------------------
    
    
    <SMandatoryPacksData>
    	<Paths>
    		<Item>platform:\dlcPacks\mpBeach\</Item>
    		<Item>platform:\dlcPacks\mpBusiness\</Item>
    		<Item>platform:\dlcPacks\mpChristmas\</Item>
    		<Item>platform:\dlcPacks\mpValentines\</Item>
    		<Item>platform:\dlcPacks\mpBusiness2\</Item>
    		<Item>platform:\dlcPacks\mpHips...
    

    Perhaps dlclist.xml or just my dlclist.xml is a special case. With Rockstar, could be Unicorns :slight_smile:



  • @Turrel81

    Confirm that your 'dlclist.xml' is installed here:

    ...\Grand Theft Auto V\mods\update\update.rpf\common\data\dlclist.xml

    as there are 2 'dlclist.xml' in the game. One in 'common.rpf' & one in 'update.rpf'. The one in 'update.rpf' in the folder structure above^ is the one the game loads. The one in 'common.rpf' is only loaded if the one in 'update.rpf' is missing/installed incorrectly etc

    Tip: You can use Ctrl+F3 in OpenIV to search for files (with options to search mods folder only, game folder only or both).

    Try another trainer (ENT or Simple Trainer etc) & see if you can spawn the cars with either of them? This will eliminate Menyoo as a possible cause.

    If neither of those ideas work post you log files here (you can use pastebin if it makes things easier) :thumbsup:



  • @a63nt-5m1th 0_1526412742115_dlccfg.jpg
    0_1526412922215_dlcopeniv.jpg

    I haven't run Gta5 yet i need to make sure everything set up properly so no log files have been generated yet.



  • Just to let you know the game is crashing.
    <script src="https://pastebin.com/embed_js/mEQTzWcR"></script>
    <script src="https://pastebin.com/embed_js/a2h3SLQf"></script>



  • @Turrel81
    Any error message for the crash?

    I also noticed in your main GTAV folder pic above^ it looks like you have put the contents of your 'menyooStuff' folder into your main GTAV root folder? All the folders/files that were in the downloaded 'menyooStuff' folder should stay there & not be moved/duplicated anywhere else.
    I would advise clearing all of those files & folders (see pic below) out of the GTA V root folder as having extra things in the games working directory may cause things to get messed up (it's just good practice not to do it. I don't know Menyoo very well so I can't account for what effects having those files sitting there might do).

    menyooStuff folder:

    alt text

    To install Menyoo you just put the downloaded 'Menyoo.asi' & the 'menyooStuff' folder into the main GTA V root directory (where GTAV.exe is). That's it, you don't move any other files or anything.


  • MODERATOR

    @a63nt-5m1th could be the crash reason!nice catch



  • Nah, it's still crashing. plus open up in windowed mode,


  • MODERATOR

    @Turrel81 did you get an error? e.g err_embbededalloc_guard_1



  • @Reacon Nope it jus crashes, removed menyoo and scripthook.vnet to be sure.



  • @Turrel81

    As far as the crash is concerned, have you tried deleting 'settings.xml'?

    C:\Users\USERNAME\Documents\Rockstar Games\GTA V\settings.xml

    Make a backup of it if you want & then delete it from that folder & then start the game to create a new one.

    How long ago did your game load correctly without the error?
    What have you edited since then? (given that your game certainly worked previously the crash is most likely human error (although corruption etc can't be ruled out))

    Have you edited any of your vanilla game files (ie files outside of your 'mods' folder)?

    If not, & you are sure the main game files are all vanilla & work correctly (easy to check by uninstalling OpenIV's 'OpenIV.ASI' plugin) then I would just delete your 'mods' folder (keep backup if you like) & start again. Rebuild it from scratch once you have confirmed that the vanilla game loads without errors.

    The secret to GTA V modding is to be methodical, always keep backups & try not to change too many things at once without testing each change thoroughly in game first. That way if you encounter a crash you'll notice it straight away & can revert your changes. :thumbsup:



  • Even in safe mode it still crashes, btw i copied the entire game folder before i reformatted so i could replace any files.
    0_1526655317128_dlc.jpg



  • @Turrel81
    Things have gone wrong (new crash) since you started this thread. That would tend to suggest that your game is not in the best of shape (or that you need to be sure you know exactly what you are doing while modding the game. Make sure you read & most importantly understand the readme's that come with a mod before installing any of them. If you have any doubts about something it's much safer to ask a question here in the forums than just install it & hope for the best :thumbsup:).

    Option A - Spend days/months/years trying to fix every little error that may pop up from now on & risk growing old :older_man_tone1: & dying having never got to play the game modded.

    Option B - Purge. Delete 'mods' folder completely. Reinstall the game & start TOTALLY 100% from scratch. Burn it all. :slight_smile:

    From what you have said it sounds like you haven't made any major changes to your install that you will lose by starting anew. So I'd advise you to reinstall/get you files back to 100% vanilla. By all means use your backup (if it works correctly) but sometimes it's just best to burn it all & start again with a fresh install.





  • I have done a reinstall, mods folder and the native trainer have been placed in GTAV folder, no mods or menyoo and at the moment it's running ok, also no scripts folder, I have copy pasted the entire contents to my external HDD.



  • @Turrel81
    Nice :slight_smile: just install one mod at a time from now on.

    • Check if the mod works correctly & that there are no errors/crashes (play for a little bit & test out what you have newly added. Put it through it's paces in various scenarios so you're confident it's stable before moving on to the next mod).

    • Always, ALWAYS make a backup each time you add a mod (just a backup of the files or the rpf archives (if you have tons of space that's my preference) the mod alters is fine, you don't have to backup the entire mods/game folder each time you add a mod)

    • If something goes wrong revert to your last backup file/rpf.

    That way you are always only one step away from recovery :thumbsup: The game is very modular, very interchangable, so a good multiple backups strategy can often aid in diagnosing errors/crashes also. This 'update.rpf' works while this one does not etc

    I recommend editing text files (.xml, .dat, .meta etc) with Notepad++ & it's XMLTools plugin (< can be used to find syntax errors. Very useful).

    Ctrl+F3 in OpenIV can be used to search for file names.

    Best of luck :thumbsup:



  • @a63nt-5m1th Installed Menyoo left scripts folder empty, still works fine, i've installed this mod but it still does not appear in spawn menu. https://www.gta5-mods.com/vehicles/supermarine-spitfire-mk-iib.
    i have followed it to the readme to the letter.



  • @Turrel81

    Checklist:
    Check that the spitfire dlc.rpf is installed here:

    \mods\update\x64\dlcpacks\spitfire\dlc.rpf

    & your dlclist.xml looks somewhat like this (ie the syntax is correct. '<Item>dlcpacks:\spitfire</Item>' line is somewhere below the '<Paths>' line but above '</Paths>'):

    Example:

    <?xml version="1.0" encoding="UTF-8"?>
    <SMandatoryPacksData>
    	<Paths>
    		<item>dlcpacks:\LA_ROADS\</item>
    		<Item>dlcpacks:\EMF\</Item>
    		<Item>dlcpacks:\addoncars\</Item>
    		<Item>dlcpacks:\spitfire\</Item>
    	</Paths>
    </SMandatoryPacksData>
    

    That's all you should need to spawn the spitfire by name "spitfire".

    The 'extratitleupdatedata.meta' data is not required to spawn any vehicle. I opt not to bother adding any 'extratitleupdatedata.meta' data when it tells me to in any readme & I have never had a single problem. Installing it (correctly) will do no harm so it's entirely up to you. I just wanted to let you know that it can be skipped safely if you wish to save time installing vehicles etc.
    If you have the vanilla 'extratitleupdatedata.meta' backed up I would at this point put it back into the game just so any possible error you may have made adding the data to it can be eliminated. Just the quickest way to eliminate it as a variable. Backup the one you have installed if ya like :thumbsup:

    I don't have Menyoo so I can't account for the procedure required to spawn vehicles (adding to spawn menu etc). The readme is sparce & I get a scripthook crash when I try to load the game with Menyoo installed so I can't test it quickly.

    To eliminate Menyoo as a variable you could download ENT (Enhanced Native Trainer)

    • Install it (place 'EnhancedNativeTrainer.asi' & 'ent-config.xml' in GTAV root directory (ie where 'GTA5.exe' is))
    • Load the game
    • press F4
    • Navigate (d-pad or 2,4,6,8 on numpad (5=select. 0=back)) to
      'Vehicles' > 'Vehicle Spawner' > 'Enter Name Manually' > Then type 'spitfire' in black box that appears & then hit Return/Enter

    If the Spitfire spawns then it is installed correctly & what you are probably missing is just the procedure required to set Menyoo to spawn said vehicle. Try that (above^) out & let me know how you get on :thumbsup:



  • @a63nt-5m1th
    Success! I left the extratitleupdate as it was with the changed line in, and used Menyoo to spawn,
    the only difference was the dlc text was in line with the rest at the bottom, even though i have tried to line it up it never fits when displayed in openv, going to try with another mod.

    0_1527170941501_20180524150001_1.jpg

    0_1527171345238_dlctext.jpg



  • @Turrel81
    Nice :slight_smile:, let us know how you get on :thumbsup:



  • I added a couple of more mods then it crashed, removed them and all was fine.
    Might be my gameconfig, how do i manually change so i don't run out of mods to add? also, i can't seem to get the text to line up properly.
    0_1527265282542_dlctext.jpg



  • @Turrel81
    dlclist.xml:
    Yeah, I'm not sure what is happening at the bottom of your dlclist?! I ain't liking the look of all those dots. They look like they are capable of messing things up.
    I would just extract text files (.xml, .dat, .meta etc) using OpenIV & then edit them with Notepad++. You'll find it's much easier to work with than a basic text editor (Notepad/OpenIV etc).
    Notepad++:
    In Notepad++ there is a vertical red line that appears when you click on a line in a text file that indicates where a block of data starts & ends (it's VERY useful!) & Notepad++ also has plugins like the essential XMLTools which can be set to automatically check for syntax errors in the files you edit (great for catching a tired silly mistake or even files from a downloaded mod that still have errors in them (I've found a few in my time)). XMLTools has single-handedly saved me days of grief. I cannot recommend it enough :thumbsup:

    Gameconfig.xml:
    The basic process would involve you trying out a few of these gameconfigs & seeing which one fixes any problem you have. I use this one but it may be worth trying a few of the better known ones out to see what works best for you (there are many variables). I'd say it's also best to select one that is specifically designed for your version of the game (1.0.1365.1 etc). Things may change as you continue to mod the game & you find your modded gameconfig no longer cuts it. It would then just be a matter of testing out a new one. It's a very simple process. You try till you find one that works for you.
    Note: Even with a modded 'gameconfig.xml' there is still a dlc limit (it's just a bit higher is all). If you plan to install a lot of vehicles you'll have to look into using a mod like this to create your own add-on vehicle pack. Don't worry about it at the moment, just remember it exists if you need it. :thumbsup:


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.