Log in to reply
 

Online interiors - problem loading mp map



  • Can anyone assist me with installing Online interiors? I'm unable to load the multiplayer maps through online interiors unless I use a trainer.

    • I have the latest update for gtav
    • Installed Open interiors and set mp maps to true
    • Have the latest scripthookV and scripthooVDotNet
    • Installed the latest NativeUI
    • Installed Microsoft Framework 4.7


  • @Gary41948 You mean Online Interiors V1 ? The naming convention can be slightly confusing, as it basically builds on the old openinteriors.asi mod. As such, it doesn't load mp maps itself (sic!), but relies on openinteriors.ini to contain the proper lines. To quote the doc:

    Open Interiors (Make sure to use the OpenInteriors.ini I provided, or open OpenInteriors.ini to change "loadMultiplayerMap=0" to "loadMultiplayerMap=1" and change "addInteriorBlipsAtStartup=1" to "addInteriorBlipsAtStartup=0".) 
    

    Or just add something like MpMap=1 to the TrainerV.ini file.



  • Sorry, yes I meant Online Interiors V1. Whats weird is that open interiors is supposed to load the mp maps but unfortunately it doesn't. If its possible I would really appreciate any suggestions.



  • @Gary41948 said in Online interiors - problem loading mp map:

    Sorry, yes I meant Online Interiors V1. Whats weird is that open interiors is supposed to load the mp maps but unfortunately it doesn't. If its possible I would really appreciate any suggestions.

    Hmm, that's weird. I have SPA load mp maps too, so it may well be openinteriors.asi isn't really loading them. But, like I said, if you have Simple Trainer, you can add MpMap=1 to the TrainerV.ini; that should get them loaded too.


  • Banned

    @meimeiriver I see that other people are somehow still using OAI, some mods even depends on it being installed. OAI died on me long ago, and could never figure why. But when I read somewhere by @Cyron43 that the code is poorly optimized, I ditched it.



  • @eshenk I was talking about SPA though. I can't decompile OAI because it's compiled C++ code and so I can't tell anything about it. Setting MP map activated is a bit tricky if you have a couple of mods doing it. I have Simple Trainer, OAI and SPA all capable of enabling MP map but not all have to be set to do so. Here is my working configuration:
    Simple Trainer: enabled
    OAI: eabled
    SPA: AlwaysEnableMPMaps "True" and NeverEnableMPMaps "True"

    SMH over these two contradicting parameters of SPA.


  • Banned

    @Cyron43 Yes, LOL.....Remember doing a "WTF" in my head, when reading how SPA had these parameters set in it's ini.



  • @Cyron43 said in Online interiors - problem loading mp map:

    SPA: AlwaysEnableMPMaps "True" and NeverEnableMPMaps "True"
    SMH over these two contradicting parameters of SPA

    If I recall correctly, the logic used was as follows: AlwaysEnableMPMaps set to True obviously always loads the mp maps. Whereas NeverEnableMPMaps is used as a secondary check, to see whether, when not always loaded, mp maps can still be loaded 'on demand' (and subsequently unloaded after having been used).



  • @meimeiriver Fun fact: When setting NeverEnableMPMaps to false then Franklin's house (didn't check the others) is as empty as in GTA online. Imo that's a contradiction because it's SPA which adds those props from SP mode back in. Well at least it's very confusing.



  • You may as well just add it into your own compiled.asi in the mean time. I’ve added all the doomsday interiors into my .asi trainer. But I’m having some trouble with the doomsday heist lab, other wise perfect. Perfect menu overall. I may release it on here. Has many things infamous had (like skip radio track and some menyoo things atm and stop cutscene (if you forget too save your game) and seen it before. Plenty more options... but yet many simple ones that many don’t have (may be some un useful options like some people have said, but I like the little things for creating a montage.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.