Log in to reply
 

Weird Crashing Issues...Scripthook Related?



  • So, I have been suffering from certain crashes for quite some time. I reinstalled GTAV yesterday onto my new 2TB SSD. It was a clean install. I had gotten rid of the main folder along with uninstalling it through Steam. The issues I had before reinstalling are the same that I am facing yet again. For whatever reason, several cars always trigger crashing when attempting to enter them (so much as pressing 'F' in their general vicinity will cause a CTD). Only two vehicles that I am aware of suffer from this; the Sentinel, and the Granger. Both vehicles spawn in traffic and drive around without drivers. This is always the case. These are the most predictable crashes. However, random CTDs also occur, with no truly discernible pattern. These cars subsequently cause certain missions to crash because of the necessity to enter them as part of an objective (such as the mission 'Father/Son.').

    With my reinstallation of the game, and subsequent reinstallation of a few mods (just Scripthook, Simple Trainer, a blood mod, a euphoria physics mod, and Natural Vision Remastered, including ENBseries and Reshade), this problem has reared its obnoxious head once more. I have not yet attempted to replace any weapons or vehicles. Everything that should be in the 'mods' folder is in that folder. I am nearly certain I installed everything correctly (I am no novice with modding).

    I cannot track down the root of the cause. On my previous installation of GTAV, the crashing occurred I believe even before I installed any car mods or NVR. I do not have any car mods or weapon mods now, so that basically dismisses them as the root of the issue. Simple Trainer does not seem to cause it (I tested without it). I suspect Scripthook, but I need Scripthook for many of my mods.

    Does anyone have any council or advice? This issue with the Granger and Sentinel spawning without drivers and triggering some of these crashes seem somewhat unique to me. I've only seen a few mentions of a similar matter elsewhere, and they seem to be related to LSPDFR, which I've never installed or used. I would really like to get this entire ordeal resolved.



  • @Sturmgewehr You may want to have a look at this topic: sound familiar?!



  • @meimeiriver Yes, that was one of the threads I was referring to.

    I don't understand why though. I've never used LCPDFR or related mods. I'm running a fresh install, as mentioned, with only one mod that adds any sort of scripts (the RDR euphoria mod).

    It seems like a quite isolated problem. If it is related to Scripthook, I have not read anything to suggest this occurring to anyone else. Bizarre. Are there any logs I could post? OpenIV's associated log does not suggest anything I didn't already know. One of the crashes happened with Amanda'sred Sentinel. I believe it mentioned 'Sentinelmod' (cannot recall the file extension) or something similar as the file in question.



  • @Sturmgewehr The usual cause for such crashes are, almost invariably, errors in vehiclelayouts.meta; morre specifically the animations (like for entering your car, for instance). Or anything pertaining to the cars' weapons. Doesn't necessarily mean the error is in the the XML itelf, per se. Like with my DeLuxo that suddenly crashed (upon auto-tuning), as it turned out it needed weapons from a DLC I had unloaded.

    So, you started with a clean install, and restored some of your mods. So, yeah, that pretty much rules out car mods. So, maybe try it with a vanilla dlclist.xml too? (In case the one in mods is missing a pertinent DLC). I would, in fact, just temporarily disable mods altogether, and see what pure vanilla does. NVR shouldn't really mess with car Ai; but, iirc, didn't it come with its own custom x64f.rpf file? Wouldn't be surprised at all if that were the cause.



  • I only installed NVR quite recently (on my earlier installation on one of my HDDs). The crash with the Sentinel (and I also assume the Granger, although I did not know about the latter vehicle causing problems at this time) predates my installation of NVR. So, I also think that should be ruled out (although not completely). I first noticed the Sentinel crashing with Scripthook (likely an older version), Simple Trainer, replacers for most weapons, and the RDR physics mod, as well as a blood decal / wound mod. Nonetheless, this was before I installed NaturalVision Remastered. These issues aren't exactly new.

    So, if NVR is left out (for now), I have no weapon or car replacers installed at the moment. That leaves them out as well. Simple Trainer does not appear to be a problem either. This leaves Scripthook, and the aforementioned physics and blood mod I'm using.

    The current version of Scripthook is frequently said to cause crashes. However, as stated, I've never heard of anyone having cars spawn without drivers as a result of Scripthook. I do get occasional 'random' crashes. I do not know if they are related to the Sentinel and Granger crashes. They may be completely different. So, should I replace some vehicle configuration files with vanilla versions, and see what happens?

    Edit: dlclist.xml seems fine. Well, there are two of them (I assume that is normal). The second dlclist.xml in my mods folder has all the appropriate stuff listed, including the three that are part of NVR.

    sentinel_mods.rpf (last line in OpenIV.log, which I take was the last thing loaded before the most recent crash occurred) does not exist in my mods folder. It only exists in the regular 'update' folder I believe. Is this a problem? When I install .oiv packages, I always choose the option to install in the mods folder. No idea why this wouldn't have copied to the mods folder as well (unless none of my mods modify it at all). If that is the case, then I guess sentinel_mods.rpf is also not causing some of the crashes? Weird shit is afoot for certain...

    Edit (again):

    I uninstalled the ASI loader to test without any mods (excluding reshade and ENBseries, which were loaded since they are in the main directory, and should be). I drove around for about a minute...and then, sudden crash. Seriously. What the fuck?!

    However, I did spot a Granger driving around. For once it did have a driver, lol.

    Curiously enough, when reinstalling the asi loader and going into the game again, this crash (which seems to happen between five minutes of loading into the game) stops. Grangers now have no drivers again.



  • Here is what asiloader.log put out:

    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\Windows\system32\dinput8.dll" => 00007FFE8B630000
    API: "DirectInput8Create" => 00007FFE8B639C30
    API: "DllCanUnloadNow" => 00007FFE8B649C50
    API: "DllGetClassObject" => 00007FFE8B649D20
    API: "DllRegisterServer" => 00007FFE8B653A10
    API: "DllUnregisterServer" => 00007FFE8B653C80
    LOADER: Loading *.asi plugins
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FFE8BD70000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" failed to load
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\timecyclemods.asi"
    "timecyclemods.asi" failed to load
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\TrainerV.asi"
    "TrainerV.asi" failed to load
    LOADER: Finished loading *.asi plugins

    Could that be the cause of these crashes?



  • @Sturmgewehr said in Weird Crashing Issues...Scripthook Related?:

    Here is what asiloader.log put out:

    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\Windows\system32\dinput8.dll" => 00007FFE8B630000
    API: "DirectInput8Create" => 00007FFE8B639C30
    API: "DllCanUnloadNow" => 00007FFE8B649C50
    API: "DllGetClassObject" => 00007FFE8B649D20
    API: "DllRegisterServer" => 00007FFE8B653A10
    API: "DllUnregisterServer" => 00007FFE8B653C80
    LOADER: Loading *.asi plugins
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FFE8BD70000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" failed to load
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\timecyclemods.asi"
    "timecyclemods.asi" failed to load
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\TrainerV.asi"
    "TrainerV.asi" failed to load
    LOADER: Finished loading *.asi plugins

    Could that be the cause of these crashes?

    Well, at this point, seems none of your ASI files are loading any more.

    LIB: "C:\Windows\system32\dinput8.dll" => 00007FFE8B630000

    That's weird. It should be

    LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FFCB6F10000

    Then again, you're not actually using "C:\WINDOWS\system32\dinput8.dll", despite what it says. The dinput8.dll being used resides in your GTA V root folder, and needs to be version 1.0.0.1 (hover over it with your mouse), and 128KB in size.

    Also, I can assure you, ScriptHookV is not the cause. In fact, I've never had my game more stable than now. :) For instance, my asiloader.log looks like this:

    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FFCB6F10000
    API: "DirectInput8Create" => 00007FFCB6F19C30
    API: "DllCanUnloadNow" => 00007FFCB6F29C50
    API: "DllGetClassObject" => 00007FFCB6F29D20
    API: "DllRegisterServer" => 00007FFCB6F33A10
    API: "DllUnregisterServer" => 00007FFCB6F33C80
    LOADER: Loading *.asi plugins
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\CharacterSwap.asi"
    "CharacterSwap.asi" => 00007FFCA1130000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\EnableMPCars.asi"
    "EnableMPCars.asi" => 00007FFCC0A80000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\GTAV.HeapAdjuster.asi"
    "GTAV.HeapAdjuster.asi" => 00007FFCBBF90000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\Menyoo.asi"
    "Menyoo.asi" => 00007FFC86240000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\openCameraV.asi"
    "openCameraV.asi" => 00007FFCBBBC0000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\OpenInteriors.asi"
    "OpenInteriors.asi" => 00007FFCB7D80000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FFCB7D50000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\QuantV.asi"
    "QuantV.asi" => 00007FFC986A0000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" => 00007FFCBFDC0000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\TrainerV.asi"
    "TrainerV.asi" => 00007FFC846A0000
    ASI: Loading "I:\SteamLibrary\steamapps\common\Grand Theft Auto V\TunableHomeRadio 1.2.asi"
    "TunableHomeRadio 1.2.asi" => 00007FFCB7D20000
    LOADER: Finished loading *.asi plugins



  • @meimeiriver Yeah, I fucked up.

    I got briefly confused between ScripthookV and the open source 'community' version here: https://www.gta5-mods.com/tools/scripthookv-net

    As a result, I had the ScripthookV.net version installed in place of the actual ScripthookV.

    That explains why Simple Trainer was not working. I created this error today when I deleted the Scripthook files temporarily, and instead of restoring them, replaced them with that assuming they were the same thing. Nope.

    Nevertheless, everything is loading fine now. I guess that takes Scripthook out too, since the Granger and Sentinel were crashing without it actually running.

    I found this in OpenIV.log: 03/06/2018 21:48:35.481 [4644] TRACE: [fiPackfile::openArchive] 'dlc_patchDay16NG:/x64/anim/ingame/clip_veh@.rpf'

    That was the last line before I assume I tried to enter a Granger (previous crash). It is tied to I think the animation of getting into the vehicle. Is there any other significance to it?

    Edit: Okay, so apparently for Scripthook the developer recommends updating the update.rpf in the mods folder. I did that, and well, I can seem to enter a Sentinel and Granger now! I assume they will spawn with drivers now (game crashes before I have time to try to find one). I only tried entering them after spawning them with Simple Trainer, and it worked fine (before this, if I spawned either of these vehicles, I wouldn't spawn inside of them like all other vehicles, but beside them, and would crash when pressing 'F' to enter).

    However, everything seems to come with a catch. I am now crashing within a minute of loading the game, even whilst idling on the street. However, it is not triggered anymore by those two particular vehicles it seems, which is good. I think this crashing is because replacing the update.rpf in the mods folder screwed up NVR and triggered the crashes. However, replacing the modded update.rpf also got rid of the two other mods I am using. The blood decal mod is not the culprit.

    I am going to install another euphoria mod to see what happens. I am guessing at this point that this one was causing these problems: https://www.gta5-mods.com/misc/red-dead-redemption-euphoria-physics

    I want to use a euphoria physics mod though, so I am very much hoping another similar one does not fuck things up again.



  • @Sturmgewehr said in Weird Crashing Issues...Scripthook Related?:

    Edit: Okay, so apparently for Scripthook the developer recommends updating the update.rpf in the mods folder. I did that, and well, I can seem to enter a Sentinel and Granger now!

    Huh?! This is standard, and mandatory for every update! On each update, you're supposed to take your vanilla update.rpf, and copy it to your mods folder! And then re-upload your custom dlclist.xml and gameconfig to it. To that end, I made my own .OIV package (they're just zip files, really) that will automagically apply my custom startup screen, dlclist, gameconfig, visualsettings.dat etc., to the update.rpf file in mods.



  • @Sturmgewehr I would not recommend to install any Euphoria mod. The whole Euphoria functionality is known to be bugged!



  • @Cyron43 I cannot play the game without one of the euphoria mods.

    Anyway, I am using one that seems to work fine. Haven't had any crashes whatsoever! Not randomly, or by certain vehicles!



  • @Sturmgewehr said in Weird Crashing Issues...Scripthook Related?:

    Anyway, I am using one that seems to work fine. Haven't had any crashes whatsoever! Not randomly, or by certain vehicles!

    So this thread can be marked as solved? Thanks for telling.



  • @Cyron43 Yes



  • Alright, so I understand this is solved now.

    However, I have noticed one thing.

    I seem to be crashing near this location: 07/06/2018 20:54:12.362 [1136] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_30.rpf'

    I do have at least 10 replacer cars installed at this point, but I do not crash anywhere else. Can anyone tell me what exactly this means?


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.