Log in to reply

add on modkits not working even after multiple id changes

  • hello,
    I got an add on pack that I made from combining few add ons
    2 cars in it don't have mods in lsc even after I changed their modkit ids several times.
    I have a few more cars in the pack that have working modkits and I had this problem before but changing modkits id always worked.
    I have the newest version of the game, openIV, and scripthook.

    any idea on what can fix this?

  • @ido156012
    Try using this just to make sure you are using free modkit ID's. :thumbsup:

  • @a63nt-5m1th
    already did that multiple times to about 4 cars.
    even reinstalling does not work.
    is there any way to give priority to the add on modkits over the vanilla gta ones?


    the vanilla game doesn't use ranges in 400 - 1024 for now, so those ID's should work
    if it doesn't perhaps there's a syntax error in your carcols.meta file in the add-on dlc.rpf

  • @ReNNie

    already tried some ids in those range and it doesn't work.

    the file itself I think is fine beause I have about 7 vehicles in it but only 2 doesn't work

  • @ido156012

    A good approach would be to use the 'Vehicle Kit ID Getter' & import EVERY single 'carcols' (inc. dlcpacks ones) you have installed & then save a .cs file/s with EVERY SINGLE used modkit ID in it. You will then be able to choose a Modkit ID that you know 100% is NOT being used anywhere else in the game. :thumbsup:

    Note: Even with this approach you'll find modkit ID's that simply do NOT work even though they are NOT taken by any other vehicle. The general rule of thumb is to just keep going trying different random ID's until you find one that works.

    Extra: this thread may have useful info in it. :thumbsup:

  • @a63nt-5m1th

    ok thank you I will try that.

  • @ido156012
    Here's an idea:

    • Take an add-on car that you know has a modkit & modkit ID that works in-game (test car in-game now & make sure it is 100% fully functional before proceeding).
    • Remove it completely from the game (easy if add-on, remove dlclist line)
    • Use the removed vehicles modkit ID on one of the cars that does not work & see if it is now fixed?

    It may get you nowhere :slight_smile: but it's pretty quick & easy to test, so probably worth a try :thumbsup:

    Tip: Make backups of the complete 'dlc.rpf's & it will be super quick to revert any changes.

    You could even download a new add-on mod just to try this^ out. Check the add-on works first & then swap your vehicle for the one in the new add-on replacing the '.yft', '.ytd' & editing the '.meta' files accordingly (leaving the modkit ID the same though :thumbsup:).
    Tip 2: To start with you could probably get away with just replacing the '.yft', the '.ytd' & editing just 'carcols.meta' in the new add-on. Then test in-game.

  • @a63nt-5m1th
    this didn't work
    I will try tomorrow to check all the ids using the vehicle id getter but I think the problem might not be the id

  • @ido156012
    Ok, cool. Copy your carcols & carvariations to Pastebin & then post the links here so we can have a look at them :thumbsup:
    Just to cover all the bases a screenshot/s of inside your '_mods.rpf' (showing the upgrades that do not work) might be useful also. :thumbsup:

  • @a63nt-5m1th
    I have 2 dlcs

    first one (none of the modkits work):

    mods https://imgur.com/a/MEA2LPn

    carcols https://pastebin.com/vsbqq4GC

    carvatiations https://pastebin.com/3rSsM2fQ

    second one (720s, arv10 and raptor2017 does not work [raptor uses id that worked before]):
    this one every car got his own meta files so merged only the ones that doesn't work into one link

    mods https://imgur.com/a/XEkQBou

    carcols https://pastebin.com/n14qZcTk

    carvariations https://pastebin.com/ui64be4W

    sorry for the late reply

    EDIT: in the second dlc I had the same trouble with the 16charger but fixed it before by trying a few fixes I found on the internet but I am pretty confident id change fixed this too so I am not sure why it doesn't help with the cars I sent.

  • @a63nt-5m1th
    just tried the default modkits on the cars that doesn't work and even that doesn't show up.
    so I am pretty sure this is a problem not related to the ids


    Which is why I said it's in the carcols.meta lines itself

  • @ReNNie I didn't really understand what syntax error meant.
    can you please explain what could be wrong?


    syntax error: anything from not using a closing statement like </Item> to a typo somewhere
    however both your carcols.meta files seem to check out via https://codebeautify.org/xmlvalidator

    however, i see in your dlc2 pack on the 720s uses modkit_ID 135 which is in use by the game for the PROTOTIPO afaik

    I suggest to start over from scratch (yeah i know) only using the aventador with a modkit_ID in the range of 500 - 600
    Which mod is that aventador btw, I probably have it -with working tuning- in my lamborghini add-on pack

    Use that one mod as a dlc to work from and check working tuning. Does it work?
    Great, add another vehicle to it's meta files and content.xml etc
    So work up from scratch again to find out when tuning stops working

  • @ReNNie the aventador came with a raptor mod by vans123 https://www.gta5-mods.com/vehicles/2017-ford-raptor-hq-rigged-suspension-multi-dirt-animated-engine-tuning
    I just separated them because I thought that it might help\

    thanks. I will try your idea

  • @ReNNie okay it worked!

    but somehow I corrupted the second dlc so I will reinstall everything into the working one

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.