Log in to reply

Bugged Indicators

  • Hello! :)

    I've got a bug that's been happening for a while. When using my Xbox One Elite controller (USB), any car I enter will turn on it's indicators whenever I rotate the camera using the right analogue stick, and turn them off if I rotate the same way again. If I push lightly, it does not happen. It's almost like there's a threshold to cross before they are turned on/off.

    I'm using the latest GTA patch (Steam, version 1.0.1492.0). OpenIV, Scripthook, ScripthookVDotNet, AdvancedHookV and RPH are all up to date as far as I'm aware.

    I have one main plugin, called LSPDFR. That itself has plugins inside of it, which only activate when a new instance is created. An instance is only created when I start one.

    The other plugins I do not edit the thumbsticks on the controller, but I can provide a list of those if you'd like.

    I have various LSPDFR plugins, though I don't believe they are the issue. The bug occurs before the LSPDFR plugins are activated (I've also tested my normal non-LSPDFR version and the bug is there too). It's unlikely that they are causing the issue since it occurs when they haven't loaded. I am using a mods folder and have not touched or edited the original game files in any way.

    I have tried updating my drivers, though that yielded no result.

    I have a scripts folder, and none of the scripts modify or use the thumbsticks of the controller. The scripts I have are:

    • Lively World (adds more variety to in-game events).

    • Contextual Menu API (Community Menu for scripts to use).

    • Spotify Rage (Used to play Spotify in-game).

    • Sergeant (LSPDFR Add-On - Allows crime scene management. Uses the Contextual Menu API).

    • Rage Presence (For detailed gameplay information in Discord).

    • Regeneration V (Regenerates armour/health over time).

    None of those plugins use the thumbsticks so, again, I don't think it's those.

    Finally, inside my GTA V directory I also have a couple of addons.

    The first one is TrainerV. There are vehicle indicator options inside the .ini files, but I have disabled those by following the instructions provided in said file.

    The second thing is ELS (Emergency Light System). This is used to change and edit the siren patterns/colour on emergency response vehicles. The indicator bug was also present before this was installed.

    On a final note, I've installed a modification that disabled some controller functions in-game, such as look-behind in vehicles and the ability to press up on the DPad to bring up your mobile. To me, this was the most likely culprit. I've looked at the original standard.meta files for controls, and can't see any difference in relation to indicators between the originals and the edited ones.

    If someone could point me in the direction of where the indicator controls could potentially be found, that would be appreciated. Otherwise, I'm open to any ideas you may have.

    You can find my logs below:

    Deepest apologies for the long post, I just wanted to make sure you have as much information as possible.

    Many thanks,


  • @Zenitae its a new feature of simple trainer, move the right stick to left indicator blinks left turn it left again indicator turns off.

  • @MaxLuk Thanks for your response. I noticed that in the changelog when I checked a while ago, though I didn't add the CLeftIndicator or CRightIndicator as it suggests I do to enable it.

    I've only now just realised that I should have added it anyways and set it to 0. This has solved my issue! How typical of me to over-analyse things :expressionless:

    Thank you Max!

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.