Log in to reply
 

Scripthook error: unknown game version



  • I recently installed a car addon pack through OIV and now the game doesn't start, and it gives me an scripthook error saying unknown game version. Here is the scripthook log:

    // GTA V SCRIPT HOOK (build Sep 3 2017, v1.0.1180.2)
    // (C) Alexander Blade 2015-2017
    [12:20:33] INIT: Started
    [12:20:33] FATAL: Unknown game version

    I didn't backup anything so I'm really hoping I don't have to reinstall the game... It was an OIV file so I suppose it isn't very easy to uninstall it without the original/backup


  • MODERATOR

    You're using a scripthookv build from Sept 2017, you need to use the latest version.



  • @stillhere okay I updated it and it seems to have fixed the error but the game just doesn't open. I will start it but nothing happens, seems like its loading forever. On steam it says I have it running but nothing shows up. This is as far as the scripthook log gets after the scripthook update

    // GTA V SCRIPT HOOK (build Jul 27 2018, v1.0.1493.0)
    // (C) Alexander Blade 2015-2018
    [17:48:58] INIT: Started
    [17:48:59] INIT: Success, game version is VER_1_0_1493_0_STEAM
    [17:48:59] INIT: Registering script 'LUA.asi' (0x00007FFDCFCCE6A0)

    Here is the launcher.log file https://pastebin.com/jA9pxEwF (it doesn't continue after that last line, it just stops there)


  • MODERATOR

    Is that first part your entire scripthookv.log? Seems short, but I guess you don't have much ASI's in your installation directory.

    Also if you have an OpenIV.log file there might be an error logged inside (a problematic asset, for example), though it seems like the game isn't even getting a chance to launch, much less load anything.

    This is a long shot but have you tried launching the game without LUA.asi? It's very old so it may be the cause of your issue.



  • @stillhere I didn't see your message when I did some troubleshooting, but anyways I got it to work by getting rid of a car mod pack, and the game loaded up fine after that. Now instead of the mod pack, I installed a bunch of car addons individually and the main menu loads up but after I try to load up story mode from the menu, the game crashes. I would assume it's the gameconfig.xml file since I have so many car addons but I used the latest 1.0.1493 one from F7YO.

    Here are my log files (can't get my OpenIV log on here since it's so big)
    Scripthook: https://pastebin.com/MU5VHLKZ (yes that is the entire scripthookv.log, I don't have that many ASIs in my directory)
    launcher.log: https://pastebin.com/r5ZGpAFd
    ASI loader: https://pastebin.com/TuJ894pB (the build is from 2015 and IDK if there is an updated version of it but I got it from the ASI manager in OpenIV)


  • MODERATOR

    Looks okay as far as I can tell. My ASI Loader is also from 2015 so that should be okay.
    I am also using the gameconfig from F7YO currently the "1x traffic 1xpeds (Means Gta base)" I think.
    I recommend you install these ASIs, they might help:

    and this one if you happen to have addons with many weapons: https://www.gta5-mods.com/tools/cweaponinfoblob-limit-adjuster

    Finally, I recommend deleting the OpenIV log file and then attempt to launch the game again. When the game crashes, check the very bottom of the newly-created OpenIV log, it should show you what asset was trying to load before the game crashed.



  • @stillhere I also use the "1x traffic 1xpeds" gameconfig. I installed both of those ASIs, but it didn't help much. I restarted the game twice and the OpenIV.log ended at these same lines in both attempts: https://pastebin.com/PXRLFAvq

    I don't see why the game would crash at an asset from a developer update (that is what I'm assuming dlc_mpChristmas2017 is from). I didn't touch that at all.


  • MODERATOR

    I assume dlc_mpChristmas2017 loaded just fine before installing more car mods, so the problem could be that there are too many individual add-on dlc installed, and/or you are reaching some limit as written in your current gameconfig. Have you tried any of the other configs from F7YO? 2x, 4x, etc.



  • @stillhere I have about 28 addon mods. I just used 2x and it worked. It crashed after 5 minutes of gameplay though, but I guess I just need to bump it to 4x maybe?

    Edit: Actually nevermind, it works now. It crashed last time because of my Reshade mod but it works now thanks to the 2x gameconfig, thank you!!


  • MODERATOR

    Great, and you're welcome. I'll mark the thread as solved for now but if you run into similar problems again you can just bump it; enjoy!


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.