Log in to reply
 

Scripthookvdotnet Crashes Game When Loading Screen



  • So, out of nowhere, my GTA V decides not to work. Everything worked perfectly yesterday, and now it crashes during the loading screens. After trying the game with one mod at a time, I found out it was the Scripthookvdotnet files the ones causing the crash. I have tried everything I could think of. I desperately need help, since most of my mods require Scripthookvdotnet. Any help is highly appreciated.

    gta v version 1.0.1493.1 (not steam)
    both scripthook and scripthookvdotnet are the latest updates.


  • MODERATOR

    Paste the shvdotnet log here



  • I had a similar trouble after the last update and my game would only work normally after when I deleted the entire "scripts" folder. :cry: Anyway, I started anew and deleted every single trace of any modification or dependent program that I could find in my GTA folder. Then pasted the entire "scripts" folder back and it finally worked.

    I think this situation might also be caused by something outdated in your "mods" folder or the game files (if you did not use the "mods" folder). Take a look at that as well.



  • @Reacon Thank you for replying. Where do I find it?



  • @TheMurderousCricket Thank you for replying. My game only works when I delete the .asi and .dll files of Scripthookvdotnet. I already tried deleting my game files so when I run the launcher.exe, it downloads new, clean and updated ones. Still no luck.


  • MODERATOR

    @Elex main game directory where you put the shvdotnet files



  • @Reacon Hmm it doesn't seem to be there. The only ones there is the asi loader and scripthook log.



  • @Elex, could you then send us a screenshot of your GTA V directory and your "scripts" directory (the latter, if applicable)?


  • MODERATOR

    @Elex post a screenshot of your game directory



  • @TheMurderousCricket @Reacon I'm currently resetting my PC and I'll reinstall the game. Once I get all that done and If it still doesn't work, I'll get the screenshot.


  • MODERATOR

    @Elex no point reinstalling just yet, might not be anything to do with the game files



  • Hello again. So I just installed the game, and now my scripthookvdotnet does not work at all. I installed the files onto the directory and no scripts appears in game.

    This is the log scripthookvdotnet log

    [23:52:48] [DEBUG] Created script domain 'ScriptDomain_FE3F2940' with v2.10.8.
    [23:52:48] [DEBUG] Loading scripts from 'C:\Program Files\Rockstar Games\Grand Theft Auto V\scripts' into script domain 'ScriptDomain_FE3F2940' ...
    [23:52:48] [INFO] Loading assembly 'ClearScript.dll' ...
    [23:52:48] [DEBUG] Found 0 script(s) in 'ClearScript.dll'.
    [23:52:48] [INFO] Loading assembly 'MapEditor.dll' ...
    [23:52:48] [DEBUG] Found 2 script(s) in 'MapEditor.dll'.
    [23:52:48] [INFO] Loading assembly 'NativeUI.dll' ...
    [23:52:48] [DEBUG] Found 0 script(s) in 'NativeUI.dll'.
    [23:52:48] [WARNING] Skipped assembly 'ScriptHookVDotNet2.dll'. Please remove it from the directory.
    [23:52:48] [DEBUG] Starting 2 script(s) ...
    [23:52:48] [DEBUG] Instantiating script 'MapEditor.JavascriptHook' in script domain 'ScriptDomain_FE3F2940' ...
    [23:52:48] [DEBUG] Started script 'MapEditor.JavascriptHook'.
    [23:52:48] [DEBUG] Instantiating script 'MapEditor.MapEditor' in script domain 'ScriptDomain_FE3F2940' ...
    [23:52:48] [ERROR] Failed to instantiate script 'MapEditor.MapEditor' because constructor threw an exception:
    System.MissingMethodException: Method not found: 'Void NativeUI.InstructionalButton..ctor(GTA.Control, System.String)'.
    at MapEditor.MapEditor..ctor()



  • As for my game directory, it looks like th
    https://imgur.com/gPMsWEm
    https://imgur.com/x6bvlqa



  • A few questions;

    1. Did you save and then copy-paste the "scripts" folder after reinstallation? Or did you make it "from scratch"?
    2. Does Native Trainer work?
    3. Does Map Editor work or open at least?
    4. Do you have all the required .Net Framework environments installed? If you reset the whole PC (like you wrote earlier) you might be missing these...


  • @TheMurderousCricket

    1. From scratch
    2. Yes. Native trainer doesn't require sripthookdotnet
    3. No. Map editor needs scripthookdotnet
    4. I'll see when I get home. I'll post when I find out.


  • Update: I downloaded the installer for .NET Framework and ran it. It gives me this:
    Details

    .NET Framework 4.5.2 or a later update is already installed on this computer.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.