Log in to reply
 

[Tutorial | Vehicles/Weapons] How to do: Add-On's / Replacer's



  • @meimeiriver Rockstar gotta be the only game dev that actively changes how their games operate out of sheer spite.



  • @jWILL253 said in [Tutorial | Vehicles/Weapons] How to do: Add-On's / Replacer's:

    @meimeiriver Rockstar gotta be the only game dev that actively changes how their games operate out of sheer spite.

    Yep, I know of no other company that is so incredible mod-hostile, really. Also slightly worried about your unique car-ID not yielding a valid modkit.



  • Anyone know if F7YO's latest gameconfig still works with the new update or not?



  • @jWILL253 said in [Tutorial | Vehicles/Weapons] How to do: Add-On's / Replacer's:

    Speaking of the ID's, some tuning kits still don't work even when I give them unique ID's.

    Has that been resolved? Or is the limit somehow (effectively) still 255?

    Reassinging all my addon car ID's will be quiet some undertaking. I'd rather see it confirmed somewhere that ID's > 255 are a real possibility (and are actually working by themselves, and are not internally bit-masked 'wrapped' to an 8-bit value, after all).



  • I really did everything like you did, I checked everything: I replaced everything with Firetruk2; and it always says "Invalid Model" :((((



  • I used the provided GameConfig, yet I still get ERR_FIL_PACK_1. I removed my Scripts folder, and I genuinely am at a loss.



  • @FakerTV said in [Tutorial | Vehicles/Weapons] How to do: Add-On's / Replacer's:

    I really did everything like you did, I checked everything: I replaced everything with Firetruk2; and it always says "Invalid Model" :((((

    Clearly you didn't do everything like he did, as <modelName> can only be lowercaps (unlike <gameName>, for instance). So, Firetruk2 will never yield a valid model. The model file names need to be lowercase too.



  • I've had no crashes so far but the problem is the tune/mod kits don't show up in game. I use Add-On Vehicle Spawner and it showed the mod kit id's which are all 0. Does this have to do with /dlc.rpf/x64/data/lang files of the individual car mods which i didn't add to the combined dlc or is the carcols solely the root of this problem?



  • @Siggz21 I'm having issues with this too :(


  • MODERATOR

    @Siggz21 @Divine

    If the cars are tunable but you can't add tuning to them in-game, is a modkit ID problem. First of all you guys need a legal version of the game with the latest game update installed. This will prevent the modkit ID's not working issue, since Rockstar Games increased the limit a lot in this last update (Doomsday).

    If you don't have the Doomsday update, you'll probably have to deal with the modkit ID problem and try changing it until you find one working, between 0 and 255 values.

    If the modkit ID's are 0, means that are using the generic tuning options, which means that there won't be bumpers, fenders, or any other customizable parts.



  • @Reyser Thanks! I changed the mod ID to the new ones. I really appreciate your help! Now my vehicle tuning parts work :)



  • @Reyser thanks! i looked over the carcols file again and found that there were multiple conflicting modkit id's.



  • Hello
    I have a big issue
    When using <turnoffbones/> function for tuning parts in carcoles.meta file
    The main object won't dissapear!!!! so it becomes combined with the tuning part which causes a lag
    Even though I named it correctly and I checked the file million times, is it a problem from the model itself ?
    Should I edit the skeleton of the model , enable options ....? What should I do



  • @Reyser
    i try to make add-on packs by put aige's huayra and p1 into 1 addon dlc.
    but the problem is tuning parts disappear when i pick it in LSCustom / trainer.
    modkit ID works fine, because tuning parts showed up in LSCustom /trainer, but when i apply it, It's disappearing car's body.

    i copied exact carcols and carvariaton lines from both dlc into my own carcols and carvariation.

    any idea what's wrong with my problem ?


  • MODERATOR

    @LexTalionis I don't know. It's an uncommon problem but I guess the tuning parts that disappear have the same name as other game files or they're bugged.



  • really well written got to say but id love a video tutorial ;)



  • @Reyser yeah finally i found the problem and already fixed it.
    do you know which line that affects dials to work ? some says, you have to edit <dashboardtype> in vehicles.meta?
    i tried to change it in my own addon cars pack but some cars works and the rest don't



  • Awesome tutorial, really, works great.
    There 's just something I don' t understand how to do...
    I'd like to replace a bike that has no tuning parts with one that has,
    for instance the carbon rs with imtaj' s awesome gsxr 1000 tunable.
    I'm pretty sure it should be possible, but I don' t find what is linked to this carbon rs in any carcols file.
    Any idea please ?



  • @LexTalionis
    Hi, I seem to encounter the same problem you have had ("tuning parts showed up in LSCustom /trainer, but when i apply it, It's disappearing car's body") , so I' m really interested in your trick to fix it if you' d please agree to share it...



  • tutorial video???



  • When I add tuning mods to my addon, the game crashes while loading with a corrupt game file warning. I have checked for problems in XML and found none. I matched the file structure to a working mod as well.

    The tuning parts were for the Primo and Primo2. I renamed them.

    When I ditch the mods rpf and just replace the default files in the mplowrider and x64i files, the game does not crash.



  • @womb_raider Provide screenshots or a video of how everything you described was done, if you can.

    I think I know what you did and I need some good visual info of what you did - preferably in video.



  • @krashadam can I PM a download link to the whole file? I could post it here, but I do not want to violate rules, as the whole vehicle is not my work. I am just making an addon version of a replace vehicle by Vans123.



  • Here is a download link for all of my XML files. The model, parts, and etc are not included.

    http://www.mediafire.com/file/wrhb8olxqojq8sv/67Mustang xml files.zip

    Thanks.



  • there's also youtube.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.