Log in to reply
 

[Tutorial | Vehicles/Weapons] How to do: Add-On's / Replacer's



  • @Reyser HOLY COW DUDE it workssss thank you so muchhh



  • @Reyser heyy it's me again is there a way so that one audio line contain all the car sound ? because when i put more than 2 audio line it crashes the game giving me err_sys_fileload


  • MODERATOR

    @Burney Afaik nope. We're limited to the game limitations, and right now only Rockstar Games can change this (which I doubt they'd do anyway).

    Also I don't really know what are you doing when you say "2 audio lines", but when I talk about "audio lines" I mean ITEMS:

    <item>
       CONTENT HERE
    </item>
    


  • @Reyser aww that's too bad anyway i fixed it the actual reason it crash because i put <Item>dlc_monroec:/%PLATFORM%/vehiclemods/infernussr_mods.rpf</Item> but with no vehicle mods on it which brings me to another question so i managed to spawn this car but the only sound i could hear was the backfire of the engine any idea why?? *i already updated the content.xml and the audio folder does contain the proper sound file


  • MODERATOR

    @Burney No idea, that's something you'll have to talk with the author of the mod. Or maybe in the section comments of the mod you can find an answer to your question? Sometimes people asks there and maybe there's someone that had the same issue that you're facing right now.



  • @Reyser alright finally got it fixed thanks alot man you've been a great help!!



  • @Reyser hey do you know why the car pack that i install doesn't show its name when i get in i can only see the manufacturer name on it


  • MODERATOR

    @Burney You would need to edit the "lang" folders inside your Add-On pack to add the names of every vehicle and its tuning parts.

    You can follow the "Step 17: Name your car" of this tutorial: https://www.imnotmental.com/guide/add-on-vehicles-tutorial/

    I personally never did it before as it's not required for the correct work of the vehicles so I won't be able to help you with it. Anyway it shouldn't be hard so give it a try if you have free time to spend on.



  • @Reyser i see well thanks for the help!!



  • @Reyser Hey I tried doing everything as you said to but it's not showing up in game..!
    The Replace mod I tried turning into an Addon Mod does not have any Meta Files that come with it.
    The pack the original bike came with (Patchday1ng) doesn't have any metafiles either (not any I could find)...

    If it helps this is the Mod I am trying to modify (https://www.gta5-mods.com/vehicles/police-kawasaki-1400-gtr-pack-els-replace)



  • @Reyser I Retried it with an already working mod and everything worked! (Took a working mod and added my yft/ytd/meta files but didn't change the name of the folder or anything in the XML files) But as soon as I try it with your base files the game doesn't even recognize the mod (I already had that proplem with 2 or three other mods that i installed correctly!)

    Can you please help me?


  • MODERATOR

    @Jan119 There's no way I can help you without you providing me your test file... :/



  • @Reyser Thank you for the response! I falsely used the Vehicles#2 File! Now it's detecting the mod but it crashes on load (Like when you install them into your main dictionary and not in your mods folder)



  • Here is the Link to my file https://mega.nz/#!vqJxQSBR!Su37XzhkN1w-Nf-JmRCbpvB-kUFgFSdvx58lu0wLLbc
    It is not The Kawasaki Gtr anymore but it is still crashing like mentioned above!



  • @Reyser I retried everything and came to the conclusion that it doesn't work because of the metafiles (They are in a big metafile that is in the other DLC folder). What should I do now? Is there any way to extract the handling/vehicles line out of the big file?
    Now I'm at the point where it doesn't crash anymore but it also isn't showing up... I'm done with my vocabulary at this point

    Regards Jan

    My base File:
    https://mega.nz/#!vvxHhYbB!5-UyqqXYqGHsqqtleiSfD-4dxMp1CJUZjF7c0I2y4sA


  • MODERATOR

    @Jan119 It's not your base file, it's mine lol. Which is the exact problem that you have right now with it?



  • @Reyser Sorry I meant the base file I used it was the wrong file!

    My Problem right now is that the mod is not showing up ingame! (I'm trying to turn a Replace into an Addon)

    This is the file I'm using: (The folder it is in is called z250 and the dlclist.xml file is modified correctly)
    https://mega.nz/#!b2gRjIAS!Su37XzhkN1w-Nf-JmRCbpvB-kUFgFSdvx58lu0wLLbc

    I think it has to do that I used the whole Vehicles.meta/handling.meta... packages and not a small one only of the bike it normally replaces!


  • MODERATOR

    @Jan119 To me your Addon looks fine, it should work. Are you using a trainer to spawn the Addon or?



  • @Reyser Yes I'm using a trainer to spawn it MENYOO in particular


  • MODERATOR

    @Jan119 I don't see anything bad on it tbh. Try to create a new Addon or add the files to an existing one to see if it works in a different Addon folder.



  • @Reyser I found the problem I forgot to edit the Foldername in the .meta files!

    Thanks for helping!



  • @Reyser said in [Tutorial | Vehicles/Weapons] How to do: Add-On's / Replacer's:

    I Need HELP PLS!!! When I start the game it crash whitout send me error... (i Have only 4 Dlc's)
    Here There is my file...
    https://it.gta5-mods.com/vehicles/crosskart-add-on



  • Excellent tutorial, thank you!


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.