Log in to reply
 

[Tutorial | Vehicles/Weapons] How to do: Add-On's / Replacer's


  • MODERATOR

    @xxminerxx10 Yes, but R* doesn't add DLC vehicles in the files on update.rpf/common/data as far as I know so you'd have to add them manually.


  • Banned

    @xxminerxx10 DLC Patch will get read first, then DLC Packs, then Update, then Common. So if there isnt a handling.meta in Patch then it will look in Packs, If it can't find it there then it will look in Update.



  • @Reyser @InfiniteQuestion I think I understand now but is there any way to make the handling.meta and vehicle.meta in my folder the ones that get read first? Tried to add the Autarch in vehicle.meta from update.rpf/common/data and the game doesn't stop loading. Also it's very difficult to edit these files when they are in DLC patches or packs occupying a lot of space in the mods folder for nothing.


  • MODERATOR

    @xxminerxx10 " Tried to add the Autarch in vehicle.meta from update.rpf/common/data" That sounds like you messed up something in the file. It should be able to be read properly even if you include new data for existing vehicles.



  • @Reyser Tried one again to edit the vehicle.meta from update.rpf/common/data. Same thing happened. After searching for a mistake but not finding anything I started once again editing the vehicle.meta from the dlc folder of the car (in this case mpchristmas2017). The game finally loaded but the car dials were glitched. Out of boredom I tried to put the text in the vehicle.meta from my folder and everything started working properly. I really don't understand what's going on but I think I'm still doing something wrong.



  • @reyser Trying to replace the Alpha with https://www.gta5-mods.com/vehicles/2016-cadillac-ats-v-coupe-add-on-replace but when I edit the vehicle.meta from update.rpf/common/data the car doesn't spawn. Is there any way to to solve this?


  • MODERATOR

    @xxminerxx10 What are you doing exactly when you edit the vehicles.meta file car info? Copy/paste or screenshot the "before" and "after" results.



  • @Reyser
    2_1597662929511_Screenshot (48).png 1_1597662929510_Screenshot (47).png 0_1597662929510_Screenshot (49).png
    This is the initial vehicle.meta
    2_1597663017219_Screenshot (45).png 1_1597663017219_Screenshot (44).png 0_1597663017219_Screenshot (46).png
    This is after I copy/pasted and edited the info in vehicle.meta from update.rpf/common/data.


  • MODERATOR

    @xxminerxx10 Everything seems to be fine there. Maybe the vehicles.meta file is not the problem but the car files are corrupt or something is messed up in any of the other meta files.



  • @reyser When I delete the added lines from vehicle.meta, excluding the dials not being in place and the hands that are supposed to be on the steering wheel, the car works just fine. I even tried 2 more cars to replace the Alpha but had the same result.


  • MODERATOR

    @xxminerxx10 weird. Are you adding the alpha replace vehicles.meta lines or replacing the existing ones?



  • @Reyser I'm adding the lines. These normally are located in 64w.rpf/dlcpacks/mpbusiness/dlc.rpf/common/data/levels.


  • MODERATOR

    @xxminerxx10 Have you tried to see if they already exist in the vehicles.meta you're editing? Maybe the game's finding 2 different Alpha settings in the same file and that's why the car doesn't spawn when adding your car info.



  • @Reyser Yes I checked.


  • MODERATOR

    @xxminerxx10 In that case... I don't really know what can be the problem. Try to replace the info in the original vehicles.meta file and if it works then you'll have to do it that way.



  • @Reyser Thank you for the help! The car finally works.



  • @Reyser Seems like there are more vehicles.metas than I thought. I had the same problem with the Furore Gt. This time when I replaced the lines in the corresponding dlc from 64w.rpf the car didn't work. I tried the other meta files too(from my folder and from update.rpf/common/data/levels/gta5) but had the same result. Then I remembered there is one more vehicles.meta in the corresponding dlc from dlc_patch (located in update/update.rpf). After replacing the lines the car worked perfectly. Therefore I will leave this here so people will know what to do if they have the same problem I had.



  • @Reyser I ran into another problem. While replacing the Kuruma I noticed that I cannot upgrade it. This means I can't buy tuning parts nor engine, transmission, brakes, suspension upgrades. Only way to make them work again is to delete my own dlc folders. I did try to replace the id value in carcols.meta and carvariations.meta (with the original id and random ones) but with had no success. Is there a limit for tuning parts like the addon cars have and if so can I change it in gameconfig.xml?


  • MODERATOR

    @xxminerxx10 Sometimes the vehicles can have compatibility problems between vanilla and mods tuning parts. Usually is an ID conflicting value but it might also be that the tuning parts (if you replaced them without overwriting the vanilla files) have the same name than the vanilla ones.

    If you're going to replace a vanilla vehicle but add the tuning parts instead of replacing them, make sure that there's not a names coincidence between vanilla and added tuning files. If instead you're replacing the files, make sure that you're replacing them on the most recent kuruma_mods.rpf file and try as much IDs as you can for the meta files. Values between 800-2000 for an ID are worth to try.



  • @Reyser I still can't fix the bug. I already tried more than 60 numbers. Usually when replacing a car and its tuning parts I write the vanilla id value in the meta files and the car is successfully installed. This time it doesn't work for the Kuruma. I also checked the tuning parts but it doesn't look like they are the problem. Restoring to an old backup doesn't fix this and the only way to make everything work normally again is deleting the mods folder.


  • MODERATOR

    @xxminerxx10 Are you installing the vehicle in a pack mod or an individual DLC folder?



  • @reyser pack mod


  • MODERATOR

    @xxminerxx10 try it in an individual one



  • @Reyser It works now! Thank you for everything you've done for me! Sorry for bothering you a lot in the last week but I know you are very good at modding and I couldn't resist not asking you what can be done for solving the issues above.



  • @Reyser I want my custom name for the add-on car to appear in but i only see the spawn title id in game for every addon car i make. Example for "Ford GT" i want Ford GT to appear in game name not just the spawning id which is "fgt". What values should i alter.?


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.