Log in to reply
 

WTF did they change ?



  • This new update is driving me nuts.

    Long story short, I have been modding this game since day one. When an update comes out its always the same procedure to get mods working, replace update.rpf, modify gameconfig and wait for Alex to update scripthook.

    Well it appears these bastards at Rockstar have decided to throw a new wrench in the process with this update. I am 100% sure they have introduced some new memory limitation which is the source of all this CTD and disappearing texture issues being reported on here.

    I boot into the game and gets passed the loading screen. My save is at Trevors strip joint. I test all peds and spawn a few vehicles, all work as expected. As soon an I walk or drive towards the bridge its an instant CTD. No error message, just crashes straight to desktop. So I thought OK, this is probably some ASI or script that is causing a collision because it needs to be updated. As I begin my process of elimination I start to realize it doesn't matter which RPF / ASI / Scripts I remove. the less mods I have, this invisible CTD barrier goes away. For example, if I disable any one my ped dlc.rpfs the CTD barrier now lets me traverse all of los santos up until the Airport.

    My setup is exactly how it was before this piece of shit update. I have three modified rpfs in my mods folder (just ped and vehicles) along with a modified update.rpf which I have only modified the dlc and gameconfig xml.

    ASI's

    ScriptHookVDotNet
    PackfileLimitAdjuster
    GTAV.HeapAdjuster
    openCameraV
    OpenInteriors
    OpenIV
    TrainerV
    Skin Control

    Scripts

    AfterHoursSP
    MapEditor
    MissionMaker
    Voice Player

    I have tried multiple gameconfigs with no luck. The only thing that alleviates (does not fix) the problem is disabling random mods. The game is clearly now limiting what we can load into memory. At least that's what I have observed while troubleshooting this crap.


  • MODERATOR

    PackfileLimitAdjuster does absolutely silch for me in my game, maybe ditch it while troubleshooting?

    If an add-on peds.rpf is removed and this doesn't make the game as unstable I'm wondering if you manage your gameconfig.xml poolsizes yourself or just trial and error with the ones available?

    What happens if you increase ped related poolsizes while keeping that add-on ped rpf in?



  • @ReNNie Its not ped related and my ped poolsizes are fairly large.

    Like I said I can remove any RPF / ASI / Scripts to alleviate the problem. My ped rpf is the largest which is why disabling it helps the most but that is not a solution because the rpf is not the problem.

    There is some odd memory limit that was introduced with this patch. The gameconfig I am testing with now is by F7YO which has some fairly large pools for Drawable, DWd, fragment, txd so I know its not one of those pools either.

    They (Rockstar) clearly changed something in regards to memory limitations.

    Just an update ago I made this video with both LC and VC enabled.

    Now I can't even get my base ped and vehicle mod setup to load.

    Ridiculous



  • After two days of agonizing failure I've figured it out.

    As a last resort I tried an old save just for the heck of it which loads me in Franklin's house in Vinewood. I immediately noticed that textures and objects were missing from the house. I disabled my mods folder (no modded RPF's loaded) and had the same result, textures and objects missing from the house. So then I disabled my scripts folder (no scripts loaded just ASI's) and noticed once again textures and objects missing from the house. So I start a process of elimination with my ASI's and when I removed YachtDeluxe.asi the house now loads up as it should. I re-enabled my mods folder (modded RPF's) and everything worked but upon re-enabling my scripts folder the house once again had missing textures and objects. So I started eliminating scripts and discovered both BennyMotorworks and AfterHoursSP cause the same issue.

    Basically every mod (ASI and scripts) I had installed that loads assets from multiplayer caused a problem. These have gone unnoticed till now because unlike EnableMPCars they don't crash the game at the loading screen. Those who have noticed missing textures reasonably assumed it was a gameconfig pool issue.

    It would be nice if someone can test with their game to confirm my findings.

    Install either of these three mods and load a Franklin save at his vinewood house.

    YachtDeluxe
    BennyMotorworks
    AfterHoursSP



  • I don’t have any of those scripts but if rent I’ve been getting texture loss that I didn’t get before I thought there was something wrong with my pc or a certain mod it doing my head in



  • @jordy1690 just do every step the OP did in his most recent post to find his issue - process of elimination. Might be another script causing it that you have and he doesn’t



  • @jordy1690 If you have any ASI or script that enables multiplayer assets remove it.

    Rockstar has changed something that with certain MP mods is causing a memory leak and bugs the map.

    The only MP mod I can verify doesn't cause issues is OpenInteriors.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.