Log in to reply

Modding advice (newbie)

  • Hello, I am new to GTA modding well pc gaming all together. I am trying to install the natural vision mod with everything it suggests and simple zombies. I have watch numerous tutorials on how to do it triple checked what I have done but no matter what I do when I get into the game it's just standard, I cant access any menus at all not using F3, F4, F10, c, i and z. I have tried the trainer than comes with the simple zombies mod and the easy trainer and enhanced trainer but nothing. I would post my log files but I'm unable to find anything that'll work, my GTA is not steam it's direct from rockstar. If someone can point in the direction of where I might find this I'll post that as well. I understand it's not much to go by but I've been browsing the internet for a week and cannot find anything relavent and its driving me nuts. Any advice much appreciated. Thank you for you time

    //edit ReN : moved


    Install Microsoft .NET Framework 4.5.2 (or higher, so skip this step on Windows 10)

    AND Microsoft Visual C++ Redistributable Package for Visual Studio 2013 (x64).

    AND Microsoft Visual C++ Redistributable Package for Visual Studio 2015 (x64).

    Download and install the latest Script Hook V. Alsways re-do this step after a R* update is pushed.

    Download and install Community Script Hook V .NET and copy the ScriptHookVDotNet.asi and ScriptHookVDotNet2.dll in the main game folder

  • I have all of the Microsoft visuals installed already, I have double checked this.

    I have already got both of these installed in the main GTA 5 directory

    Thank you

  • Then welcome to modding and PC @Bodders. ;)

    Maybe you just miss some script-specific dependables. Some scripts and mods may require Microsoft Visual 2010 for instance or even different versions of .NET Framework environment.

    First things first however. At the beginning, please make sure Script Hook is in the main directory and not the "scripts" folder. I learned the hard way it will cause trouble...

    And while this is true of script hook(s), scripts themselves have to be placed in the "scripts" folder (well, duh...).

    Log files are (at least should be) present in your main game directory (the one with .exe file) under ScriptHook.log and ScriptHookVDotNET.log (something along these lines, name-wise).

    If these tips fail, please provide a screenshot of your main game folder and your "scripts" folder so we can have a look.

  • @Bodders
    If you can, provide screenshots of your main GTA V folder, your 'mods' folder (if you are using one. If not, you should be :thumbsup:), your 'scripts' folder (if you have one) & also OpenIV's ASI Manager screen (OpenIV > 'Tools' tab > 'ASI Manager') :thumbsup:

    Inline Images

    https://imggmi.com/ works well for pics (free, no login etc).

  • ![alt text](0_1547674076947_upload-1808e2cf-41ea-419e-8010-345afdff8828 image url)

  • ![alt text](0_1547674143995_upload-48be9509-e525-4350-a02f-02e196820852 image url)

  • ![alt text](0_1547674210706_upload-2a60a267-b657-4c8e-b4f3-4df2dc170bdd image url)

  • This is what you asked for?

    I don't require a mods folder for the simple zombie mod as far as I am aware it is all scripts?

    Thank you for your time! This has been driving me crazy

  • @Bodders

    Yep, that's perfect. Ah, there you go, got your solution :slight_smile:

    'NativeTrainer.asi' should be in your main 'Grand Theft Auto V' folder not in the 'scripts' folder.

    That'll fix it :thumbsup:

    Note: ALL '.asi' files always go in the main game folder ( 'Grand Theft Auto V') so any others you get in future put them there too :thumbsup:

  • Ok no issues. I think I that's one I was just moving around to see if it will work. I'll move it to the main folder and see what we get. Thank you for your help!

  • Right I have moved this to the main GTA v folder and still nothing. It's like the normal game. I press F3 and it brings up the action replay toggle on/off f4 nothing and f10 nothing. Any other advice on what it could be?
    Thank you
    Edit I have changed f3 so it is blank to make sure this wasn't interfering and still nothing, unable to access any mod menus.


    No ScripthookV logs present in main folder? Then scripts simply will not work

    I advised you to download and reinstall those VB redists, so did you?
    Even if Windows says it's installed fine, do it anyway please

    Also, do you perhaps have two installations of V, one for offline and one for online use for example? In which case OpenIV might register the asiloader in the incorrect installation folder

    OpenIV will quite happily install its files into any folder you point it at, even if it's just a copy of the game folder. So it saying that ASI Loader and OpenIV.asi are installed can be misleading, because they might not be installed in the version of the game that is actually running.

  • I don't think OpenIV's asi loader is even necessary to run a trainer... :/ Not the native, script hook one that is!

  • @Bodders
    :slight_frown: meh, was sure that would work. I'll see what else I can think of. Follow @ReNNie's suggestions & see where that gets you :thumbsup:

  • @Bodders

    In Enhanced Native Trainer (ENT) you need the config file to define what key to press to open it but not sure if it is the same for NativeTrainer.asi?! To rule it out can you download Enhanced Native Trainer & try that?

    ENT Install Instructions (edited by me for clarity):

    • Download scripthook
    • Open the scripthook zip file, and inside the "bin" folder copy ScripthookV.dll and dinput8.dll to the ROOT of your GTA game folder (where GTA5.exe is). Note: Make sure files are unblocked (see pic below)
    • Copy BOTH the "ent-config.xml" and "EnhancedNativeTrainer.asi" from ENT download to the main game folder (also make sure unblocked).
    • Press F4, or RB + Y in-game (default bind. Can change in the config) to open.

    Try that out & see what you get with ENT (even though you have scripthook.dll & dinput8.dll already, download new ones, unblock them & replace anyway).

    If no luck, here are some more ideas:

    • Uninstall & reinstall OpenIV's asi plugins.
    • Try turning off your anti-virus & then test it
    • Right-click all of your downloaded .dll & .asi files & make sure they are unblocked (see pic).


    • Check file permissions for the Grand Theft Auto V folder & make sure scripthook/trainers/OpenIV etc have the ability to write to that folder. Right-click folder/drive > 'Security' Tab > Make sure allow boxes are ticked (full instructions here)
    • Maybe also take Ownership of that hard drive/Grand Theft Auto V folder (Win10 Instructions here)
    • Do you have a Function ('Fn') key on your keyboard? Test using Fn+F4 to open trainer if you do (info here)

  • @ReNNie I have tried to install the ms visuals 2013 and 15 but comes up saying repair which i complete, i then restart the pc as requested but still nothing. I cannot see any log file? i have re downloaded everything again but still no log file? With open IV i only have 1 copy at a time named v, i change the other names to make sure it doesn't read the incorrect folder if that makes sense?

    @a63nt-5m1th thank you for all of the detail! I have followed every step that you have suggested but i still have no joy! i have tired using F4 and FN+F4 but still nothing i am unable to access any menus. I have tried to unblock the downloads but it doesnt give me that option under the general tab in properties

    I am new to all of this so please be patient with me and thank you for the advice so far. I really want to get this to work but i dont know what i am doing wrong

    I have the Razer Ornata Chroma keyboard so if i hit FN and F10 it turns on and off gaming mode, i dont think i can change this, i did check the enhanced trainer and the control key for this is f4 so this shouldnt make a difference. it is like the scipt hook wont read anything?

    Thank you

  • ![alt text](0_1547935087637_upload-a49d6c6e-0cc7-4aba-af52-3998b69fcf17 image url)

    This is my main folder after re downloading it all and re installing

    Thank you

  • @Bodders
    You have 2 separate installs of GTA V then yeah? If that is the case even if you rename the folders the registry entry will not change.
    Can you open a 'Run' command & type 'regedit' & then move to this location:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Rockstar Games\Grand Theft Auto V]

    & confirm the folder path in the 'InstallFolder' entry is correct for the version you are trying to get to work?

    Also, as there is no 'Unblock' setting in File Properties can you confirm what kind of User Account you are using? (Standard User or Administrator?). Win10 instructions/info here & here.

    Is this your computer or are you using someone elses? ie Who manages it usually? It's just that the unblock is default in Windows & you have to registry hack (as I have done) to remove it. You don't sound like hacking Windows is really in your skill set. No offense :slight_smile:

    Did you check your file & folder permissions & whether you have ownership of the hard drive & GTA V install folder? Folder permissions can be quite complicated to get right unless you know what you are doing & usually it will throw errors on certain files & you have to press continue or ignore etc or the process will not continue past that point. The errors don't matter usually, It's just you haven't mentioned anything to do with that?
    Also Windows usually throws a security warning if you try to take ownership of a hard drive at it's root (ie In My Computer/This PC).

    To me it looks like there's a chance it might be a Windows problem. Either some sort of registry conflict or scripthook does not have the correct permissions etc.

    Can you right-click the 'Grand Theft Auto V' folder & select 'Properties' & then the 'Security' tab & confirm that 'SYSTEM' & your user account have 'Full Control' ticked?

    Send us screens of that & then hit the 'Advanced' button & send us screens of the 'Permissions' & 'Owner' tabs also. Thanks :thumbsup:

    Also, can you try this Visual C++ Runtime Installer (All-In-One) v56 (downloads top-middle-rightish) which should uninstall all the runtimes you have & then reinstall them all correctly. As mentioned on the page often when you install the Visual C++ Libraries from 2005, it places one of its DLL files (msdia80.dll) incorrectly in the root folder of the largest accessible partition with free space. This AIO will install everything correctly :thumbsup:
    Also read the Editor's Note:
    "The 2017 runtimes are later versions of the 2015 runtimes with added support for new 2017 features. Therefore, from now on the 2015 runtime set will be known as 2017 runtime" so you don't get confused if it's missing etc

    What about Windows Defender? Do you have that turned on? You don't need it if you have another anti-virus.


    @Bodders said in Modding advice (newbie):

    With open IV i only have 1 copy at a time named v, i change the other names to make sure it doesn't read the incorrect folder if that makes sense?

    So you do have two installations copies as I asked in the final part of my post?

    We've found the reason then

  • Sorry .. I didn't realise this would case much of an issue. I'll have a look at this tonight and update youthank you very much!
    Is there any other way I can use get mods and online without having a couple of copies?
    Again thank you

  • Sorry about the long delay.. have been very busy

    I have finally got the trainer to work. I didn't realise I had another copy of the game installed else where which it was reading from which I found by what you said @a63nt-5m1th . As I said I have ENT working now just trying to get the zombie mod to work

    Thank you very much

  • @Bodders said in Modding advice (newbie):

    Is there any other way I can use get mods and online without having a couple of copies?

    I don't play online but generally you would use a 'mods' folder for single player & then disable it (remove 'dinput8.dll' from 'Grand Theft Auto V' main folder/uninstall OpenIV ASI Manager plugins) before going online & then reactivate it when you want to play singleplayer again.
    Note: Make sure you don't go online with a modded game or you could get banned. Also, as I'm no expert on the process & I don't know exactly what you might have installed in your game folder so a little research into what is required to be disabled etc specific to you to play online safely with no risk of ban is advisable (Google etc). :thumbsup:
    Glad you got your game fixed anyway :thumbsup: If you like, create a new thread with detailed info on the Zombie mod you are trying to use (link to the mod as well) & what you have done so far to get it to work & I'll certainly have a look at it :thumbsup:

  • Thank you for all your help! After a fresh download of the mod everything works perfect! Thank you for you patience.. how do I delete this thread or mark it as solved? In the end the reason it wouldn't work as it was reading the game from a different location. I though I was modding the only version on my hard drive!
    Thank you again

  • @Bodders
    No probs bud. Glad you got your game working :thumbsup: @ReNNie should know how to mark it solved, I'm not sure (but would also like to know).

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.