Log in to reply

Corrupt Game Data Every time I add a mod

  • Hi everyone. So I've been struggling to mod my game for the past few weeks because everytime I add any addon mod such as addonpeds, I run into the damned 'corrupt game' pop up window, I've problaby deleted and re-installed my game a dozen times by now trying to get this to work, as well as just deleting the files inside of my mods folder and starting again, but I always hit the same corrupt data message. I've been modding GTA V since the very first few weeks of its PC release, and I've never run into this problem before

  • @Alaannnn Ok you need to go to where you will apply the mod (the directory) from open iv an example would be x64e.rpf and you click on such... It will show a red Warning and you want to click add to mods folder... You can not modify game data directly...

  • @Alaannnn Sorry it is not add to mods folder it is (Show in mods folder)

  • @JeffParkerModHDx yeah I know that I don't touch the original game files, I work only in the mods folder but I still get the same problem

  • @Alaannnn Huh... Yeah i legit do not know what to say but if i find out more i will let you know bro... I am very sorry this has been happening to you...

  • @JeffParkerModHDx dont worry man I appreciate that youre trying to help

  • @Alaannnn

    • What actual error do you get when is says corrupt game? There are a few 'ERR_FIL_PACK_3', 'ERR_GEN_INVALID' etc. Also, any '.log' files? If so, copy them to Pastebin & post the link/s here. Thanks

    • Do ALL add-ons cause this error or just some? List the ones that do & the ones that don't if you can. Link to the ones that break it if you can as that would be ideal :thumbsup:

    • If you can provide screenshots of your 'Grand Theft Auto V' main folder & 'scripts' folder (if you have one) that may help too.

    • Also, any other info that might be relevant to your game being different to the average install. Installed on external drive - copying 'mods' folder from old install - Just "upgraded" (sold soul :slight_smile:) to Windows 10 etc.

    • Are you redownloading ALL the mods you are trying to install each time you try to install them or installing them from the same files/location on your computer?

    • What version of the game are you running? Was it the same as you ran before (when it worked) or have you updated as you reinstalled etc.

    Got to cover the basics here, sorry.

    What modded 'gameconfig.xml' are you using?

    Also, have you installed OpenIV's 'ASI Loader' & 'OpenIV ASI' plugins (OpenIV > 'Tools' tab > 'ASI Manager') before installing any (esp. '.oiv') mods? It should look like this:

    ASI Manager

    Just double-check & confirm both of them ('openCamera' not important) are installed correctly. Uninstall & reinstall them too even if they are just in case :thumbsup:

    If you reinstall again, reinstall to a new folder location (in case of corrupt Windows registry etc). Maybe run CCleaner's Registry Cleaner once you uninstall but before reinstall. Don't worry, it's not like all other 'Registry Cleaners' that dig too deep. I've used it for 10+ years multiple times a week without a single error/problem. :thumbsup:


    Once it completes the scan & you 'Fix all selected issues' (backup registry if you want to feel safe. Option will appear), run it a second time to clean any leftovers. :thumbsup:

    Depending on what version (Steam, disc etc) of the game you are using you might want to look at verifying that your vanilla install is 100% fine (ie not corrupted etc).

    I have more ideas but that's probably enough to get you started. Let me know how you get on & we'll take it from there :thumbsup:

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.