Log in to reply
 

Rage Plugin Hook quits at Validating System Requirements



  • Hey Guys,

    i'm running GTA V via the Rockstar Launcher, not via Steam.

    I've installed LSDAPFR manually and installed the Up-2-Date version of RPH, but after it gets to "Validating System Requirements" it just closes.

    I've ran RPH in logging mode and get this:

    15:41:54.994: An unhandled exception has occurred.
    15:41:55.001: System.InvalidOperationException: Beim aufrufenden Thread muss es sich um einen STA-Thread handeln, da dies für viele Komponenten der Benutzeroberfläche erforderlich ist.
    bei System.Windows.Input.InputManager..ctor()
    bei System.Windows.Input.InputManager.GetCurrentInputManagerImpl()
    bei System.Windows.Input.KeyboardNavigation..ctor()
    bei System.Windows.FrameworkElement.FrameworkServices..ctor()
    bei System.Windows.FrameworkElement.EnsureFrameworkServices()
    bei System.Windows.FrameworkElement..ctor()
    bei System.Windows.Controls.Control..ctor()
    bei System.Windows.Window..ctor()
    bei =dKOVNqTPZASSZHvIT11DoBxidW=..ctor()
    bei =O1mJqbjd6zug26oSNjgrcZ3xhI=.=UuMJn7vnKNWjKs5oaCBP63SEIs=(String , String , String , Boolean )
    bei =YXpg4uD0DcNbVDSvXw9NCQ6ydO=.=fJNdzi0cxCIhJ9LzYFuH86FYFQ=(Boolean )
    bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    bei System.Threading.ThreadHelper.ThreadStart()
    15:41:55.003: Is terminating: True

    (Sorry, im German. in English it should be smth like the following:
    15:41:55.001: System.InvalidOperationException: The calling thread must be an STA thread because it is required by many UI components.

    I aint a developer, so i hope you guys can help. Thanks!



  • No Clues Eh? :/
    I wonder that i am the only person with that problem?

    Also (i didn't mentioned, because in my mind it was obvious) i played already around with forcing windowed mode, disable custom login, disabeling direct-x-hook etc.

    I already reinstalled Visual C++ thingy. No Change.



  • Hello, and sorry to be late. You can maybe delete the Game Backup, if you cant find it:
    Search RPH in the game root directory (where the GTA 5.exe Is locate) find GameBackups.rph and delete it. Hope you understood and it worked.



  • Have you tried launching it with -forcedwindowmode as a command line setting (either manually or via the RPH settings page)


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.