Log in to reply
 

How can I update/downgrade? I'm on 1.0.1365.1 and Scripthook doesn't work



  • I'm actually on v1.0.1365.1 and want to play with a Trainer or/and car mods but when I want to start the following Message is coming up.

    I had the "Updateblock" in my Firewall Settings and I was trying with it and without the rule... Both didn't work...

    Can you help me? :o

    Thanks
    CaptainTeck!

    Screen 1
    Screen 2
    Screen 3



  • @captainteck - I'll give it a shot if you don't mind. ;) Indeed, you are on version 1365.

    If you are getting a fatal for script hook, then my guess would be that you needlessly updated script hook to newer version. Remember that each script hook release works only with a respective game version. Having said that, revert to using script hook version 1365. Not the newer or latest one.

    In my experience and from what I can see in the third screenshot, the situation is just the same - you are using RPH made for the latest game update which means no RPH plugins will work for you on version 1365...

    If you still have it, use RPH version 1365. Otherwise, the game will not be able to run RPH.

    One more important thing - I can see you managed to avoid updates because you are on version 1365 (which is perfectly normal - it is possible to stay with that version). In that case, it is not needed to update RPH, script hook or script hook .NET!

    Wrapping it all up, you need to use files made for 1365 game build. In the future, do not update discussed files if you don't update the GAME itself!

    I hope I made myself clear and that you can solve your trouble. :slight_smile: Get down to work and let us know if it worked. ;)



  • Last but not least - remember that neither Script Hook nor Rage Plugin are backward compatible (why? :/) so it's not like you can use newer version for older game builds.



  • @TheMurderousCricket

    neither Script Hook nor Rage Plugin are backward compatible (why? )

    It's simple: support. Since GTAV updates tend to break things, it's hard enough to ensure one working version and quite another to have multiple versions with backwards compatibility to maintain and deal with bugs or breakage. The devs behind these programs aren't some million dollar business with 200 people devoted to maintaining libraries of code while working on new projects.
    TLDR keeping one version is already time consuming as is, multiple versions would be more headache than it's worth.


  • MODERATOR

    you can use the latest ScripthookV and SHVDN on older game versions just fine



  • @ReNNie said in How can I update/downgrade? I'm on 1.0.1365.1 and Scripthook doesn't work:

    you can use the latest ScripthookV and SHVDN on older game versions just fine

    See @Anonymoused281 this is what I, as a layman, thought - it shouldn't be a problem to get this to work!

    As far as I can tell, it is as simple as keeping the old settings and adjustments in the new file version. After all, the older builds do not get updated or changed and don't need any maintenance as such...


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.