Log in to reply
 

Removing props from the map



  • is there a way I can remove props from the map(fences, lamps etc) and have them not spawn again. I am working on a little something for trevors house and I want to get rid of the couch on the patio



  • @Boosted_Greek ... Use CodeWalker to find the entity and what ymaps it is located in. You'll have to "fly" the camera to Trevor's trailer while in CodeWalker, click the double arrow thing in the upper right corner to bring up a window to select stuff.
    Go to the selection tab and click the little box to select with right click. Make sure the drag down box is on Entity. Then right click on the couch and it will bring up info on the right side of that window you opened up. Copy down the name of the prop and then copy the name of the ymap. Then use OpenIV to search for the ymap name listed in CodeWalker. There will be around 4 or so ymaps that will pop up in the search window. Like a lr, a hei, or @hi. Make sure the folders with the ymaps are in your mods folder before deleting anything. Like if it is in x64a or wherever, that folder needs to be copied into your mods folder. A red banner will show up top when you are not in the mods folder. There will also be a button there to copy the folder to your mods folder. Go into the ymap and search for the prop you want to delete (the entity name you copied down from the info window in Codewalker) Delete the prop info from each ymap location in your mods folder. It should hopefully all make more sense once you start.

    Oh yeah, you'll need to be in Edit Mode in OpenIV to make changes and you need to right click on the ymaps and click edit.



  • @Boosted_Greek Also forgot, for the couch, you will also need to scroll down in each of the ymaps and remove it's line from the physics dictionary. I went ahead and made a little video where I remove that couch, also towards the end, since R* server is down right now, I show how to check your work in CodeWalker and I also remove the table so you can see that process too. The table doesn't have anything in the physics dictionary. For the files that I open that don't have anything or just the physics dictionary section I delete, that's because I started the video and deleted some stuff then had an issue, had to restart and so your files will have more to them.



  • since you can move objects, couldn't you just move the prop underneath the ground so its no longer visible and then make that changed ymap a custom map for single player or stream the ymap for FiveM?



  • @Quakex64 I suppose you could just move stuff under the world, I haven't tried it. Seems lazy to me, you could just take the extra 10 minutes to properly delete the items. Then you can start a new project in CodeWalker to add items and save that ymap for use. That way no issues happen from having a bunch of unnecessary crap under the map.



  • @chonkie thank you for making the video you helped me a lot but i still have one problem.. i removed objects but kind of the texture is still there but no collison, you can see in the image im talking about the trailer https://imgur.com/a/lGZED9l



  • @SatlaItay---ItayAH Honestly at first glance of your pic, it looks like what setting up a collision looks like in 3ds. But you shouldn't see collision in the game and you said it wasn't collision, so my next guess is that you just didn't delete all the info necessary to completely remove it. Maybe it is a lower LOD that you would need to delete since in your pic it doesn't look that smooth to put textures on. I'm not 100% sure on that though. Let me know the info on that object and I'll look into what is needed to completely remove it and I'll let you know what you missed. I would look for it myself, but am unfamiliar with the area in your pic.



  • @SatlaItay---ItayAH I found what you are modifying. I'll take a look and let you know.



  • @SatlaItay---ItayAH I just tried and removed every dang thing related to that trailer and it still appears in my game too. I deleted every LOD of that trailer, I even went so far as to delete the LOD that you have to be reeeeeeaaaally far away to activate, in fact that LOD removes a lot of stuff like part of the road, parking lot, etc ... and that didn't solve it in game. Of course when I flew really far away, everything disappeared that was in that LOD but I was so far away that I wouldn't have been able to see if that image was still there.

    I can't find reference to it in any way in CodeWalker, so I'm stumped. I do know R* put odd test stuff in places that we weren't supposed to see. Maybe that part you found was originally a mistake and so R* made that whole area full of trailers so putting that trailer there covered it up. That's just a wild theory of mine. Heck, I found what looks like the twin towers out in the ocean near the edge, but even that I can select and manipulate.

    Hopefully someone else will have an answer, cause now I'm curious wtf it is. The low detail LOD shouldn't come into play if you are making an "interior" and you are always fairly close to it.



  • Here's a video of what I did trying to remove that trailer. This is after I already deleted the files you probably deleted to get to the point you were at.

    I didn't think removing the low lod and vlow lod would do the trick and it didn't, but sometimes weird stuff happens so I tried anyways. I don't know much about how the parent/child thing works, so it might be something like that. I looked around but couldn't really find much pertaining to that and the trailer. At the end of the video, it shows I didn't delete that LOD, but I did end up deleting that just to see what would happen.



  • alt text



  • @chonkie thanks for trying to help and sorry for responding to late..
    i just moved the build and now its fine https://imgur.com/a/O9s0AwU https://imgur.com/a/jRrgO31 https://imgur.com/0XxHahz


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.