Log in to reply

My game will not load any addon vehicles.

  • My game will not load any addon vehicles. I tried using a mod folder and it loads the game but no addons. I tried vanilla 'update' but the same thing. I even edited the dlclist in the 'common' but nothing works. I uninstalled my game and reinstalled hoping to fix the problem but its the same. I have been modding for 2 years and never had this happen.

  • Well first thing first. Did you install ScripthookV into your directory? What about OpenIV.asi? What trainer are you using? If it's simple native trainer after doing these steps check under vehicle spawning and check under added vehicles.

  • @Algonquin1234 I've installed the asi from open IV, I have the latest scripthook and scripthook.net. I'm using the latest simple trainer. and it's not just addon vehicles, it's addon dlc.

  • @KarensJohnny

    Always use the mods folder.

    • Create a folder named mods in your GTA V directory
    • Copy/Paste your update folder into your mods folder
    • Read the install instructions from your downloaded add-on car

    Don't forget you need things like a Gameconfig to stop crashes also.

  • @H3llo you guys are telling me things I already know. I have everything I've always had in modding. for some reason nothing works. I can load into my game with the dlclist edited but it acts like there are no addons present in my game. I can't spawn by name or check through the addon car list

  • @KarensJohnny

    Have you been into the game directory to make sure that the dlc list contains the entries for your dlc vehicles still and another mod/OIV installer has not overwritten it ?

    Are you on steam and able to Verify the Integrity ?

    Last but not least try removing OpenIV.asi and re installing it through OpenIV

  • My dlclist contains all of the dlc from Rockstar and the ones I added. that's it. everything was added manually, so no OIV installer has overwritten anything. I'm on steam and my game is up-to-date. and I installed OpenIV.asi through OpenIV. I was unaware you could install it anywhere else. What game config are you using? and are you using heapadjuster.asi and packagefilelimiter.asi? sorry for long replies, I can only reply every 600 seconds.

  • @KarensJohnny

    No problem. Ok so we're just narrowing down things at the moment.

    I always use the gameconfig made by F7YO :https://www.gta5-mods.com/misc/gta-5-gameconfig-300-cars

    I also use the HeapAdjuster and the PackageFileLimiter yes.

    Any chance you could check your ScriptHook/ASI logs ?? They might have some helpful answers.

  • @H3llo Alright, that's the config I'm using. I have never had this problem before. here are the logs.

    ASILOADER: API: "DirectInput8Create" => 00007FF88F918FD0
    API: "DllCanUnloadNow" => 00007FF88F92A150
    API: "DllGetClassObject" => 00007FF88F92A220
    API: "DllRegisterServer" => 00007FF88F934130
    API: "DllUnregisterServer" => 00007FF88F9343B0
    LOADER: Loading *.asi plugins
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\GTAV.HeapAdjuster.asi"
    "GTAV.HeapAdjuster.asi" => 00007FF89F810000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\openCameraV.asi"
    "openCameraV.asi" => 00007FF89B130000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FF88F4A0000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\PackfileLimitAdjuster.asi"
    "PackfileLimitAdjuster.asi" => 00007FF89F3F0000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" => 00007FF8A8000000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\TrainerV.asi"
    "TrainerV.asi" => 00007FF85CB10000
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\Xenolit Additional Car Controls.asi"
    "Xenolit Additional Car Controls.asi" => 00007FF88C9D0000
    LOADER: Finished loading *.asi plugins
    // GTA V SCRIPT HOOK (build Feb 10 2019, v1.0.1604.1)
    // (C) Alexander Blade 2015-2019
    [18:21:34] INIT: Started
    [18:21:34] INIT: Success, game version is VER_1_0_1604_1_STEAM
    [18:21:34] INIT: Registering script 'ScriptHookVDotNet.asi' (0x00007FF8A8001390)
    [18:21:34] INIT: Registering script 'TrainerV.asi' (0x00007FF85CD943A0)
    [18:21:34] INIT: Registering script 'Xenolit Additional Car Controls.asi' (0x00007FF88C9D6A20)
    [18:21:41] INIT: Pool 1 extended
    [18:21:41] INIT: Pool 2 extended
    [18:21:41] INIT: Pool 3 extended
    [18:21:41] INIT: Pool 4 extended
    [18:21:47] INIT: GtaThread collection size 189
    [18:21:47] INIT: wnd proc 0x00000000FFFF0AE7
    [18:21:47] INIT: IDXGISwapChain 0x00007FF8AF6F4568 (0x00007FF8AF684910)
    [18:21:47] INIT: IDXGISwapChain set
    [18:21:47] INIT: DX init started
    [18:21:47] INIT: DX feature level B000
    [18:21:47] INIT: DX init succeeded
    [18:22:36] CORE: Requesting thread creation
    [18:22:36] CORE: Creating threads
    [18:22:37] CORE: Started control thread, id 33 active 1
    [18:22:38] CORE: Started thread 'ScriptHookVDotNet.asi' (0x00007FF8A8001390), id 34 active 1
    [18:22:38] CORE: Started thread 'TrainerV.asi' (0x00007FF85CD943A0), id 35 active 1
    [18:22:38] CORE: Started thread 'Xenolit Additional Car Controls.asi' (0x00007FF88C9D6A20), id 36 active 1
    [18:22:38] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FF8A8001390), id 34
    [18:22:38] CORE: Launching main() for 'TrainerV.asi' (0x00007FF85CD943A0), id 35
    [18:22:38] CORE: Launching main() for 'Xenolit Additional Car Controls.asi' (0x00007FF88C9D6A20), id 36
    [18:23:18] UNINIT: Unregistering script 'Xenolit Additional Car Controls.asi'
    [18:23:18] UNINIT: Unregistering script 'TrainerV.asi'
    [18:23:18] UNINIT: Unregistering script 'ScriptHookVDotNet.asi'


  • @KarensJohnny , Have you installed the addon cars in the correct folder within Mods? Look here in this image, so I do.

    alt text

    On the other hand, have you edited the correct Dlclist.xml? Look at this image, so I do.

    alt text

  • @josketer yes and yes. Like I said, I’ve been modding this game for so long, I can do it with my eyes closed. Never had this problem before and it makes absolutely no since why it doesn’t want to work.

  • I would really like a solution. I've uninstalled GTA 5 twice. The game acts like I don't have a mods folder. What is the problem with that?

  • @josketer I'm using F7YO Gameconfig and it is 90kb but yet yours is only 59. Why is that?

  • Also thought I should mention, as a last resort, I changed all my dlclists' to the modded dlclist, and they still wont load even if I put my mods in the vanilla update

  • @KarensJohnny When you use OpenIV do you see you mods folder as purple ? You should really hold off on editing the vanilla files as even if you back them up and replace them they lose encryption.

    I honestly am at a bit of a stand still here, it's one of those situations where you'd usually blame user input but since you say you've been doing this for a good while i'll give you the exception, the next step we can take will seem quite tedious.

    I need you to only use the bare essentials for a moment which would be ScripthookV(ASI loader), OpenIV, and Simpletrainer.

    You need a fresh mods folder

    Start by downloading just 1 add-on car and install it via the given instructions to your new mod folder.

    Try spawning the car in game and see if it works, If it don't we can say that we've eliminated old scripts and or asi's and that your mod folder also wasn't the culprit.

  • @KarensJohnny ,I also use the one from F7YO, but the size of the gameconfig.xml file varies according to the version of the game you use. I use the 1493 version of the game, because I like to use scripts, mods, addon cars and peds. I'm not interested in the online version, to play deathmatch I prefer other games like Quake , Doom ...

  • Hello, here's my option. Go to mods\update\x64\dlcpacks[your mods]\dlc.rpf\content.xml.

    Delete "locked value", turn all value to false.

  • Hi @KarensJohnny I got the same error but I think I have solved this. I have the original GTA 5 game from epic games and for installing the mods I downloaded the crack version, so when we install openIV it searches the system for the game folder in the C:\Program Files and the loads it.
    If you have another a copy in any another directory you need to change the game folder directory in openIV from Tools->options->Game->GTA V Directory there you can see change directory option. After changing the directory you need to restart the openIV then you need to install the options in ASI manager. This solved the issue for me so try this and if it doesn't work please reply to me I will tell you what other changes I have done.

  • @VamsiVK35

    1. Timely response, you're only 3 years late. OP and others can finally breathe a sigh of relief.

    2. Cracked versions often contain malware, viruses, trojans, or other goodies that can slip by anti-virus software, some even come with instructions telling you to dismiss warnings that the exe is infected. Wonderfully stupid advice.

    Discussing pirated or cracked games, even if you purchased the game, isn't allowed on these forums. Aside from the legal reasons see point 2 above.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.