Log in to reply

"You must be signed in to Social Club to play Grand Theft Auto V" after installing mods

  • I'm new to modding GTA V but I've been trying to lurk and learn, so forgive me if I've missed something obvious. Here is what I am doing:

    1. Install GTA V via Steam
    2. Run it, confirm that I'm able to sign in to social club and play both online and single player.
    3. Install OpenIV, ScripthookV, and Menyoo (and activate ASI loader and OpenIV.ASI in OpenIV)
    4. Run GTA V and get a message about how I'm not signed in to Social Club. Screenshots.

    Really at a loss about how to fix this. I've tried disabling firewall, plugging directly into modem in bridge mode, but I don't think its a network issue since unmodded everything connects fine. Its also weird how in the second screenshot, you can see that social club pops up and shows that i'm logged in but none of the menus load. If I close out of the social club interface it just goes to the "you must be signed in" screen.

    Also weird, GTAV will run after installing JUST ASI Loader, OpenIV.ASI, and ScripthookV. But as soon as I try installing a trainer like native trainer or menyoo, it breaks. I haven't tried other .asi mods yet.

    Some other troubleshooting I've tried: Reloading .net, reloading Visual C++2013 redist, reinstalling social club, clearing literally everything GTA related off my PC and starting again from scratch... Any advice? GTA version is build 1604.1

  • Welp, I fixed it I think. Disabling windows defender real time protection seems to have fixed the issue... Feel dumb that thats whats been preventing me from modding for the past few days lol.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.