Log in to reply

None of my addonpeds or scripts are working

  • Hey so a couple days ago I started to mod my gta 5 just to play story mode and mess around with mod. I followed all the steps and did everything to the letter and none of the mods will load in game.

    I added:




    Native U

    LUA Plugin for Script Hook V 10.1

    Scooby- Doo Shaggy 1.0

    Scooby Doo Mod

    Scooby Doo's Mystery Van v2.0

    Deadpool [Add-On]

    Rick Sanchez (Rick and Morty) [Add-On] 3.0

    Portal Gun Script (Rick and Morty) 3.1

    This should be all of it. I tried watching videos and looking on forums but nothing I try works.

    If anyone knows what to do some help would be great.

  • @xXChefDopeyXx
    Have you also installed:

    .NET Framework ≥ 4.7.2

    Visual C++ Redistributable for Visual Studio 2013 x64 (Download 'vcredist_x64.exe' after you hit [Download] button).

    Visual C++ Redistributable for Visual Studio 2017 x64 ('vc_redist.x64.exe' link :thumbsup:).

    & OpenIV's ASI plugins (OpenIV > Tools > ASI Manager > & make it look like pic below).

    OpenIV ASI Manager

    Perhaps also have a look at the mod pages of the mods you have installed & double-check you have all of the requirements the mod author suggests.

    Also, do you happen to have 2 separate installs of GTA V on your PC? Let me know if so, as it breaks functionality like you are experiencing but there are workarounds for it (use 'mods' folder instead, registry edits etc).

    Try that out & if you are still having problems get back to me with a screenshot of the contents of your main Grand Theft Auto Folder. :thumbsup:

  • Hey I checked all the mod pages to triple check if I needed to download anything and I have everything they suggest. I haven't downloaded the programs you mentioned yet. I uninstalled openCamera in the OpenIV manager and I've had the other two downloaded. Here's the contents of the main folder. I only have one copy of the game downloaded.


  • @xXChefDopeyXx
    Don't notice anything out of place or missing in your screenshot.
    Download & install those .NET & Visual C++ Redistributable files I linked to (they are vital to getting it all to work) & get back to me :thumbsup:.
    If you are still having trouble after that, post the contents of those 3 '.log' files ('asiloader.log', 'OpenIV.log' & 'ScripthookV.log') to Pastebin & share the links to them here :thumbsup:

  • @a63nt-5m1th The response is below. Thanks for the help.

  • @a63nt-5m1th
    .NET is already downloaded according to the install menu.
    Visual 2013 is already installed and asks if I want to repair, uninstall, or close. I clicked repair but it ran into problems and said fix log file.
    I downloaded Visual 2017 and it went smooth.

  • @xXChefDopeyXx
    Hmmm? That error needs to be ruled out as the cause of you problems. You might try downloading the Visual C++ Runtime Installer (All-In-One) v56 provided by MajorGeeks here.


    When you get to the MajorGeeks page, download the 'Visual C++ v56.exe' file from either of the links I've highlighted in the pic above (forget the installer version), reboot your PC & then run the file & follow the instructions in the black box that opens & it should automatically uninstall & reinstall all Visual C++ Runtimes for you. :thumbsup:
    After that (probably reboot again) & then test your game. If you still have problems, paste copies of those 3 '.log' files to Pastebin & post the links here. Thanks :thumbsup:

  • @a63nt-5m1th
    Its still not working. In one of the cut scenes of the game it was weird cause there was a green portal from the portal gun mod in the background.

  • @xXChefDopeyXx
    You need ScriptHookVDotNet (download 'ScriptHookVDotNet.zip' from link at bottom of page) for the Portal Gun (for the versions of it I checked anyway). I don't see it in your GTA V root folder screenshot.

    Place 'ScriptHookVDotNet.asi', 'ScriptHookVDotNet2.dll' & 'ScriptHookVDotNet2.xml' in your 'Grand Theft Auto V' root folder (where 'GTA5.exe' is) :thumbsup:

    Stil having trouble? Might be worth looking into reinstalling .NET Framework (see here) & if you have any trouble with that (unable to uninstall it etc) try running through the advice here :thumbsup:

  • @a63nt-5m1th
    Hey nothing seems to be working. What log files and screen shots did you want and how do you want me to send them?

  • @xXChefDopeyXx

    Post the contents of any '.log' files you find in the main GTA V root folder ('asiloader.log', 'OpenIV.log' & 'ScripthookV.log' for example) to Pastebin & share the links to them here. Thanks :thumbsup:

  • @a63nt-5m1th

    GTA V Script Hook

    Too many characters

    ASI Loader

  • @xXChefDopeyXx
    What Trainer do you have installed? Pick one, install it :thumbsup: Spawn the Bravado 'paradise' & see if it is the Mystery Machine?
    I'll need to do further research & testng but I'm begining to think your game is working fine it's just most, if not all of the mods you have chosen to install are 2 to 3 years old & no-longer function correctly (without finding a work-around or fix for them etc).

    Best way to test this is to pick some recently updated mods that require scripthook/vcredist/.NET etc, install them & see if they work? If they do, then you game is working fine & you know you need to concentrate on fixing or finding a workaround for Add-On Peds if you want the mods you mention in your first post to work :thumbsup:

    Here are a few ideas of scripts to test: (simple scripts, easy to uninstall (delete/move them), won't change anything in game files, changes are easy to see in-game :thumbsup:)

    Street Racing 0.9.3 -

    • ScriptHookV
    • ScriptHookVDotNet2
    • NativeUI

    Watch Your Death 3.2 -

    • .NET Framework 4.5.2
    • Script Hook V
    • ScriptHookVDotNet

    VRope [.NET] v1.0.10 alpha hotfix2 -

    • ScriptHookV
    • ScriptHookVNet
    • .NET Framework v4.6.1

    Alternatively, scour the site for scripts that suit your need (ie it requires: Scripthook or ScripthookDOTNET or vcredist2013 or vcredist2017x64 or .NET Framework ≥ 4.7.2 etc) that you actually want to install to your game or sounds fun to mess about with etc. If you can find one you like the sound of that requires all of those prerequisites you can do it all in one go :thumbsup:

    Note: If any ScripthookDOTNET scripts work then you can mark Microsoft .NET Framework 4.5.2 & Microsoft Visual C++ Redistributable Package for Visual Studio 2013 (x64) off you list too as they are requirements for Community Script Hook V .NET.

    Add-On Peds is the main one you want to get working but you're not the only one having problems with it. Have a look at this video & also trawl through the Add-on peds Comments section. Hit the 'Show previous 20 comments' button a heap of times & track back to August 2017 (the latest release) & read from there to see if you can find any solutions that users have posted (Ctrl+F in your Browser will be useful to search) & that you can try out.
    If any users confirm they have it working, send them a message & see if they are willing to share that information.
    Alternatively, create a new thread & see if anyone can confirm if it is even possible to get Add-on Peds to work now that it is so old & how to do it?

    Note: The Portal Gun Script (Rick and Morty) 3.1 also requires Portal Gun (Rick and Morty) [Add-On] 2.0 to function correctly :thumbsup:

    Do you have any idea about the state of Add-on Peds & whether it even works/how to get it working/workarounds etc? Cheers :thumbsup:

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.