Log in to reply

Trainers/Mods won't work.

  • JUST TO START YOU OFF: I've been modding for years so I don't really need a lecture on what's what, I just need help on getting my scripts to start working again.

    Basically, one day when I was just feeling like playing some GTA, pressing F4 wouldn't open the Enhanced Native Trainer. I exited the game, removed the ScriptHookV DLL file, the dinput8.dll file and the mod files I had installed. I later re-installed them and tried opening the trainer yet again. This wouldn't work and my mods haven't been working for almost a month now (they stopped working around April 16th.)

    So I started looking for help in the ScriptHook V thread on the mods site. One individual gave me a bunch of fixes, I tried them all and unfortunately none would work.

    Now, since he's exhausted his solutions, I've decided to look for help on here instead.

    Here are a few screenshots:
    1 - Game Directory
    2 - Scripts Folder
    3 - Mods Folder

    Here are the fixes I've exhausted:
    Re-installing the files.
    Downgraded my NativeUI.dll file to 1.7.00.
    Trying different Trainers (Native Trainer, Enhanced Native Trainer, Simple Trainer, Menyoo etc.)
    I've also tried re-installing GTA V entirely and then re-installing all the other files.


    Do you have two copies of the game installed on your PC? See my posts here if so. I just don't notice any '.log' files in your Game Directory pic (unless either that 'ScriptHookVDotNet2' file is a log file with the extension hidden or you had not run the game yet when you took the screenshot).
    Is a 'ScriptHookV.log' file being created when you run the game? If you're still having trouble once you run through all of this, post the contents of any '.log' files you have to Pastebin & share their links here (or alternatively, upload them somewhere so I can have a look at them). Thanks

    If you right-click 'dinput8.dll' & then go to 'Properties' is there an [Unblock] button? Unblock it if there is & also check other important files ('.dll', '.asi' etc) you have placed in your 'gta' or 'scripts' folder manually for the same thing :thumbsup:


    Try going to this directory, make a backup of 'ent.db' & then delete it (if it exists).

    C:\Users\YOUR-USERNAME-HERE\AppData\Roaming\GTAV Enhanced Native Trainer\ent.db

    See here or here if you have trouble finding the 'AppData' folder :thumbsup:

    Reinstall ENT if you don't have it & then load up the game & see if you can now open the ENT menu?

    Specifically, what scripts did you have installed previously/want to have installed now? You can link to them if you like :thumbsup:

    'mods' folder:
    I take it the screenshot of your 'mods' folder is from when you reinstalled? Just wondering why empty?

    Extra Questions/Ideas:
    Have you tried running your game with your antivirus disabled?

    Can you right-click your 'gta' folder > 'Properties' > 'Security' tab & confirm 'SYSTEM' & your user accounts (inc Administrators) have 'Full Control' over the folder?

    Folder Security Permissions

    Have you checked that you have all the .NET & Visual C++ Runtimes required for the scripts you have to work?

    You might try downloading the Visual C++ Runtime Installer (All-In-One) v56 provided by MajorGeeks here.


    When you get to the MajorGeeks page, download the 'Visual C++ v56.exe' file from either of the links I've highlighted in the pic above (forget the installer version), reboot your PC (so it's fresh) & then run the file & follow the instructions in the black box that opens & it should automatically uninstall & reinstall all Visual C++ Runtimes for you. :thumbsup:

    For .NET Frameworks you can find instructions & links on this page :thumbsup:

    Also, if you can, link to the ScriptHook V thread you were recieving help on so I'm not going over stuff you have tried previously :thumbsup:

    Let me know how you get on with that anyway & we'll take it from there. Best of luck :thumbsup:

  • @a63nt-5m1th
    Thank you so much for the help, I tried many fixes, removed my second instance of GTA and nothing really worked.

    After a couple of weeks, I got the tip from a friend to check the GTA regkeys and then I realized that I hadn't changed my installation follow in the registry. After changing it, all of my scripts started working.

  • @UNKNOWNTEMPTATION said in Trainers/Mods won't work.:

    After a couple of weeks, I got the tip from a friend to check the GTA regkeys and then I realized that I hadn't changed my installation follow in the registry. After changing it, all of my scripts started working.

    Would you mind elaborating on that? Sounds like a useful tip if something goes haywire.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.