Log in to reply

GTA crashes on launch with "mods" folder

  • I'm having trouble launching the game with the "mods" folder in my installation directory. I am by NO MEANS a professional modder, so there may be some crucial steps I've missed here.

    I'm running the latest version of GTA 5 (yesterday's casino update), and it is the Social Club version, not the Steam version.

    I have had luck in the past using graphics mods installed via OpenIV. After the update, my game was having some issues with crashes so I did a fresh install and it worked fine. That is until I downloaded this mod: https://www.gta5-mods.com/vehicles/realistic-top-speed-for-gta-v

    I followed the instructions thoroughly, and copied all of the correct folders and .rpf files to the "mods" folder. The directories are the exact same as they were in the main installation folder, except instead of C:/Program Files/Rockstar Games/GTA V/update it is C:/Program Files/Rockstar Games/GTA V/mods/update etc.

    The only file I modified is the handling file. I can confirm the the game will launch fine if I move the mods folder somewhere else. When the folder is in the install directory, it crashes every time.

    I can get the game to run with the mods installed using FiveM Singleplayer, but the actual mod itself isn't working.

    If the installation instructions on that handling mod page are correct, I have followed the correct steps in installation. I've tried changing the shortcut target for the launcher by adding "-scOfflinePlay" at the end, which allows me to play offline, but still won't launch my game. Does anyone have a clue as to why this is? I can include any other info you need.

    Thanks for your help.

  • To further clarify, when I swap the handling file from that link into ANY of the files in the main installation directory, my game immediately starts to update and remove the mods (when launches from Social Club launcher). If I try to launch from FiveM, it gives me an error and crashes. The game ONLY launches when the mods are placed in the "mods" folder. But they mods don't work then. I'm kind of at a loss. I only wanted to improve the game experience by giving the cars a higher top speed, but nothing seems to be working. If anyone can chime in or let me know if I did something wrong, it would be greatly appreciated.

  • Ok lets start with one thing at a time here. Do you have ScripthookV.dll and ScripthookV.net.dll in your GTA V directory? If not install them and place them in the root folder of gta 5. Do you have all the openiv.asi files installed in the GTA V folder? If not, then open up OpenIV and click on tools and then asi manager. I had this mod and I used the OIV installation because it's faster and there's no chance of any errors because it's automatic. It also puts all the necessary files during the installation. If the above are ok then make sure you have a good Game Configuration. Do not by any means install any mods into GTA V without a mods or scripts folder. Unless it's an ASI mod which you just have to put to your directory.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.