Log in to reply

[HELP] Missing Diamond Casino Exterior

  • With the latest version of the game, the casino exterior will not load, and it appears as a giant hole for that part of the map. It does, however, not drop into the void because it is using the original casino hitbox. What does work are the new Diamond Casino props including the fake casino interior that is visible from the outside.

    If I use nothing but an updated gameconfig, everything works fine. But, even adding a few simple things to the update.rpf such as carcols, carvariations, handling, vehicles.meta, and popgroups result in the new exterior vanishing leaving nothing but a hole.

    I have replaced countless times with a reinstall:
    the update.rpf
    mpvinewood (the dlc update)
    and even x64p.rpf which contains pieces that the casino should be replacing.

    Even if you don't know an immediate solution, I could most likely figure it out with just knowing where the files for just the exterior map pieces for the new casino are located and the files in the update.rpf that are responsible for loading it in (or any files that would load it in).

    Here are the pictures of what it looks like:

    EDIT: You can note in the second picture that the lower LOD for that piece of the map goes missing entirely as well. It could be another map piece that might be disrupting the casino, even though other pieces are fine up close.

  • What specific mods are you running? Some of what you mention sound like pieces of different ones.

  • @Anonymoused281
    In one of the tests that I did, the only mods I had was a customized handling (for realism), carcols (for using full-body liveries), carvariations (for a few color changes), vehicles.meta (for changed vehicle spawning occurrences), and an updated gameconfig (because it wouldn't work with the default one) all of which were located in the update.rpf in the mods folder. My dlclist only had the default Rockstar dlcs. This alone made the casino exterior not load. I also did one with just the gameconfig, and the casino exterior worked then. I've tried multiple gameconfigs. It's not the gameconfig causing the problem.

    I think the problem is deeper than I thought because last night, the game stopped reading 3d files for vehicles and vehicle mod parts for one of my addon packs without me doing much to the game. All I did was reinstall gta5.exe (just testing a hypothesis related to the casino) through steam, and it did that to me.

  • I am reinstalling GTA V right now. If the problem persists, I'm going to assume that one of the external programs that helps run GTA V is the problem.

  • This post is deleted!

  • Alright, so far I have my addon mods installed with a working casino, and I am slowly adding things to the update.rpf. So far I have the handling and carcols in just fine.

  • Okay, the other missing addon mods were because the vehicle and vehicle mod .RPFs somehow got corrupted. That was a simple fix with backups. I slowly rebuilt the update.rpf the way I had it set up prior, and the new casino exterior still works. The reinstall worked. I must have had something corrupted in my main game.

  • @JustHelpMeFixMyMods Hi there! Did you find any solution to the casino disappearing poblem after the tests that you run? What was causing the problem?

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.