Log in to reply

Need help troubleshooting my DLC pack crashing RAGE client

  • Hey,

    I have in May started working on a DLC pack involving a map to be used on RAGE MP. I've set up texture dictionaries, model (only one building), YMAP, YTYP and MANIFEST file(s) in their respective RPF.

    For some reason, whenever I try connecting to my RAGEMP local server it crashes with the below crash message.
    alt text

    I have tried deleting client_resources folder to then re-download everything into my client though nothing helps. It's worth noting that I used this DLC pack creator to create the setup2 and content xml files https://www.gta5-mods.com/tools/dlc-pack-creator. I have also added my DLC name to dlclist.xml in GTA V\mods\update\update.rpf\common\data\ .

    The DLC shows up on Codewalker (where I usually test the models) when viewing the DLC levels dropdown menu. Everything works just fine there.
    I want to mention that I have set up the YMAPS and YTYPS etc. for every model in the map, although in the DLC I've only added 1 model. Is that a problem? Is the game crashing because the game can't find the rest 2000 models?

    Please, I highly appreciate replies to this. I have been stuck on this for a very long time. Thank you in advance.

  • Update: I have been told that the problem is likely to occur due to the DLC pack only containing 1 model, while it's full of YMAP/YTYP files that tells the game there are 3000 other models (basically I had a lot of missing models).

    I have now corrected this by instancing a random object and naming it that of the 3000 missing models, as sort of placeholder.
    I have also verified (3 times?) that I have no more missing models, by going through every YMAP file using Codewalker - everything is just fine and there's nothing missing.

    The file types that my DLC pack contains are YTD, YDR, YMF, YMAP, YTYP, RPF, content.xml, setup2.xml.

    I am looking forwards to help on this. Thank you!

  • Update: I was recommended using the ArchiveFix tool https://gtaforums.com/topic/871168-affix-fix-your-rpf-archives-and-work-without-openiv/#comments and thus did that for both dlc.rpf, vice.rpf and vice_metadata.rpf. The latter 2 rpf are stored inside dlc.rpf so just wanted to make sure to do those too.

    When I checked them with OpenIV there was literally no change. The files did change the time/date that they were modified, but I couldn't spot any difference. No encryption or anything. Worst of all, my DLC wasn't fixed and it still crashed my RAGE client.

    After all of this, as suspicion that it crashed due to some models being outside the red boundaries in below image, I made sure to only include parts of the northern map through YMAP/YTYP and MANIFEST files - yet I still crashed.
    alt text
    I'm at the point where I feel I've tried everything and am getting very frustrated why crashes still occur. I have looked into someone else's DLC pack which essentially has the same type of files as mine does, nothing obvious different. Although the YMAP/YTYP's in that other DLC can't be accessed by OpenIV, so I'm assuming that it's "properly" encrypted or so.

  • I fixed this by using RpfEncrypt as ArchiveFix didn't seem to work at all. I am so glad I came across of this awesome thread. Check it here: https://rage.mp/files/file/150-rpfencrypt/

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.