Log in to reply

ASI Mods working, but scripts (DLL) won't load at all.

  • Hello all I've been having an issue since first starting to mod GTA V. My ASI mods load without a problem, but any script mods fail to load. See below for details...

    Things to Note

    • I have a ScriptHookV.log but no ScriptHookDotNet.log or ScriptHookDotNet2.log
    • I use GTA V Mod Manager
    • I noticed that even with the scOfflineOnly command, it still connects me to my Rockstar Social account. If I cancel the login GTA V fails to load all together.
    • The asiloader.log shows ScriptHookDotNet loading correctly as well as my other asi mods. Same goes for the ScriptHookV.log file.
    • I've made sure I have the latest greatest .Net version along with the Microsoft Visual C++ 2012 through 2017 Redistributables
    • I'm on Windows 10 Pro 1803 and am currently in the process of upgrading to 1903.
    • The script mods I'm trying to run are Open All Interiors & Benny's Original Motor Works in SP 1.8.10
    • Ironically I can get the FuelScript mod to work, but that uses lua not DLL.

    Things I've tried

    • Reinstall of GTA V
    • Replaced ScriptHookV with latest greatest along with ScriptHookDotNet
    • Modded GTA V directly versus using Mod Manager.
    • Different versions of dinput8.dll

    Any help on this matter would greatly be appreciated. I'm running out of ideas.

  • @iSteiN Post more info, game version, other mods and their version numbers and don't just say you have the updated versions, because some things on the site are not the current versions, like Menyoo for example, which you have to download from github for the current one. Post screenshots of your gta root directory, mods folder, scripts folder. Maybe you have some things in the wrong spots. Open All Interiors is an asi mod.

  • @chonkie Thanks for the reply. Please see below...

    Game Version: 1.0.1737.0
    ScriptHookV Version: 1.0.1737.0
    ScriptHookVDotNet Version: 2.10.10
    Bennys Mod Version: 1.8.10
    GTA Root Directory: 0_1567840694974_upload-c341a09b-1c8f-4c9b-be89-d27e2b6e54ca
    Mod Manager Mods Folder: 0_1567840759355_upload-d7a73986-6df1-40ee-9a65-cdb62f1bab1e
    Mod Manager Scripts Folder: 0_1567840827196_upload-9b59a76d-f8d5-4567-8cd8-b998de841710

    Also I made a mistake in saying Open All Interiors, what I meant was OnlineInteriors which is a DLL. I've been very carefull that any of the mods I install I check their respective GitHub page to get the latest version.

    Added some of the logs I do have below as well...

    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\Windows\system32\dinput8.dll" => 00007FF8FFAD0000
    API: "DirectInput8Create" => 00007FF8FFAD9D40
    API: "DllCanUnloadNow" => 00007FF8FFAE9BD0
    API: "DllGetClassObject" => 00007FF8FFAE9CA0
    API: "DllRegisterServer" => 00007FF8FFAF3990
    API: "DllUnregisterServer" => 00007FF8FFAF3C00
    LOADER: Loading *.asi plugins
    ASI: Loading "G:\SteamLibrary\steamapps\common\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FF921280000
    ASI: Loading "G:\SteamLibrary\steamapps\common\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" => 00007FF922D30000
    ASI: Loading "G:\SteamLibrary\steamapps\common\Grand Theft Auto V\TrainerV.asi"
    "TrainerV.asi" => 00007FF8CC3E0000
    LOADER: Finished loading *.asi plugins

    // GTA V SCRIPT HOOK (build Jul 27 2019, v1.0.1737.0)
    // (C) Alexander Blade 2015-2019
    [03:35:48] INIT: Started
    [03:35:48] INIT: Success, game version is VER_1_0_1737_0_STEAM
    [03:35:48] INIT: Registering script 'ScriptHookVDotNet.asi' (0x00007FF922D31390)
    [03:35:48] INIT: Registering script 'TrainerV.asi' (0x00007FF8CC6D42B0)
    [03:35:57] INIT: Pool 1 extended
    [03:35:57] INIT: Pool 2 extended
    [03:35:57] INIT: Pool 3 extended
    [03:35:57] INIT: Pool 4 extended
    [03:36:02] INIT: GtaThread collection size 189
    [03:36:02] INIT: wnd proc 0x00000000FFFF0637
    [03:36:02] INIT: IDXGISwapChain 0x00007FF924C5EC80 (0x00007FF924BF5070)
    [03:36:02] INIT: IDXGISwapChain set
    [03:36:02] INIT: DX init started
    [03:36:02] INIT: DX feature level B000
    [03:36:02] INIT: DX init succeeded
    [03:36:47] CORE: Requesting thread creation
    [03:36:47] CORE: Creating threads
    [03:36:48] CORE: Started control thread, id 31 active 1
    [03:36:48] CORE: Started thread 'ScriptHookVDotNet.asi' (0x00007FF922D31390), id 32 active 1
    [03:36:48] CORE: Started thread 'TrainerV.asi' (0x00007FF8CC6D42B0), id 33 active 1
    [03:36:48] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FF922D31390), id 32
    [03:36:48] CORE: Launching main() for 'TrainerV.asi' (0x00007FF8CC6D42B0), id 33
    [03:36:49] INIT: Registering script 'ScriptHookVDotNet.dll' (0x00007FF8D49914A0)

  • @iSteiN Ok, first off, you actually need to install the Open All Interiors mod for the Online Interiors mod to work.

    Second, you are missing the Metadata.dll file from the Benny's mod in your scripts folder.

  • @chonkie Thanks again for your help! I did what you said and am actually getting somewhere now. When the game load I get this error though: 0_1567845776662_upload-3a292e50-dfa7-4fcf-8c08-4650b6e52751
    This error also shows up in the Script Hook V log.

    If I disable the openinteriors and onlineinteriors the error goes away, but Bennys mod still doesn't load.

  • Well I fixed the error by modifying my ini file carefully. Problem now is I still can't get Bennys mod to work properly.

  • @iSteiN That mod manager mods folder is throwing me off. Like everything that is in that folder should be in the gta root directory, but since things are loading it must be somewhat working, but maybe it has a bug with some things. The scripts folder should also be in the gta root directory. Maybe start over and try not using that mod manager and only install files that are necessary. Not sure if indeed they are causing the issue, but won't hurt to remove them. For example, to install ScriptHookVDotNet, all you need is the ScriptHookVDotNet.asi and ScriptHookVDotNet2.dll files in your game root directory, remove those other xml and pdb files and that ScriptHookVDotNet.dll.

    Benny's is a .net mod so it does need ScriptHookVDotNet to work, maybe having that extra ScriptHookVDotNet.dll is messing it up since it isn't supposed to be there. You said you did not have a SHVDN log file, but you should have one each time you start gta5, that's where you'll see Benny's loading or not.

    alt text

  • @iSteiN Here's pics of my root, mods, and scripts folders of how it should look in OpenIV when things are where they are supposed to go.

    alt text

    alt text

    alt text

  • @chonkie Hey, sorry for getting back to you so late. Was out of town for a couple of days. I know the mod manager folder is confusing, but essentially when the game runs that's how my files look (just like your GTA 5 game folder).

    I've narrowed down the reason I can't get some of these script mods to work is because when I enable the MP map in the ini, that's when I get the ScriptHookV error message.

    For no I've sort of just given up on any script mods. If you have any ideas what could prevent me from running the MP map, I'm all ears though. I know this is required in order to run the benny's mod and a lot of the other mods.

    Thanks again Chonkie, I do appreciate all the help.

  • @iSteiN Like I said before, try without that mod manager, maybe it is causing issues. Don't know, but why not remove a variable. Just use OpenIV, it's easy, probably easier than that mod manager. Also do indeed remove the unnecessary files. For example again, to install ScriptHookVDotNet, all you need is the ScriptHookVDotNet.asi and ScriptHookVDotNet2.dll files in your game root directory, remove those other xml and pdb files and that ScriptHookVDotNet.dll. Again, I'm not 100% sure if they are causing issues, but why not remove variables. I would really bet that having the old SHVDN.dll is the culprit. Don't give up on installing scripts, they are easy to install.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.