Log in to reply
 

Allowing game to use more RAM memory?



  • I think about the files as gameconfig and would like to hear from people who have experiences with editing these files if there is anything like limit of RAM memory usage?

    The reason is that game is slowly loading the textures (coz of using tons of mods) but it's using still not much of RAM memory. With opened chrome and few other programs it still don't go over 8-10GB of RAM usage, aswell CPU is about 40% usage, just GPU is jumping from 20 to 90%.

    Is the slow loading of textures due to graphic card or is the game using RAM for it? If it's using RAM, do you think it's possible to let game use more memory and use most of your computer power to load even on Ultra with tons of mods as fast as without mods? :thinking:

    Aswell when we speaking about this, what is your 'Advanced Graphics' settings? Do you have any of them on? I'm wondering for what is using 'Frame Scaling Mode' coz I experienced it start using 4GB of RAM more but it change whole graphic for not good one and start ultra lagging, even that I can't change that settings back :D


  • MODERATOR

    Slow loading of game assets could be because of your hard drive. Do you have an HDD or an SSD? SSD's are much faster.



  • @Jitnaught GTA is installed on SSD with system to make it load faster, have 134GB left on it, should be enough or?


  • MODERATOR

    @ArmaniAdnr Sounds good; should be enough. Don't know why that happens for you then, that was my only guess.



  • @Jitnaught I think it's simply just coz I replaced too much files what makes size of loading items a much bigger. I just wonder why the game don't use more RAM to load it all in real time when I have enough not used RAM. :confused:



  • @ArmaniAdnr Make sure you have the heap adjuster. Set heap to 700. In your gameconfig, scroll down until you find physical and virtual streaming buffer. Change values from 252 to 756 and 1000 to 3000 respectively. Boot up your game, and try again.



  • I think I have dealt with an identical request on the LSPDFR forums... was that you @ArmaniAdnr? :smirk:

    You can't force the game to use more RAM memory. Maybe with some heavy tweaking but I don't know.

    The reason for that is simple - any program uses only as much resources as it needs to operate at "nominal" power.

    If you force your game to use more RAM it will nothing but reduce your performance, since your system will be running at peak capacity. From there, it is a short walk to throttling and crashing.



  • Slow loading of the game could be because of the hard drive. Try using a faster SSD.



  • @eshenk I have heapadjuster, but it's only 'asi' file, how can I set heap to 700?

    Base config. which applies to all paltforms and builds is set up like this

    <ConfigStreamingEngine>
    <ArchiveCount value="1406"/>
    <PhysicalStreamingBuffer value="350000"/>
    <VirtualStreamingBuffer value="0"/>
    </ConfigStreamingEngine>

    PC configurations overrides are set up like this

    <ConfigStreamingEngine>
    <PhysicalStreamingBuffer value="58"/>
    <VirtualStreamingBuffer value="1000"/>
    </ConfigStreamingEngine>
    </Config>
    </Item>
    <Item>
    <Build>any</Build>
    <Platforms>durango</Platforms>
    <Config type="CGameConfig">
    <ConfigStreamingEngine>
    <PhysicalStreamingBuffer value="2304"/>
    <VirtualStreamingBuffer value="0"/>
    </ConfigStreamingEngine>
    <Threads>

    </Entries>
    </PoolSizes>
    <ConfigStreamingEngine>
    <PhysicalStreamingBuffer value="2304"/>
    <VirtualStreamingBuffer value="0"/>
    </ConfigStreamingEngine>

    So just <ConfigStreamingEngine> values or all of them to the same values? :thinking:

    @TheMurderousCricket no it wasn't me :smirk: but when the game is not loading files as fast as before using mods (which I understand that it makes size of files a much bigger), and is not on PC power limits, there have to be set up some limits or anything like that don't you think? :thinking: I can't find out what else could be limiting loading speed, do you have any other ideas what to check and try? :see_no_evil:

    @Petrary I have no idea which SSD is used in MSI GT75 8SG Titan, so don't know for which SSD look for to choose faster one :frowning:


  • MODERATOR

    Maybe related, maybe not

    But for some reason, since a month or two I'm also experiencing slower loading (than before) of World at game start
    most noticeable when you teleport to a new location

    After that, my game is stable, running a shit ton of mods, scripts, dlcpacks (excluding Add-On maps) etc
    Just its initial load seems slow.

    Unrelated to HDD vs SSD as I've always ran the game from my WD 3TB Black 7200rpm
    Disc itself is healthy

    • using @eshenk suggestions on streaming buffers makes for no changes;
    • flushing settings.xml and pcsettings_bin and savegames all together makes for no changes;
    • alterations to Win10's size or location of the swap file (virtual memory) makes for no changes.

    So at this point I'm suspecting either a newly imported mod or script
    Or a bug infestation :)



  • @ReNNie hmm, for me it's not only start up loading coz I tested it to go in the field with vehicle which have highend textures in _hi.yft file and it loaded immediately, but in city, where are tons of other textures to load, it don't want to load or load after one two minutes :confounded: as you wrote using teleport make you wait a few more sec to load whole world around you, even playing missions make loading a slower than playing open world out of missions.

    I take care on used mods to be fully working with LOD and other assets to avoid bugs so I know it should not to be problem of any used mod. Maybe just some pack used as base as LA billboards or WOV which I think are stable or? My mods folder with copied all folders have still under 100GB so it's not so much to make problems I think.

    Also defragmented for sure and using new dlcpack folder for replaced vehicles to don't make vanilla folders too big at the point for example x64e which contains most vehicles have almost 3GB so placing mods there should cause making it over limit which is if I remember good around 3.4 GB. Aswell these my dlcpacks I keep under 2GB, better to make new one as going over 2GB of files in there.



  • @ArmaniAdnr - This may very well be a very trivial thing - a need for maintenance.

    About 8 months after each maintenance, I also experience slowdowns. It's almost exclusively related to dirt (or bug infestation as @ReNNie puts it) and thermal grease being worn out.

    This results in clogged air ducts and some parts being overheated. I learned the hard way (after three GTA reinstalls, countless dxdiags etc.) that replacing thermal grease (i.e. cooling) works wonders for one's machine.

    If you kept using your computer at high output and never bothered to replace thermal grease or cleaned it inside, you might simply be getting slight performance deterioration because of that. However, I cannot tell for sure because, obviously, I have no idea when you bought your machine and how you care for it.

    Summing it up, even the best and strongest machine is bound to fail if it is not properly maintained in a physical sense. If all else fails, you may as well take your computer to a service stand and ask them to patch it up.



  • @TheMurderousCricket I just bought this Titan about one - one and half month ago. During opening GTA for more than 5 minute test I always turn on fan boost which this notebook have (it's loud af 50-60dBA but who cares lmao). Do you think it already need maintenance due to my high performance work?



  • Naaah. Than it's certainly not the case here. Even if you had played GTA each day throughout that entire month.

    If you feel your computer is not running as it should, then it has to either be a software or hardware problem, but I'm afraid I can't help you with that.

    As far as the overheating (or, in its most extreme case, thermal throtling) is concerned you'd normally want to renew cooling and thermal grease every 12 - 15 months. I do it each spring as ideally, you want to have your cooling at its best when it gets warm outside.



  • @TheMurderousCricket thanks anyway, would keep eye on it and do it after some time, also contacted saler if they do it for me when I would need it to don't lose warranty (on MSI I need keep warranty for sure :D )



  • MSI, eh? Me too. ๐Ÿ˜ƒ Good equipment. Though very limited support in my country. So one point in the future I'll probably be switching to Dell.



  • @TheMurderousCricket same, bought it just coz at this time it was only notebook with 4K screen. My cousin from Dell told me they had MSI motherboards few years ago and he never want to see it again lmao waiting for alienware with RTX and 4K screen then will swap it for sure :ok_hand_tone3:



  • Yeaaah... Regardless of how much one likes their computer I think, nonetheless, that Dell's Alienware series is a king...

    I just wonder how it would handle my CG projects. But I guess it would just blaze right through them!


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.