Log in to reply

OPENIV Problems

  • Well, hallo again.

    I Already made a Thread about my Problem but now it seems that i know, which problem causes those crashes. I Tried it just now, to be Sure that there is no Problem with a mod, i´ve installed this mod in my gta 5 Vanilla Game on my Laptop. Well, it seems that there is no Problem with that mod, rather with those ASI Plugin´s OpenIV uses. Everytime I´m installing those Plugins thanks to the ASI Manager in OpenIV, the game lasts 20-30 Minutes and crashes. If i´m closing the game right on the spot (Regardless of the situation... so it happens in the "Guide Menü" for Single and Multiplayer and also in Singleplayer Mode), it always crashes. First, i thought that the Problems are because of GTA 5 Revive.... but it seems, after installaing and uninstalling those ASI Plugins, the game works extremly Smooth without any problem, no crashes or anything like that. Does anyone have a clue what causes the problem? Don´t know how long it will take for the OpenIV Publisher to be able to fix that problem (The last OpenIV Update seems to be BEFORE the last Launcher and the Launcher already got a update few days later) and before i´m going into the hospital, i want my Laptop GTA 5 to be able to mod and play without Problems :D

  • @Deathmatic OpenIV isn't the issue. The asi loader is just a tool that loads asi files, the asi plug in loads modded rpfs. If it loads a bad mod, that's where you have issues, with whatever mods you have installed. If you remove the asi loader(dinput8.dll), then mods aren't loading, it's just the vanilla game, that's why it's running smooth then.

    You're the only person seeming to have an issue with OpenIV, if there were an issue with it, there would be a lot more posts about it.

  • @chonkie I can´t make a Vanilla out of a freshly downloaded Vanilla Game, though. I´ve Installed GTA 5 COMPLETELY, fresh and within a lot of disturbing, nerv wrecking hours because of my Bad wlan BUT after around 18 hours (Shoud have used LAN over night, would have been 4 hours). I´ve installed OpenIV and the ASI Plugins, Scripthook, obviously and Community Scripthook. I´ve placed a mod and Script Folder BUT never used a mod. After TESTING one mod and getting a Crash, i´ve deleted x64w and "update" out of the Mod Folder and copied one freshly out of the original Vanilla Game download. I´ve tried to use it but thought "Shit, wanted to do something", closed it and it said "GTA 5 ended unexpectedly" (in German of course) so i tested it. EVERYTHING was in Vanilla, the complete GTA 5 Folder was UNTOUCHED, i´ve deleted modded folder like x64w completely und copied it anew from the Vanilla: Every time i´m deleting the ASI Plugins: It works just fine. And everytime i´m INSTALLING those... it crashes after 20 Minutes. And like i repeatedly said... ALL in Vanilla. And that dinput Problem was also the case after the new Launcher first. Even after i´ve installed GTA 5, sadly, anew with that crappy Launcher, after putting dinbut in the Vanilla folder, it crashed instantly (Not like now)... So, if OpenIV isn´t the issue, what then? And no, no mod, Script or something, it is completely PURE Vanilla :)

  • @Deathmatic What mod did you try to test? Could you provide screenshots of your folders Vanilla and after you start modding it. Maybe you're possibly putting something somewhere incorrectly.

  • @chonkie It was only one replacement car, which i had a backup of all files, obviously. My question: Of what exactly should i make a Screenshot. My Folder looks completely the Same like yours. I´ve deleted Script and Mod Folder, only have installed both Scripthook Versions and OpenIV WITHOUT the ASI Plugins atm. SO there CAN´T be ANY mod left.

    So i Tried to find out, wich plugin is causing the Problem... it is the ASI Loader. Yesterday uninstalled GTA 5 and Installed it from the scratch. No Mod Folder, no Script Folder, like i said: Really Vanilla. Installed the middle ASI Plugin from OpenIV. NO Problem. Installed ASI Loader and game crashed. started the game but didn´t go into the solo mode, just ended it right away and there was the crash information...

  • @Deathmatic Screenshots of main directory, then mods folder is what I was wanting to see.
    Don't assume your folder is going to look like mine.

    Don't know about what else could be wrong. Plus I can't reproduce the issue. I would just have to guess it's either still user error, or something else is wrong with your computer. Maybe the windows update messed yours up. Notice how you are the ONLY person having an issue with just OpenIV. I would think it to be really odd that openiv.asi and dinput8.dll would cause crashes for just you.

  • @chonkie Well, correct. But also correct: A LOT of people got a Launcher Bypass, while i´m updated that crappy launcher the the newest Version... therefore there were a lot of people with problem like that. I´m installing it right now from anew, if everything is ready, i will show you a screen of my main directory... i won´t place a mod folder... or won´t cope any data into it, at least because the mod folder will be generated through OpenIV either way. In about 2 hours, i could be able to make a screen.

  • @chonkie So, I´ve tried it with a new Clean download.... And i´m greatly embarassed, because that´s the first time but after that Clean Installation, it worked, I think that the Reason was a wrong installed GTA 5 REVIVE Mod or that the Mod isn´t working for that Version (Likely to see that the Roads are disapperaing after getting near enough, leaving behind the Vanilla road instead the modded one).

  • @Deathmatic The Road disappearing, i had this with another mod. But i couldn't configure out which one. Do you had any map mods installed? Business packs, Casino updates, extra buildings or areas?

    Ok, i see revive is a map mod which bring new probs too.
    Found this tutorial. It's for the policemod but there are some tweaks in the graphic options you can do, for the missing textures.

  • @Deathmatic Glad to see you got it figured out and the game is working now.

  • @Justme2000 Not quite right, the MODDED Map is disappearing, leaving behind the ordinary, vanilla Streets, not a complete Streetless City or Something and it is clearly a Mod Problem, not a Problem on either one of my computers ^^ So that Tutorial won´t help me, the modder already said that it looks like he forgot to overrite the Vanilla texture of the roads^^

    @chonkie Sadly, i´ve found the real problem now for good... it is Scripthook, it seems that Scripthook was rushed, therefore crashing the game. It only need: Vanilla Game and: Scripthook. Get into the game but don´t go on either Singeplayer or Multiplayer, that´s far enough to encounter the crash... just ending it in the decision Menu is enough. After Ending the Game, it crashes. My Opinion: After that patch and everyone crying in agony for a new version, the Modder of Scripthook V rushed it a little bit, so right know, regardless of existing mods or Scripts, it is only Scripthook which is crashing the game. I don´t know which is causing the Problem exactly. It COULD be the "He has rushed" argument OR it could be the Problem with the dinput8 file, which contained in OpenIV as well as in Scripthook

  • @Deathmatic Scripthook wasn't rushed. It isn't your issue. It works perfectly fine since it got updated to match Rockstar's update of the game. People only complain about ScriptHook not working on here when there is an update because they are clueless.

    I, like many others, do not have issues with ScriptHook or openiv. I think you are making errors when installing stuff and you are also trying to use a mod that is bad and when you think you remove it you don't remove it completely so it still causes issues.

    Also, just tested a theory, and each time I've manually quit the game from finishing loading, it says that it exited unexpectedly. That isn't a crash, it's the game not realizing that you're the one that closed it before it was finished loading. It even gave me that message on a 100% vanilla game just now.

    If you can't get the simple basics to work, start looking towards other pc related issues, maybe gpu driver, windows update issues, etc.

  • @chonkie Your Issue is simply the same like me, tried to search for it but couldn´t find a satisfying solution or even an Answer. Your Answer sounds simple, try to delete Scripthook before starting the game and Close it, it will be closed perfectly. I´ve got GTA 5 on PC and Laptop, my Laptop is my Mod Testing GTA 5, if there are Errors, i try to search by installing Mods one after another, testing also one after another. This Folder is COMPLETELY Script-Free, because Testing Scripts is way to easy, simply put it outside the main Folder/Script Folder to search for a problem. First tried it on GTA 5... deleted every File, except for Common, x64, Update and x64a - w. Installed Scrippthook, Scripthook NET and simple Trainer one after another, slowly, even putting craps like those links into the folder. Game said, after Ending, that it exited unexpectedly. ON LAPTOP, so NO Script, even no mods anymore after deleting the Mods Folder and i NEVER EVER use the original File with OpenIV. Deleted Scripthook, worked perfectly. If that´s true what you said, than it should only "crash" after exiting the game... therefore there is a interference or something like that, which causes GTA 5 to think that it wasn´t loaded fully, even tough i, once, used to let it open for, about... 30 Minutes and was causing the same problem... Well, last time it REALLY crashed after 20 Minutes, even tough every mod so far, worked also on my laptop. It is sad that there is no diagnosis tool for finding defected mod files....

  • @chonkie said in OPENIV Problems: "If you can't get the simple basics to work, start looking towards other pc related issues, maybe gpu driver, windows update issues, etc."

    You didn't mention the same error as these people had, but at least they were seemingly having similar issues as you are experiencing with OpenIV appearing to not work for you.


    And fyi, you don't need to copy over every x64a through x64w folder. You'll only need to copy those over when something inside one of them gets modified, and then you only copy over the folder that actually has it's files modified.

  • @Deathmatic
    Just for note: My game crashes too after closing it. But i ignored it.
    It could be that this problem has nothing to do with your current one (the ingame crashes and flickering).

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.