Log in to reply
 

JulioNIB's Spiderman ScripthookV errors



  • In GTA V I try to load up script (Spiderman Mod) but when I click okay, I get MissingMethodExeption and Unhandled exeption error. After that the game works normally but i cant use that mod. PLZ help!!!

    I have every updated version of the game and files
    No script mod works
    Im trying the spiderman one RN
    This is the ScripthookV.net log-
    Pictures-https://docs.google.com/document/d/1FH_62aLE67MIu2Iw_qiW99py6olzeJWTH0gVUKd6dMY/edit

    [00:23:37] [DEBUG] Loading API from .\ScriptHookVDotNet2.dll ...
    [00:23:37] [DEBUG] Loading API from .\ScriptHookVDotNet3.dll ...
    [00:23:37] [DEBUG] Loading scripts from D:\CHRIS\SteamLibrary\steamapps\common\Grand Theft Auto V\scripts ...
    [00:23:37] [DEBUG] Loading assembly DirectShowLib-2005.dll ...
    [00:23:37] [INFO] Found 0 script(s) in DirectShowLib-2005.dll.
    [00:23:37] [DEBUG] Loading assembly NativeUI.dll ...
    [00:23:37] [INFO] Found 1 script(s) in NativeUI.dll resolved to API 2.10.12.
    [00:23:37] [DEBUG] Loading assembly NAudio.dll ...
    [00:23:37] [INFO] Found 0 script(s) in NAudio.dll.
    [00:23:37] [DEBUG] Loading assembly PedSelector.dll ...
    [00:23:37] [INFO] Found 1 script(s) in PedSelector.dll resolved to API 2.10.12.
    [00:23:37] [DEBUG] Loading assembly ScriptCommunicator.dll ...
    [00:23:37] [INFO] Found 1 script(s) in ScriptCommunicator.dll resolved to API 2.10.12.
    [00:23:37] [DEBUG] Loading assembly spiderman.net.dll ...
    [00:23:37] [INFO] Found 6 script(s) in spiderman.net.dll resolved to API 2.10.12.
    [00:23:37] [DEBUG] Instantiating script NativeUI.BigMessageThread ...
    [00:23:37] [INFO] Started script NativeUI.BigMessageThread.
    [00:23:37] [DEBUG] Instantiating script PedSelector.PedSelector ...
    [00:23:39] [INFO] Started script PedSelector.PedSelector.
    [00:23:39] [DEBUG] Instantiating script ScriptCommunicator.ScriptCommunicator ...
    [00:23:39] [INFO] Started script ScriptCommunicator.ScriptCommunicator.
    [00:23:39] [DEBUG] Instantiating script SpiderMan.PlayerController ...
    [00:23:39] [INFO] Started script SpiderMan.PlayerController.
    [00:23:39] [DEBUG] Instantiating script SpiderMan.ScriptThreads.AnimHelper ...
    [00:23:39] [INFO] Started script SpiderMan.ScriptThreads.AnimHelper.
    [00:23:39] [DEBUG] Instantiating script SpiderMan.ScriptThreads.BackgroundThread ...
    [00:23:39] [INFO] Started script SpiderMan.ScriptThreads.BackgroundThread.
    [00:23:39] [DEBUG] Instantiating script SpiderMan.ScriptThreads.Controls ...
    [00:23:39] [INFO] Started script SpiderMan.ScriptThreads.Controls.
    [00:23:39] [DEBUG] Instantiating script SpiderMan.ScriptThreads.SpideySense ...
    [00:23:39] [INFO] Started script SpiderMan.ScriptThreads.SpideySense.
    [00:23:39] [DEBUG] Instantiating script SpiderMan.ScriptThreads.Time ...
    [00:23:39] [INFO] Started script SpiderMan.ScriptThreads.Time.
    ![[00:23:58] [ERROR] Caught fatal unhandled exception:](image url)
    System.MissingMethodException: Method not found: 'GTA.Math.Vector3 GTA.Math.Quaternion.op_Multiply(GTA.Math.Quaternion, GTA.Math.Vector3)'.
    at SpiderMan.ProfileSystem.SpiderManScript.SpiderManProfile.GetCameraDirection()
    at SpiderMan.Abilities.SpecialAbilities.Melee.<>c__DisplayClass19_0.<IsAttackable>b__0(Entity x)
    at System.Linq.Enumerable.WhereEnumerableIterator1.MoveNext() at System.Collections.Generic.List1..ctor(IEnumerable1 collection) at System.Linq.Enumerable.ToList[TSource](IEnumerable1 source)
    at SpiderMan.Abilities.SpecialAbilities.Melee.GetClosestTarget(Single radius, Single angle)
    at SpiderMan.Abilities.SpecialAbilities.Melee.Attack()
    at SpiderMan.Abilities.SpecialAbilities.Melee.Update()
    at SpiderMan.PlayerController.UpdateAbilities()
    at SpiderMan.PlayerController.OnTick(Object sender, EventArgs e)
    at SHVDN.Script.MainLoop()
    [00:23:58] [ERROR] The exception was thrown while executing the script SpiderMan.PlayerController.
    [00:23:58] [WARNING] Aborted script SpiderMan.PlayerController.

    Someone help me

    // edit ReN : topic title change



  • i have the same problem and i have tried everything to make it work but it keeps failing.



  • It is a ScriptHookVDotNet bug: https://github.com/crosire/scripthookvdotnet/issues/904

    This issue can be fixed on the ScriptHookVDotNet side, by implementing the operator mentioned in the issue, or JulioNIB can implement the operator in his mod.



  • So what specifically can I do to get rid of this error? And if not, are there any mods i can use.



  • The ScriptHookVDotNet bug has been fixed. You can download the automatic build from here: https://ci.appveyor.com/project/crosire/scripthookvdotnet/build/artifacts

    Your options are: use the automatic build; wait for the next release of ScriptHookVDotNet; or downgrade to 2.10.10.



  • What would you recommend and wont downgrading versions give me an error too



  • I recommend trying the automatic build. Just download the bin/ScriptHookVDotNet.zip file from that link I posted above, then install like normal.

    Downgrading might not give you errors. It depends on the scripts you have installed. If you have scripts installed that specifically use SHVDN v3, which was released only a few months ago, then you would get errors.



  • I tried it now and i can run the mod but now the game crashes if i move too quickly in the game



  • my game is working great now. thnx


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.