Log in to reply

Scripthook/dinput8 being ignored by game? Game loads without mods

  • Hi all,

    When I launch GTA 5, through Steam or through the launcher, it launches and plays fine without any crashes or errors, but no mods work. No trainers, no OpenIV mods, nothing. I am able to get some mods to work using RAGEPluginHook and its beta ASI loader, but that doesn't enable OpenIV's mods folder to work at all (ASI Support For RAGE Plugin Hook: [22:50:15] [INFO] Skipping "OpenIV" as it is not a ScriptHookV script.).

    I already have:

    • GTA 5 1.0.1868.0 on Steam
    • ScriptHookV.dll for 1.0.1868.0 in the same directory as GTA5.exe
    • dinput8.dll (I've tried the one that comes with ScriptHook, and the one OpenIV installs) also in the same directory as GTA5.exe
    • OpenIV 3.2
    • Visual C++ Redistributable Packages 2013, 2015, 2017, and 2019
    • .NET Framework 4.8
    • Latest DirectX

    I've tried completely reinstalling GTA 5, and only installing ScripthookV.dll, dinput8.dll and NativeTrainer.asi, and even then the trainer doesn't load. To me, it seems like the game is ignoring the Scripthook/dinput dlls, even though they're in the right place. I've previously had GTA V installed on this PC, and had no trouble then, so I'm at a complete loss here.

  • Did you install the ASI loader with OpenIV?

  • dinput8.dll is the ASI loader, so yes I've tried both Scripthook's and OpenIV's, and neither works.

  • I'm having this same issue, game launches but without any mods or anything loaded in. Not even scripts are working. I do have to use a launcher-bypass because otherwise the game doesn't even load, it's constantly asking me to log in, and then fails.

  • Having a somewhat similar problem. First, the game had me download an update for about 870MB+, but I've seen no word about an update. I'm on PC and don't play online. Now when loading a map from menyoo, not long after I see a large spike in cpu activity and a major fps drop. Mods load okay, but that once that frame spike hits the game shuts down shortly after. I've got the most recent config in, I turned off peds and traffic and all critical mods have been updated. Recent mods I put in have worked just fine until now. When I checked the task manager for processes, I saw eight 'Social Club' processes running all at once! Exactly how many are required since I don't access it at all? I swear, I never had this much trouble before they put that new launcher in.

  • EDIT:
    I may have found the problem. I have multiple GTAV folders, so that when I mod GTAV, it doesn't screw up anything for Online for me. This seems to be the problem, I haven't fully tested it yet but it seems when I launch GTAV from my modded folder, it's still actually loading the game from my original GTAV folder, not the modded one, thanks to the new Rockstar Launcher which appears to always want to launch from the steam directory instead of where I'm actually launching the game from. Of course this is for the steam version only. @celediel do you have multiple folders?

    The test that came from this that I personally did, was just to simply install an ENB, when the game launched it wasn't even loaded and that doesn't need anything to load. So this is probably the reason why dinput8 and scripthooks don't appear to be working, at least for me, because its not even launching the game from the right directory. I have no fix for this currently unless you just mod your original GTA folder. There is currently no LauncherByPass mod that fixes this.

  • Nope, I've only got one GTA folder. I don't do multiplayer, so I didn't bother trying to keep Online working. My game isn't installed on the C: drive, but at "D:\Steam\steamapps\common\Grand Theft Auto V" instead. Maybe I'll reinstall the game on the C: drive and see if that makes a difference.

    edit: wt actual f, that actually fixed it....

    Don't install GTA V on non-C drives, I guess.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.