Log in to reply

Very strange water bug...

  • Hey, I'm running the latest version of GTA V on Steam (not sure how to check what it is though), and I have come across a strange bug as of recently. The water on the map, the oceans, rivers, etc. are all flat, like 100% flat, and due to that it's like I'm looking at a mirror or something and it looks weird. No idea what's causing it, with my scripthook and everything disabled I still get it. I've tried changing my timecycle files in update.rpf with vanilla ones, because I had a mod that removes lens distortion and chromatic aberration, and it didn't fix it. It's recent when I noticed this. I'm unsure of what is causing it. I was wondering if anyone else has had this problem and if anyone might be familiar with what file can create this bug. If it helps at all I also have a lot of add-on vehicles, but I haven't gotten any more as of recently, and before then the water was fine. Also Verified Cache and it didn't find anything, all files validated successfully.

    Sorry if this information isn't helpful, I'm just trying to go off what I know and what I've been able to find out.


    try replacing weather.xml with vanilla too, iirc that affects waves

  • I will try that later, and maybe send a screenshot too if I can.

  • It didn't fix it.
    alt text

  • Not to mention it literally affects water everyone on the map. The rivers are flat and shiny, too, it doesn't even have waves, the only "waves" are the fake streaks that like go up against the rocks to show that its flowing.

  • Water.xml?

  • @HeySlickThatsMe said in Very strange water bug...:


    Already tried it. Wasn't it.

  • This post is deleted!

  • @mrwallace888
    Work through this & see where it gets you :thumbsup:

    'Water' Files Approach:
    Quick (if it works), relies on a bit of luck, doesn't eliminate corruption as a cause:

    After making backups of the mod folder '.rpf's they are contained in, try replacing these files with their vanilla counterparts from the game folder:

    Use 'Ctrl+F3' in OpenIV to search for them by name (there's a search box drop down to select mods/game/both as the search criteria).

    • graphics.ytd
    • water.ytd
    • All water related shaders in 'update.rpf' 'win32_40_final' folder
    • watertune.xml
    • water.dat
    • waterheight.dat

    Diagnostic Approach:
    More time consuming, better chance of full solution, eliminates corruption:

    Try this to see if you can pinpoint what '.rpf' the problem resides in:

    • Make a backup of your 'mods' folder 'update.rpf' & also 'common.rpf' (most likely problem in one of these).
    • Then replace one of them at a time with a vanilla one from the game folder.
    • Load game & check if issue resolved.

    That will hopefully narrow the search down to a particular '.rpf'

    From there (if it fixes it) you either rebuild what you had installed previously using the working vanilla '.rpf's as a base or you swap back to the modded '.rpf' archive/s & hunt further for the culprit (rebuilding is probably easier in most cases, less time consuming & eliminates possible corruption as a cause).

    Do the rebuild in stages if taking files from the old archives, loading the game & checking after each, so that you don't reintroduce the issue. :thumbsup:

  • @a63nt-5m1th Huh... it's actually neither... common.rpf nor update.rpf... vanilla files and unloading the OpenIV modloader thing doesn't fix it... hmm... this is a very weird bug indeed.

  • @mrwallace888
    Hmmm?! Yes, weird indeed :confused:.


    Presumably, defaulting 'update.rpf' would have removed all your add-ons (ie vanilla 'dlclist.xml')?
    If so, they can be removed as a possible cause too.

    Have you tested removing/renaming 'scripts' folder (if you have any scripts installed)?

    Do you have a copy of all the '.rpf' archives ('update.rpf', 'common.rpf', 'x64a>x64w.rpf') in the game folder also residing in the 'mods' folder or only select ones?

    Any overclocking of CPU/RAM/GPU?

    A few ideas:

    Try uninstalling your GPU driver using Display Driver Uninstaller (works for both Nvidia & AMD/ATI) & then reinstall the latest driver.

    Still no solution, then check to see if it still happens with the 'mods' folder removed/renamed (I know you've done the modloader thing, but try this anyway. It's only a simple rename of the folder & one load of the game).

    If still having issues after all that it would tend to suggest the issue is within your game folder or OS.

    Let me know how you get on with all that anyway & we'll take it from there :thumbsup:

  • @a63nt-5m1th Okay for f---'s sake, I figured out what it was. And it's the stupidest reason. Just listen to this.

    It was a script. More specifically, in my Enhanced Native Trainer, I had it set to "No Waves" in the weather options. THAT'S what it was...

    Oh my God! I went through all this trouble, trying to figure out what the actual f--- is wrong my game, only to realize it was just a setting I had. God dammit... That's just depressing... Welp, least I figured it out now lmao. Only took me like forever. I feel so stupid now for overseeing this.

  • Where do the vehicle mods spawn

  • @mrwallace888
    I missed that too (& I'm supposed to know what I am doing?! :disappointed: lol).
    One day I'll actually have to look at the settings/options in Trainers so I don't miss the simple stuff :thumbsup:
    Glad you got it fixed anyway, the solution is all that matters at the end of the day :slight_smile: :thumbsup:

    That's a very broad question, but generally, a replacement vehicle will spawn on the streets just like the vehicle it replaces did & an add-on vehicle require a trainer to spawn it. Create your own thread with more specifics & you'll undoubtedly get a more detailed answer :thumbsup:

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.