Log in to reply
 

Scripthook/ASI Loader won't work at all?



  • Ive installed both multiple times, tried multiple trainers, none of them fucking work. Created a second GTA V folder, to have an online vanilla one, and Im trying to mod the other one, obviously. Meant for SP. Its just not working and Im losing my fucking patience.



  • @Guapp

    make sure you have a clean Grand theft auto 5 folder.
    make sure you have updated to the latest version and no mods installed.

    Step1.
    https://www.gta5-mods.com/tools/script-hook-v
    dinput & scripthook to gta 5 location where gta5.exe is.

    step2.
    https://www.gta5-mods.com/scripts/simple-trainer-for-gtav
    copy 2 file's to gta 5 location where gta5.exe is.

    step 3 start game press F4



  • Thats exactly what I did. It's just not working. Tried some other ASI mods now, they won't work either.



  • @Guapp

    Then you are probaly missing some file's redownload the game/file's



  • Bro. The game works perfectly. This is the copy of the vanilla folder, I just copied it like 30 mins ago.



  • @Guapp

    It's not my fault your game mods aren't working.
    mine are working with a lot of everything.

    you messed up somewhere somehow.



  • I literally only copied the fucking scripthook including the asi and trainer into my game's directory. That was it.



  • I got the RGSC version. I launch it through a desktop shortcut with
    "D:\Program Files\Grand Theft Auto V\GTAVLauncher.exe" -scOfflineOnly
    if that makes any difference?
    Also, OpenIV says the ASIloader is installed



  • @Guapp

    // (C) Alexander Blade 2015
    LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FFDE4750000
    API: "DirectInput8Create" => 00007FFDE475A050
    API: "DllCanUnloadNow" => 00007FFDE47693C0
    API: "DllGetClassObject" => 00007FFDE4769490
    API: "DllRegisterServer" => 00007FFDE4772AF0
    API: "DllUnregisterServer" => 00007FFDE4772D70
    LOADER: Loading *.asi plugins
    ASI: Loading "D:\Program Files\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FFDE7840000
    ASI: Loading "D:\Program Files\Grand Theft Auto V\TrainerV.asi"
    "TrainerV.asi" => 00007FFDC6130000
    ASI: Loading "D:\Program Files\Grand Theft Auto V\vehicle cannon.asi"
    "vehicle cannon.asi" => 00007FFDE55C0000
    LOADER: Finished loading *.asi plugins

    // GTA V SCRIPT HOOK (build Oct 5 2016, v1.0.877.1)
    // (C) Alexander Blade 2015-2016
    [16:37:23] INIT: Started
    [16:37:23] INIT: Success, game version is VER_1_0_877_1_NOSTEAM
    [16:37:23] INIT: Registering script 'TrainerV.asi' (0x00007FFDC626C560)
    [16:37:23] INIT: Registering script 'vehicle cannon.asi' (0x00007FFDE55C22A0)

    It basically says its working, but in the game nothing happens when I press any of the hotkeys.



  • @Guapp Scripthook + dinput.
    and 2 file's from simple trainer.



  • @yeahhmonkey Yes. The .asi and the config file. And as u see what I posted up there, those come from the dinput and scriphook text documents, basically saying it loads and stuff

    Also just verified game files over the RGSC launcher, they're perfectly fine.



  • Found the issue. Opened Task manager, and went on properties on the running GTA V. It automatically opens the other one, thats in Program Files/Rockstar Games/Grand Theft Auto V, instead of the modded folder which is Program Files/Grand Theft Auto V. Even though the shortcut I run it through is connected to the modded folder?



  • so how did you make sure it opened your modded one instead?



  • I'm gunna try this task manger thing cuz ive had this same issue 4 times everything says its good but if its opening the original file everytime that sucks



  • i had this same issue for a damn month....thanks for that helpful thinking i am going to try this and then i'm going to do a video on it so at least for us new folks getting into gta5 modding....we can look for this..what was your fix for that



  • how'd you go @lazysatan ?



  • I know the topic is old, but I have the same issue, I'm launching the game from a moded folder, but when I go into task manager after launching the game from the moded folder and do right click and hit open file location, it shows me the vanilla folder.


  • MODERATOR

    @Tazeq_ If your modded folder is called something like Grand Theft Auto V - modded, or basically anything other than the original name, then it won't work.

    If you have two folders, the only one that will get used, is the one that matches the name of the folder that was originally installed. You have to rename the folders each time depending on which version you want to use.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.