Log in to reply

Scripthookv asi loader (dinput8.dll) not working probably.

  • Some quick info, running the latest version of gta v on steam as of the 15th of May 2020. Also this has been going on for a few days.


  • asiloader.txt file lines

    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FF9BC300000
    API: "DirectInput8Create" => 00007FF9BC308F80
    API: "DllCanUnloadNow" => 00007FF9BC319EB0
    API: "DllGetClassObject" => 00007FF9BC319F80
    API: "DllRegisterServer" => 00007FF9BC323CB0
    API: "DllUnregisterServer" => 00007FF9BC323F30
    LOADER: Loading *.asi plugins
    ASI: Loading "D:\steamey\steamapps\common\Grand Theft Auto V\els.asi"
    "els.asi" failed to load
    ASI: Loading "D:\steamey\steamapps\common\Grand Theft Auto V\LUA.asi"
    "LUA.asi" failed to load
    ASI: Loading "D:\steamey\steamapps\common\Grand Theft Auto V\openCameraV.asi"
    "openCameraV.asi" => 00007FF9BC220000
    ASI: Loading "D:\steamey\steamapps\common\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FF9A1920000
    ASI: Loading "D:\steamey\steamapps\common\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" failed to load
    ASI: Loading "D:\steamey\steamapps\common\Grand Theft Auto V\trainerv.asi"
    "trainerv.asi" failed to load
    LOADER: Finished loading *.asi plugins


    @RavenPlayz don’t tag me multiple times. have you tried reinstalling scripthook? what game version are you using? epic games, steam or retail?

  • I play on steam I have reinstalled it multiple times and the latest version.

  • I have tried reinstalling it multiple times and it just does not load try using els

    "els.asi" failed to load

    I don't know what to do its been like this for 2 weeks now.

    Please help, thanks.

  • What does your ScriptHookV.log file say?

  • Nvm @Jitnaught @Reacon (sorry for the pings)

    Found the issue. I kept replacing the openiv dinput8 with the script hook v one so it would work. Thanks for trying to help me.

    (mark this solved)

    From RavenPlayz

  • *would'nt

  • @RavenPlayz I'm sorry, but could you clarify. Did you or did you not use the dinput8 from script hook v? If you didn't which dinput8 did you use instead?

  • @RavenPlayz Dude, Frankovich asked a question. can you answer please?

  • @Maceika That thread is a year old. The file that comes with scripthook is the one to use. Not that is seems to matter but SH gets updated and OpenIV doesn't - but it doesn't seem dinput8.dll gets updated. The Microsoft version gets updated however.

    The OP was confused, wrongly thinking there were two versions, because OpenIV calls it the Asi Loader and SH has it as dinput8.dll,(aka Asi Loader). Either one however can disable your mods to play online - why? Because it's exactly the same file. Unless he was using a super old version of OpenIV and a new version of SH.

    If you delete dinput8.dll manually and then install it as Asi Loader from OpenIV it will be timestamped with the current date, giving you the impression of a newer file. It's not, it's the 2015 version.

    Alexander's Blade version (from 2015) works with the Windows 10 version (2019 on my build).

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.