Log in to reply

Scripthook Installation Isn’t Working

  • I’m using the latest Steam version. I’m just trying to get a simple trainer going, i.e. menyoo trainer. I’ve copied the Scripthook.dll and the dinput8.dll in the root directory. Before that I tried simple trainer and native trainer. They both didn’t work, so I tried menyoo trainer and that also didn’t work. I have a clean install on linux (proton 5.0-8). I have read a thread where a guy on linux did get the native trainer to work, so I wouldn’t directly jump to the conclusion that it’s just linux and therefore nothing works as intended. I don’t seem to have any logs in the game files. So, is it just that ScripthookV is outdated, or that i’ve done something else wrong?

  • How did you even install GTA V on a Linux computer? Scripthook needs Microsoft C++ to run and .Net Framework as well. Without those, the scripthook will never start. As far as I know, they aren't available in Linux.

  • @Algonquin1234 You can run GTA V on Linux via Wine, which is a Windows compatibility layer. He mentions Proton, which is an assortment of packages for Windows compatibility, like Wine and DXVK. Microsoft C++ Redistributable and .NET Framework also work via Wine/Proton.

    @Lord-Nearquaad As far as I know, modding doesn't work very well via Wine. Well, last I heard about it was March of 2019, so it may have changed. There is some incompatibility with some mods. I know Simple Trainer doesn't work, and Menyoo probably doesn't work as well. I heard the trainer that comes with Script Hook V works though.

  • @Jitnaught Really? I didn't know that. Well you learn something new everyday. What if he would to try the Microsoft virtual machine? You know where you could have a different type of Windows but it's installed in a program not the actual computer? He could have C++ installed and have GTA V installed on that too and have all the mods working through there.

  • @Algonquin1234 Virtual machines aren't good for gaming because they don't have direct access to the GPU. Unless you set up GPU passthrough, but I've heard that is a pain in the ass.

  • @Jitnaught If installing the trainer that comes with Scripthook is just copying all the files in the game directory, then it dosen’t work. So I guess Linux dosen’t work at all? Well, maybe there’s someone else who could help.

  • Do you have a ScriptHookV.log file in your game directory? If so, what does it say?

  • @Jitnaught Well, as I wrote in the first post, there are no log files I can find.

  • I missed that, sorry. My guess is that Wine is ignoring the dinput8.dll file (the ASI loader) and instead using the built-in version that Wine provides. I think there is a way to change that behaviour in Wine, but I don't know how.

  • I came across the same issue with Native trainer, when I wanted to use it.


    I found a solution!!!:grinning:

    I used this old ask Ubuntu thread: LINK

    Keep in mind: I did this on GTAV installed from the Epic Games Store through Lutris.


    • Install Script hook and Native trainer as you would do on windows

    • open the wine configuration of GTAV's wine prefix

    • go to libraries

    • In the New overreide for library field select dinput8 from the drop-down menu and clik add

    • Apply the changes and close the window

    Enjoy the trainer!!!

    I guess if you install any mod, that uses custom windows system dll (just as Script Hook does with dinput8.dll), you just need to repeat these instructions for that specific dll.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.